Showing results for 
Search instead for 
Did you mean: 

Contact Center Agent receiving Zoom Phone direct number calls


We are getting ready to go live with Contact Center/Zoom Phone and have run into an issue during our testing that I'm hoping has a solution:  All of our Contact Center Agents also have Zoom Phone direct inward number (DID) lines assigned to them, as well as a physical Polycom VVX 350 phone for their DID line.  When an agent is on an active Contact Center call, we are looking for a way for their Zoom Phone DID line to recognize that they are on a call such that the physical phone doesn't ring.  Is there a way to control this type of setup so that Zoom Phone would know that the agent is already on a call and not ring the phone?  This is causing an issue for us with headsets that get confused because they think that the user needs to answer the physical phone while engaged with the Contact Center call.  


Any help you can provide regarding settings to prevent this from occurring would be greatly appreciated!


Community Champion | Customer
Community Champion | Customer

Hello @CUExec 

The "Presence" information between ZP and ZCC marks as busy a ZP when the same user is engaged in a call as a ZCC Agent; I have tested that and it works as designed sending the call to Voicemail if somebody calls the ZP's DID when the associated ZCC Agent is in a call, but I haven't tested it with a physical phone so I have a questions/test for you

  1. When the ZCC Agent is engaged on a call: Can you confirm the ZP status changes from Green (Available) to a  📞 (Busy)? This should be happening in both, the Zoom App/Client (Top Right picture) and also it should show as Busy on the POLY VVC350 device.
  2. If 1.) is True and you are still receiving a call on the ZP's DID while the ZCC is Busy, then maybe you still have enabled "Call Waiting" on the Agent's ZP settings; change that to another option that won't allow ringing because in your case with multiple devices, it will ring on the other devices that are not actually engaged on a call.

On the picture below, shows set to send a second call to Voicemail, but other options are available, like for example, "Play Busy Signal"



I hope this is the culprit of your issue and can solve it.



Community Champion | Customer
Community Champion | Customer

Hello @CUExec .  Have you tried the proposed options?