Showing results for 
Search instead for 
Did you mean: 

Camera freezes while in meetings with Mac OS 14.5



I'm transitioning to a Mac M2 Studio (OS 14.5) from an Intel iMacPro (OS 13.6.7) - same Logitech 4K Brio camera. I had a meeting this morning and just before the meeting I opened Zoom and was told there was an update for Apple Silicon, which I did (Version: 6.0.11 (35001)). Immediately my camera was black, it wouldn't turn on. When toggled the video on switch it would work for a brief instance and  refreeze so it in effect created a screen cap pic. I was able to get audio during the session.

  • I know Sonoma (14.5) has been a bit of a hot mess and has strict security - but I think I've set everything properly with security permissions. BUT MAYBE I'VE MISSED SOMETHING?
  • I've restarted the app, restarted the computer (both multiple times) - to no avail
  • The camera works with FaceTime and PhotoBooth (and it worked before with Zoom on OS 13.x)
  • Audio works fine through my my audio interface
  • I tried downloading the installer from Zoom and reinstalling, nope.
  • I have it set properly (on, blue) for the following under Privacy & Security: microphone, camera, for Documents & Downloads under Files & Folder,  I DID NOT GIVE ZOOM FULL DISK ACCESS AS I NEVER HAVE AND DO NOT WANT TO (is that the problem?),  it's set to on for Screen & System Audio Recording
  • I have two identical Dell 2723QE monitors on the Mac Studio (I had the iMacPro monitor plus a 2nd 24" Dell running as dual monitors with the same Logitec Brio previous to the Mac Studio)
  • It seems like it's either a missing/incorrect Sonoma setting or some sort of conflict with this latest Zoom update.

BUT... same Zoom build on the same OS works on my 13" M1 MacBook Pro right now.


Anybody running into this as well?

Any suggestions on how to fix it?






Community Champion | Customer
Community Champion | Customer

Just want to rule out a few more items.


  • Does the issue persist when using different USB ports?
  • What firmware is the Brio running? Can you update it via LogiTune/Sync?
  • Have you played with the video settings in Zoom (HD, original ratio, advanced settings for capture, hardware acceleration, etc)?
  • Are there any other applications/utilities running that may be competing for the camera's stream?


Hey, thanks for the reply! Far from an expert, but:

I did download LogiTune and there aren't any updates.

No other camera competing apps.

DIdn't play around with Zoom settings 

I've tried 3 different ports IN  my Anker 10-port USB C Superspeed hub and I only have 2 USB-A in the Mac Studio. 1 goes to my audio interface, the other went to the hub. I just pulled out the hub and plugged directly into the Studio... and OF COURSE it works now! Now I've got a problem. I'm going to have to see if I can plug my interface into the hub, not directly into the Mac so I have a 2nd free port on the Studio. I need to check on this.

You'd think for such a powerful setup I wouldn't have a dumb thing like this screw it up.  Thanks for the tip. 



Community Champion | Customer
Community Champion | Customer

Hubs add a number of variables, which is why they're rarely suggested/supported. Apple sure does hate USB-A, though, that's for sure.


Perhaps a USB-A -> USB-C adapter might serve you best for the webcam connection, assuming you have a few type-C ports on the Studio to spare.

I'm trying the Motu UltraLite MK4 audio interface through the Anker hub and So far...  it's working, which seems counterintuitive, as I'd think audio through a USB hub would be problematic. I had 2 other thoughts: 1. I have ports on the Dell 2723QEs. I guess I could try the Logitec in one of the USB ports on the Dell - maybe it's just a hub and I'll have the same problem. 2. I could get a more high-powered multi-hub. I have 2 Thunderbolt ports open in front. If I got a powered TB4 hub and it had USB-A, or I used a USB-C adaptor, as you say, maybe that would work?

I just realized that the freezing is ONLY with Zoom. The camera does not freeze if I'm using FaceTime or PhotoBooth. So: why? Zoom is that much more taxing on throughput than FT or PB?


Possible resolution! I was correct that there are issues with plugging an audio interface into a USB hub. The solutions were to purchase a USB-A to USB-C adaptor for the camera and use/waste one of my TB4 front ports on the Studio, psych as this:

OR... I could see if my pair of Dell U2723QE's could work as a hub (the monitor has a built-in hub with USB-A etc.). SO FAR... my camera is working in Zoom plugged into one of my Dells. Can I tell you why? No, but I'll take it. <y audio interface goes back into one of two rear USB-A ports in the Studio. I'll post a follow up if it this stops working. Cross fingers, please.