cancel
Showing results for 
Search instead for 
Did you mean: 

Zoom for Linux not working well with newer distributions

EduardoSza
Listener

Dear All,

 

I am having a lot of problems with meeting's audio, particularly my microphone. Sometimes the sound is too low, sometimes there is an echo and other times the other person only hears a buzzing sound when I speak.

 

This happens in distributions that use Pipewire (Fedora 35 and Opensuse Tumbleweed). I did not have this kind of problem in olders distributions that used ALSA for audio.

 

I am using an AMD Ryzen 4500 laptop.

 

Can you please  let me know if there is a solution to this problem?

 

Thanks!

 

 

10 REPLIES 10

CarlaA
Zoom Moderator
Zoom Moderator

Hi @EduardoSza!

 

I know it has been a while since you initially posted, but I want to make sure you receive assistance. Are you still having this issue? If so, I'd love to help you get it resolved. 



Zoom Moderator
-CA
 

GiuseppeA
Listener

Same laptop (I guess, I have a Thinkpad T14), same distribution (Fedora 35) and Zoom doesn't work with any  microphone (I guess after the latest update of pipewire).

Screensharing is also not working, although I've read of a workaround using OBS studio and creating a virtual camera. But it's, in fact, a workaround.


@GiuseppeA wrote:

Screensharing is also not working, although I've read of a workaround using OBS studio and creating a virtual camera. But it's, in fact, a workaround.


For context, Zoom incorrectly implemented their screensharing on modern gnu+linux distributions which use Wayland. Zoom did not introduce Wayland support until March 1, 2020 version 3.5.361976.0301. This was broken upon release because they did not use the correct API (gdbus-org.freedesktop.portal.ScreenCast) which has been available since early 2018: https://github.com/flatpak/xdg-desktop-portal/releases/tag/0.10. This resulted in issues for multi-monitor setups, problems with HiDPI screens, unusable performance, and other glitches from the beginning, and now it is broken completely.

Many users are switching to affordable, reliable, backed-by-open-source options like https://8x8.vc, powered by Jitsi (plus, they didn't lie to their users about end-to-end encryption and get sued). The screenshot API exists only for the system to take screenshots (of course). It is very inefficient for video but what's worse is it is also completely insecure because in order for it to be publicly enabled, applications have full access to record your entire screen without explicit permission.

 

The correct API was designed for video, and gives the user control over sharing specific windows/apps or the entire screen, so no app gets to spy on your screen without your permission. So when Zoom created their  implementation they used the wrong API, and for the almost two years since then Zoom still didn't update, ignored the users with issues, did not monitor for deprecating APIs, and did not test upcoming gnu+linux distributions like Fedora to see that the API they use was incorrect, long been deprecated, and imminently disabled. This left many users and developers to do the testing and investigation for them, but still took nine months to be recognized. Finally, they are working on this now, so we will see how long the fix takes.

Full discussion here: https://community.zoom.com/t5/Meetings/Wayland-screen-sharing-broken-with-GNOME-41-on-Fedora-35/td-p...

Reinier
Listener

Same problem here with two very different computers running Fedora since version 34, where Pipewire replaced Pulseaudio (around May 2021). The microphone works in Zoom, but the automatic setting of the microphone volume does not. I always find the volume set to 0 % and I have to set the level manually. This also means that sharing a screen with audio gives very bad results, as this requires automatic volume setting of the microphone.

 

I have installed the pipewire-pulseaudio plugin to pipewire, but it appears this isn't working for Zoom. In the log file (~/.zoom/logs/zoom_stdout_stderr.log) I always find the line "No PulseAudio daemon running, or not running as session daemon.",  twice per session. According to google, that error is emitted by the pacmd command.

 

Audio output to the speakers is working fine.

I am also having major problems running Zoom under Fedora 35.
Fedora 35 by default runs the Pipewire audio daemon,
and my outgoing audio (my spoken voice) was extremely
distorted.

 

I switched from Pipewire to the PulseAudio daemon,
and my spoken voice problem was fixed.

 

HOWEVER, I teach music classes and I need to
play audio files while I share my desktop.

 

Still, even though I am running the PulseAudio daemon,
when I try to share my desktop, Zoom displays this message:

 

"You need to install PulseAudio(1.0 and above) to support Audio Share"

 

even though I am running PulseAudio VERSION 15 !!
So the Desktop Share feature is not recognizing
PulseAudio.

 

I have reported this problem to Zoom support, as
ticket 13239618 but Zoom support NEVER gets
back to me!

 

So now I am in this forum. Zoom Moderator,
can you look into this issue for me?

I am having the EXACT SAME problem, have you managed to find any solutions, or work-arounds yet?

I have actually just found a solution, maybe this would work for you too...

So after a bit of digging, I decided to open 2 applications: Software manager, and package manager - into both I typed "pulse audio". There were a few "updates/dependencies" etc. I decided to install/upgrade, and tbh I kind of did them in a slew of what made sense to me, so I can't pin-point exactly which 1 or combination worked, but for me I was able to solve the issue with the following:

Software Mgr: Gstreamer 1.0, P.A. utils, and P.A. were already installed, however i uninstalled, then re-installed P.A., and additionally I installed P.A. Module Gsettings || 

 

Package Mgr: Many packages came up - I can't remember which were previously installed, and which ones I added (there were 3 in total) but what I have installed currently are:  

apulse (new), gstreamer1.0, libao common, libao 4, libao sound 2 plugins, libmatemixercommon (i'm running mate), libmatemixer0, libcaudio, libpulse mainloop glib0 (new), libpulse 0, libpulsedsp, libdsp, libsox3, matemedia, mkchromecast (new), pavucontrol, p.a. utils, sox, ||

That is all. Note, even though I selected 3 additional packages to be installed, upon hitting next I was greeted with a dialogue box saying "1 of the pkgs require additional dependencies/pkgs" and it came with about another 3 pkgs. I agreed to all, restarted, and instantly Zoom was able to share audio no problem.

This sounds a bit lengthy, and it was a bit tedious, but honestly it took me 30mins to figure out and now zoom runs smoothly for the most part, but Audio is in full swing. I hope this helps you and whoever else out there may need it. 

Peace. 

ianv
Listener

Hi,

 

Another Fedora 35 user, I am having lots of sound latency issues sonce zoom version update for fedora 35. Video still runs well but the sound side is not going very well at all.

 

Sync of video and sound has not been good once in the last 6 months.

 

Would be good if this could be addressed in teh near future

Same here. Zoom is now unusable even under normal circumstances. Audio cuts out repeatedly, and the strange thing is, sometimes just opening the audio settings and keeping it open helps the audio stay connected. Though even with it open, sometimes the audio still gets disconnected and I need to switch the audio devices back and forth. This happens so constantly I can't use Zoom for any meetings now.

Another Fedora 35 user - Zoom is unusable for me as most of what I say is dropped.  If I go to zoom.us/test the first sentence I say during the test is repeated fine but after that either nothing is output or part of what I say is dropped.