Showing results for 
Search instead for 
Did you mean: 

Delegated Scheduling using Zoom for Google Workspace not working for some users


EDIT: Zoom Support has confirmed Engineering has identified the root cause of this issue and is working on a fix. No ETA to the patch, but I'll update this thread once it's confirmed resolved.


Original Post:


I'm onboarding a new EA, and probably the most critical piece of their setup isn't functioning.


When trying to schedule for someone, they receive the error:


""Schedule For" is not available because Shared Access Permissions is not enabled. Click here to visit Zoom Marketplace and enable "Allow this app to use my shared access permissions" for the Google Workspace app from the Shared Access Permissions column."


What I've done so far:


Spent two hours on a call with the user testing literally everything. I set up my own user as having scheduling privileges for the first time, the exact same way we did hers. Mine worked, hers didn't. I tried it with a new Google Workspace user. It didn't work for the new Google Workspace user. All testing was done on fresh browser sessions (new Chrome profiles).


I have tried toggling anything that could be toggled; authorizations are 100% correct, and I've tried re-doing them. Signing out and back into everything.


The only difference between "works" and "doesn't work" appears to be the age of the Google Workspace accounts in question; I can get it to work on older accounts, but if I create an account right now then Zoom doesn't recognize the Shared Access Permissions as being authorized.


I'm out of ideas 😞 please help



I’m having the exact same problem, except I have been setup to schedule zoom meetings for others for over a year. The other day I signed on and I’m now getting that same message. I’ve contacted zoom, and spent hours uninstalling and reinstalling and nothing is working. I’m an EA and this is a huge part of my job and I’m now stuck. Super frustrating. 

Did you find a solutions?


Also am getting the same issue after 2 years of being able to schedule for others. I wonder if it was an update they recently released that is causing problems? Incredibly frustrating! 


Same thing is happening to me today - have spent over 2 hours trying to fix this with our Tech team. Any answers?


Did you find a solution?


I have not found a solution yet

Update- had a chat with some folks at Zoom. Sounds as though something was updated on their side. No solution yet, but they are working on it 


No I haven’t found a solution either. I’m wondering if it’s an issue on the google workspace side. But I’m not able to tell because I’m not the admin for that app at our company. Are you all using google workspace as well? Or do some of you use outlook to schedule?

Working with my admin and tech team - they have called Zoom and Google Workspace - 6 hours now without being able to do my job properly.


I hope this gets figured out soon. I've been without it since Friday morning. I have a ticket open with Zoom, but no response yet. Please let me know if they figure out a fix! I don't have a tech team so I'm left to try to figure this out on my own..


I had my IT team uninstall and reinstall the Zoom app from Google Workspace and that did not work either. I also have a ticket open with Zoom but no update. Will share here if I find a solution! 


Figured I'd provide an update - I also have an open ticket with Zoom support. I'm still able to duplicate the issue on the new test user, and my primary user still doesn't have the issue - so whatever is causing this isn't systemic, it's impacting only some users, at least for us.


I'm providing more detail below in case other users have the same issue and want to pile in. Hopefully we get a resolution at some point, but this at least will help folks sort out if this is the same issue they're having.


This is the error:




Clicking "Click here" leads to, where Google Workspace is already shown as "authorized"



Clicking into "Update" and selecting "Revoke Delegated Permissions", then re-authorizing Google Workspace, doesn't resolve the issue either.


No progress so far, but I've been delinquent on replying to the support ticket, so we'll see what comes of it, as I just replied today with a screenshot of the error message they requested..

Yes, this is exactly my problem as well!


Morning! Not sure what happened but this morning - I had the Zoom app loaded and the extension at the top of my screen. The add-on for google workspace isn't working but the Zoom app window opens up when I select 
"make this a Zoom meeting" and all the people I coordinate for are listed and it works now.


That pops up for me too, but once i selected one person i support, now it defaults to that persons zoom on all the other calendars. Not winning this battle over here! Are you able to switch between people you coordinate? Does it pop up to choose who's zoom to pick every time you click that?

i've been having the same exact problem everyone else here is having.  luckily, this work-around is working for me too 😃


Having this exact same issue.
Enabling or disabling shared access permissions does not seem to have any impact, unless the user has an administrator account.
Removing the extension from the workspace also achieves nothing.

Opting to update app permissions as instructed by the extension does not fix the issue. This only seems to have an effect on an administrator account where it behaves correctly. On any other (non-administrator) account, regardless of whether the shared permissions are enabled or not, it is currently not possible to setup a call using scheduling privilege in Google Calendar. I was able to replicate this behavior on multiple accounts with the same result. Removing the app from Google Workspace and adding it again does not solve the issue. The scheduling privilege is setup correctly and functions normally in the desktop client as well as in the web interface.

This actually squares very neatly - all of the people in my org who have the Google Workspace app functional ARE Google Workspace admin users, and the one user who it's broken for isn't (and won't be made one). I need to go update my ticket... 


I joined Zoom Community five minutes ago to find out about this issue that I've been trying to tackle for a week, and literally, the first thread I saw was this one!

I'm getting a slight difference in wording with the error, it could be that I have a different role than the rest of you who have posted. Would love to hear if anyone has any updates.


Here's what I'm getting, copied straight off the Google Calendar event:

Failed to create meeting for [email] because Shared Access Permissions is not enabled.
Click here to visit Zoom Marketplace and enable "Allow this app to use my shared access permissions"for the Google Workspace app from the Shared Access Permissions column.
After enabling, remove this item by clicking "✕" and try again.

You're just using a different pathway to utilize the same shared permissions, I think, and hitting basically the same error. Our impacted user was doing what you're doing initially, then we went to the Zoom for Google Workspace app at another EA's indication and had the same issue that you're seeing most of us reporting here. Same issue, different UI pathways, probably different actual outputs (in that Zoom for Google Workspace lets you do way more meeting configs ahead of saving the event).


Zoom for Google Workspace will be in the right sidebar if your organization has it installed at the Google Workspace level, though you may need to go to the very bottom right of the Calendar page and hit the left-carrot to pop out the side panel that the icon is on).


A temp fix is to make the impacted user a Zoom admin. Not great, but I'm using it for now.


Hi all - two updates:


1. I made the test user having this issue a Zoom admin, went and followed the instructions (revoking and re-authorizing at The problem disappeared.


2. I then removed their admin status on Zoom, hit refresh on the Zoom for Google Workspace App, and the problem re-appeared immediately.


Making the person a Zoom admin is not necessarily a good solve, but I've passed the data over to support on my ticket.


Edit: Credit to @earlybird_it, who spotted this nuance first. Initially I thought you meant GSuite admin, but the test user already was one, so I tested w/ making them a Zoom admin, and got the above results.






Oh yeah sorry for not being more specific - it's the Zoom admin account that makes a difference and to my knowledge it's currently the only way around it. I only figured this out after a couple of hours of testing and eliminating potential causes. I was able to recreate the faulty behavior on all accounts (tested roughly 3) except for mine, which is the only one which happens to be the administrator.


Since there is no fix, my only option is to assign administrator roles for all our EAs. However, I absolutely do not want 6-8 additional people to have access to all account settings etc. I noticed there is an option to set up custom roles for specific users. My goal here is to create a custom role which enables the shared permissions but without giving them full admin access, even though I have a sneaking suspicion some of these necessarily overlap. I haven't been yet able to figure out which of the settings are crucial for making the Workspace integration work again. If anyone has figured this out, I would appreciate if you could share the information with the rest of us!


I'm encountering this at my org as well and haven't been able to successfully address it, so I am having our EAs work around it by scheduling through the Zoom Chrome Extension instead:


This has worked without issue, although the meeting details and setup process is a bit different from what they are used to with the Google Workspace marketplace app. Might be something for folks to try.

We've tried the extension as well and it does indeed work, but the problem is that I have EAs who schedule calls for not just one but multiple people and with the extension it's not as easy to switch between the accounts. There's also the necessity of having to onboard everyone since they will most likely not figure out these things on their own.

We have EAs who are in the same boat and we were able to show them the setup quickly, but I hear you that it's an adjustment and can depend on their tolerance for change.


Several days later I received an official reply from Zoom to my ticket. What they suggested is the workaround I already managed to come up with. You have to create a custom user role in the web interface. 


To resolve, kindly navigate to the Role tab and **create a new role** (you can name it how you want), and enable the **View** permission under User and Permission Management > Users. Once done, please add the affected user that will be doing the scheduling and advise them to sign out and sign back in to the Zoom for Google Workspace add-in as well as the zoom application to make sure changes will be applied accordingly.


This ain't no fix, it's just a workaround for something that used to work but it doesn't anymore, but I guess I'll take it as a temporary solution. Will this ever get fixed to work the same way it used to? Having received that kind of response from Zoom, I think I know the answer...


@earlybird_it - I just got off a screen share with Support - they're escalating to Engineering for a review of what's happening on the back-end.



We may just get a resolution, given the number of customers it must be impacting. Until then, workarounds are the name of the game.


From the Zoom support individual I was on a call with the other day while we went through everything:


" Thanks for patiently waiting. Our engineers have confirmed and identified the issue and will apply a fix in the next days. 
Unfortunately, they do not have a specific date yet of the resolution patch. I will provide more information once we have one. 

Let me know if there are other concerns. "


So, sounds like the Eng team got to the bottom of it and we'll be out of the woods soon.

Yay! Finally! Thanks for the update! Please let us know if your gets fixed. Hopefully it will be a fix for all.

Wondering if this has been fixed for anyone yet? I'm still booking zooms the work around way, but it's default is for everyone to have the "waiting room" option on, instead of just letting people in when they join. Seems there's no way to turn that off with this work around..