Showing results for 
Search instead for 
Did you mean: 

Screen Sharing Control Bar Keeps Disappearing on KDE Wayland




I am using the 5.11.9 (4300) build from AUR on Arch Linux with Wayland KDE plasma. The screen sharing works OK, and the screen recording works OK too. But the main issue right now is the disappearance of sharing control.

For any window W that coexists with the sharing control bar, closing W will make the sharing control disappear.

Here are some combinations that can reproduce the issue.

1. click on the "more" as shown in the attached picture, and click open and then close the chat/record on the computer/reactions/...
2. close the main zoom window (the one that shows the new meeting/schedule/...)


No.  The people here are complaining that they cannot stop screen sharing, not that the "Screen Sharing function is missing".    They are complaining that once screen sharing has been starting, it cannot be altered in any way because the controls to do so disappear.   Rendering screen sharing close to useless unless you only want to do it once for the entire duration of the rest of the meeting.   Shocking there is no response to this whatsoever.  Zoom should provide at least SOME way to stop screen sharing once started.   Like fix the supposed keybinding at least so it works, even if they cannot figure out how to keep the toolbar visible.  How hard can it be?


Hello, i have the same issue here. Zoom installed through Flatpak on Fedora 38. This is quite relevant with Fedora discussing dropping X11 support entirely and going Wayland-only.

The issue is not about anything being disabled in the profile or not, when screensharing starts the ondisplay bar with the controls appears and does work but is not stable. After some usage it may disappear on its own or like szzonly describes always disappears after you press the chat button. Or if you press any other button which spawns a context menu. Then when you click to close the context menu the bar disappears.

When this happens the control window and the main window disappear and there is nothing that can be done but to kill the zoom process or exit from system tray icon.

Also, in the main zoom window, clicking "Return to meeting" does nothing so it is impossible to bring back the main window during screensharing.


Zoom Version: 5.14.7 (2928)
Operating System: Fedora Linux 38
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.106.0
Qt Version: 5.15.9
Kernel Version: 6.2.15-300.fc38.x86_64 (64-bit)
Graphics Platform: Wayland
Graphics Processor: Mesa Intel® HD Graphics 3000

I reported this problem over a year ago (for Gnome under Fedora 36) and still it does not work, rendering Zoom useless in Wayland if one needs to do screen sharing, and most people do, I wager.


Why is no one else talking about this, only a few people?


The screen sharing control bar disappears always within six seconds of the screen starting to be shared.


After that, there is no way to stop sharing.  


The shortcut keys do not work either.   Actually it would be preferable if the bar disappeared by default because it covers up other things one wants to see.   If the shortcut key Alt-S worked to stop sharing at least the thing would be usable.    Did you try your shortcut key?   If it works for you, you at least have something, but probably it does not work for you.


Why can't this be fixed after more than a year?   Zoom under Wayland is useless if one needs to share a screen, and who doesn't?



I am also experiencing this same issue.


Linux Client Version is 5.14.10 (3738)




Same here, on Fedora 38 with Wayland, it's impossible to use Zoom if you share a screen. Better not to use it or start a session with x11. Frankly I don't understand why zoom on Linux is so poorly maintain. 

I wish we had an alternative to zoom so I don't have to use at all.  

Do you find it works with XWayland?   I find if I start Zoom with XWayland, it works and actually catches the entire Wayland screen with no real difficulties (although that seems weird).   This is not really acceptable since it should work in Wayland but at least it is usable for the time being this way if it works for you.

Yes, this is a major pain, and probably the only reason I am not using Linux as my main OS at the moment - I rely so much on Zoom and sharing to Zoom screens it's not acceptable this feature simply doesn't work.  I have tried forcing Zoom to launch in XWayland (used env -u WAYLAND_DISPLAY /usr/bin/zoom) but it doesn't seem to launch under XWayland.    


Any further ideas or updates from Zoom would be appreciated

lrob,  could you clarity what you are saying?   Why can't you use Linux with X11 instead of using something else?   I am still using X11 on some machines and everything works okay, its just that we should be switching to Wayland.   But X11 still does work. 


As far as not being able to start under zoom under XWayland goes, one possibility is that you have other environment variables set, in addition to WAYLAND_DISPLAY, that trigger the use of Wayland.   Check that XDG_SESSION_TYPE is not defined, and, that  QT_QPA_PLATFORM is not defined.  I find that this latter variable can cause  QT to use wayland EVEN IF the other variables are not defined (I had set this variable because without setting it, I could not get zoom to start in Wayland, only XWayland, and later I forgot about it and thus could not get zoom started in XWayland again).


Can you also report what happens when you start zoom in Wayland?  Do you find, as I do, that screen sharing does start up okay, but that the control bar disappears and then you cannot stop screen sharing?   This is not widely reported, but people do have this problem, so I would like to know how to get around it.

Hi @BensonBear - I could install X11 but I wanted to use build a Wayland only box.  Currently using Sway and Labwc compositors.    I assume xwayland probably has some of those components installed anyway.


The issue was as you mentioned, I clear all three variables and Zoom loaded under xwayland.  This created a few new issues 1) The desktop share was a black box only (assume I'm missing some dependencies here?) 2) some of the pop up menus only appeared for a split second then disappeared - again maybe a X11 dependency issue?  If you have any recommendations here that would be great.


When I start it in Wayland screen sharing starts OK but as you say control bar disappears and then cannot stop or get back to screen share - also the minivideo box doesn't come up either.  It sounds like the same issue you have.  And it's doing my head in 🙂

Irob, I also want Wayland only, and I have that except for zoom and a few minor things I know can be solved.   But I am curious, if you could answer, why you move away from linux entirely instead of using X11 at least for now? 


Regarding the black screen, I got this occasionally.   I think it is a leftover old attempt of an earlier Zoom to do a screen share using incorrect (probably X related) means.   I had in the app settings for sharing set it to share the screen automatically, to try to avoid the long series of clicks needed to share screen (should be able to be just one click, not click click click click).    If I set it back to "always ask" what to do regarding screen sharing, then it seems to work.   Try that.  Then I found I could set it back to always share entire screen and it worked again.  


The key difference seems to be that when you share screen, if it is doing it the right way, it should still ask you which screen you wish to share (which is dumb because it should be able to tell if there is only one screen, and avoid this pointless dialog in that case).  


Do you get that dialog?  (And the earlier dialog about whether to share a screen or a window?  Geez, just give us one dialog, with the screens and  windows listed, not click click click click, but that is a minor issue compared to total failure!).   If you get that dialog I bet it will work after that. 


There are other issues such as you mention but this is the big one I would like to get clear that this is a real and major issue that they have utterly not resolved.   Possibly it just requires some new settings, or different library in one's linux setup (PEBCAC)  but even so they have not acknowledged there is even an issue here!!




Maybe these are still  some kind of window that Wayland is failing to find and display.   Maybe we can do something about it without changing the Zoom.  I don't know what.  You say you are using sway, not gnome (or can you replace mutter with sway, seems unlikely).    Perhaps in sway screensharing has additional problems.  It would be good if you could verify your problems under gnome.

I dual boot on my work laptop - so rather than spend time configuring an X11 setup which will increasingly become more redundant with the adoption of Wayland wait for Zoom to be fixed (hopefully soon) and use Arch/Wayland/Labwc/waybar on my non zoom intensive days.


Regarding the black screen, it is only for the entire desktop share,  other XWayland applications such as Slack and Evernote show up as individual windows to share (which does not work on Wayland given issues with reported issues xdg-desktop-portal-wlr & wlroots) - however performance seems to be noticably impacted running Zoom this way on the last call I was on (poor video and audio for the other attendees).


If Zoom can fix Wayland screen sharing issue (bars and popups disappearing) that would be a great 1st step - then if wlr can deliver per app screen sharing that would be the icing on the top!


I do not run gnome but have run zoom using the XDG_SESSION_TYPE=gnome and still does not work.


Oops, I mentioned gnome because I thought this was the "doesn't work in gnome" thread but its the "doesn't work in kde" thread.   Ha ha.  


It appears that you are getting something quite different from me here.    It seems like your XWayland session is using something purely from X to do the sharing.   That could explain why you cannot share the entire screen (managed by Wayland) and can only share the windows that are also XWayland windows.   When I ask to share windows, it will share any window whatsoever.  


It's probably not worth getting into the different versions of library, kernel, etc.   But at the least I would check to ensure you have the latest Zoom. 


If anyone has any idea about what might be happening I would like to know.    It seems like my Zoom when it nearly works is partly running under Wayland, partly under XWayland.    The window itself is rendered by XWayland (as xeyes shows) but when I ask to share the screen, it uses Wayland to do that (and has access to everything it needs). 


I never tried XWayland but I need to give a try.

Feels again hackish, trying to find solution to a problem that zoom can fix it easily. Right now, I'm just using x11 tbh, it's not worth the hassle.