Check out our new Work Transformation Summit page, and join our upcoming event to learn how leading organizations are building a smarter hybrid workspace for their employees.

Visit the page
cancel
Showing results for 
Search instead for 
Did you mean: 

Trying to stop pop-up google calendar notifications every time I schedule a meeting

BryanW
Listener

Like many people (I assume), I have both a Zoom and a Google (Gmail etc) account. I never used to get any Google calendar popups or notifications when I scheduled a Zoom meeting (on my older 2015 MacBook, with somewhat out-of-date OS). But suddenly, as soon as I upgraded days ago to a 2021 MacBook Pro (Monterey OS), every time I schedule a zoom meeting, it activates my Google Calendar app, and I am immediately prompted to add it to a Google Calender.

 

I have to click "cancel" to make the pop-up box go away, and then I must separately quit Google Calendar (which I find annoying and never choose to activate myself).

 

I cannot figure out whether some setting in Zoom, or Google Calendar itself, is automatically turning on this app and prompting me to add the meeting to some calendar, but it's extremely annoying.

 

The only thing I can find in Zoom settings is an option to link to Google, Microsoft Exchange, or Microsoft 365, and as far as I can tell I have never activated them that way. When I click on it, there's an option to proceed but I haven't done so. I don't see any option to affirmatively disable any automatic calendaring or anything like that.

 

In Google, I have turned off every possible calendar notification setting I can find, disabled gmail calendar notifications (a separate annoyance!), have not added any Zoom extension to my Chrome browser, etc.

 

So how and why is this happening? Very baffling. It is adding an extra click plus having to turn off an app I never chose to turn on in the first place, every time I schedule a new Zoom meeting (and as a teacher meeting remotely with many students, I schedule a lot of meetings).

2 ACCEPTED SOLUTIONS

colegs
Community Champion

@BryanW I hear you on being too hooked to Apple, and having to live with their faults despite the frustration!  Hopefully, as Monterey gets fully baked, these issues will get resolved.  Good luck!

View solution in original post

So this problem had not actually been solved by this discussion in the Zoom community support group, but it now has been solved by the Macbook community support group, in the very first reply I received there to my inquiry (which kindly looked into the Zoom support info online which I had somehow missed or not understood).

 

The problem turns out to be in the Zoom settings, though it was "my bad" for not noticing something so obvious (and I'm kind of amazed that no one in this forum noticed it either).

 

What was happening was that I had inadvertently defaulted to the "iCal" calendar option when scheduling my meetings. The better option to click is "Other Calendars" which then simply prompts one with a field to copy and paste (such as in an email) with the scheduling info and link.

 

As explained here on the Zoom support page:

https://support.zoom.us/hc/en-us/articles/201362413-Scheduling-meetings

  • Calendar: Select a calendar service to add the meeting and send out invites to participants.
    • Outlook: Open the Outlook desktop app and create an event for the meeting.
      Note: You will see Outlook when using the Windows client.
    • iCal: Open iCal and create an event for the meeting.
      Note: You will see iCal when using a macOS.
    • Google Calendar: Open Google Calendar in your default browser and create an event for the meeting.
    • Other Calendars: Open a new window, where the meeting text can be copied pasted into the user's preferred communication method. You can also down an ICS file which can be opened in most email applications.

View solution in original post

10 REPLIES 10

colegs
Community Champion

@BryanW Since you have not enabled the Google calendar integration in Zoom, it is sounding like a setting in Google.  Next time the Google calendar opens up, can you please go into settings, then make sure everything is turned off in the 'Events from Gmail' option?

BryanW
Listener

Thank you so much the reply! I opened up Calendar to try this, but one problem I already had is that I can't find anything called "settings" in that app. Under "Calendar" menu at upper left, there is "Preferences" but the limited range of options doesn't seem to include anything dealing with turning the darn thing off (I did set it to refresh only "Manually"). I specifically do not see anything like "Events from Gmail" in the Calendar app "Preferences." I would just trash the entire app if I could (I literally never use it), but the Mac system doesn't allow that.

colegs
Community Champion

@BryanW If you click on the gear icon in the upper right, it will bring up a menu that has the settings.  If you have not been in this menu already, there is also a notification settings that you would want to make sure is completely unchecked.

BryanW
Listener

Thank you, but that's just the problem. I do not see any gear icon or "settings" anywhere under any menu in Calendar. Have spent quite a bit of time looking and clicking through it. I can only find "Preferences" in main "Calendar" menu at upper right. See screen shot.

colegs
Community Champion

Please go to https://calendar.google.com and try to sign in there.  You are looking at the Apple calendar, which could be integrated with Google, or we could be looking at a different issue altogether!

 

Oh dear. So sorry, I think I have been misspeaking all along. I now see it is the Mac's own Calendar app that is engaging in the unwanted prompt/activation. (I got distracted and confused them when disabling calendar notifications in Gmail.) My problem remains, however, and I am now thinking there must something in the Zoom settings that is activating the MacBook's Calendar. See attached screen shot of my MacBook's settings on which Apps (none) have access to the Calendar. Zoom is an App, right? Puzzled how it is activating a connection to the MacBook's Calendar when it doesn't even appear in this pane. I must be missing something obvious (or this is some weird setting or glitch).

Addendum to my previous follow-up just sent: By contrast, for example, Zoom has requested (and I've given) access to the Microphone on my Mac (obviously). See this additional screenshot. So shouldn't Zoom also be requesting access to the Mac's Calendar if it is somehow triggering it? I do not see anything in my Mac Calendar "Preferences" that would suggest the Calendar itself is initiating this connection (still have not found any relevant Calendar "Settings" except these references to Calendar in the screen shots in my main "Security & Privacy" Settings).

I just did another test meeting in Zoom, and it looks like Zoom has requested access to my Mac microphone and camera (perfectly normal, of course), and thus shows up as a linked App in my MacBook Security & Privacy settings. But those settings also include the Mac Calendar and it does not indicate any requested access or other linkage to Zoom. I am now thinking it's very unlikely this problem is originating with Zoom (so sorry if I have wasted your time!). Somehow it is something triggered by something in the MacBook's operating system or Calendar app (though I can't find how, and as noted can't even find any useful "Settings" (just some unhelpful "Preferences") in the Mac Calendar app itself). I have read online there are some glitches with the Monterey OS 12 which my brandnew 2021 model MacBook Pro uses, so maybe that is somehow at fault. Sigh ... I guess for the time being I will just have to constantly "cancel" the unwanted Calendar prompts (won't bother repeatedly, and pointlessly, quitting the Calendar app, since it seems to get automatically turned on whenever I schedule a new Zoom meeting).

 

Knowing Apple (a source of endless frustration to me, even though like many I am too addicted and invested into their laptop computers), I am sure this is somehow Apple's fault. Zoom software has always (in my experience) been very user-friendly and never does anything weird or unwanted. Apple constantly does!!!

colegs
Community Champion

@BryanW I hear you on being too hooked to Apple, and having to live with their faults despite the frustration!  Hopefully, as Monterey gets fully baked, these issues will get resolved.  Good luck!

So this problem had not actually been solved by this discussion in the Zoom community support group, but it now has been solved by the Macbook community support group, in the very first reply I received there to my inquiry (which kindly looked into the Zoom support info online which I had somehow missed or not understood).

 

The problem turns out to be in the Zoom settings, though it was "my bad" for not noticing something so obvious (and I'm kind of amazed that no one in this forum noticed it either).

 

What was happening was that I had inadvertently defaulted to the "iCal" calendar option when scheduling my meetings. The better option to click is "Other Calendars" which then simply prompts one with a field to copy and paste (such as in an email) with the scheduling info and link.

 

As explained here on the Zoom support page:

https://support.zoom.us/hc/en-us/articles/201362413-Scheduling-meetings

  • Calendar: Select a calendar service to add the meeting and send out invites to participants.
    • Outlook: Open the Outlook desktop app and create an event for the meeting.
      Note: You will see Outlook when using the Windows client.
    • iCal: Open iCal and create an event for the meeting.
      Note: You will see iCal when using a macOS.
    • Google Calendar: Open Google Calendar in your default browser and create an event for the meeting.
    • Other Calendars: Open a new window, where the meeting text can be copied pasted into the user's preferred communication method. You can also down an ICS file which can be opened in most email applications.