Showing results for 
Search instead for 
Did you mean: 

Linux screen sharing broken in new client


 A few days ago, I installed the latest Zoom client (Version 5.7.5 (29123.0808)) on Fedora Linux Release 32. Now "Share Screen" offers only the whiteboard under "Basic". There is no option to actually share the video screen. Yes, I rebooted the system to be sure there was not some other problem. The old client worked great, though it may have been a few versions back. Does anyone else have this problem?


That was it! I'm not sure why it worked before, but I switched over from Xwayland (Wayland) to Xorg following the instructions at Now screens and application windows appear in the Share Screen dialog window. Thanks!

View solution in original post


Participant | Zoom Employee
Participant | Zoom Employee

Hello @climate_dude 


Can you verify if you are utilizing Wayland with your Linux set up? If so, you will need to launch your Linux session with Xorg instead. From the support article:

"Linux sessions utilizing Wayland can only share an entire desktop or whiteboard. To share just a specific application, you need to launch your Linux session with Xorg instead."


Let me know if you continue to experience any other issues or if this resolves what you are experiencing. Thank you.

That was it! I'm not sure why it worked before, but I switched over from Xwayland (Wayland) to Xorg following the instructions at Now screens and application windows appear in the Share Screen dialog window. Thanks!

Meh, this isn't really a "solution" it's more accurately a workaround for a Zoom bug

And a poor workaround at that. I believe Wayland is in the process of replacing Xorg entirely, and right now Zoom is the ONLY app I'm forced to use with Xorg.



Agreed. Also, it seems to work for very specific distributions and on GNOME only. KDE users are left out in the cold with Wayland+Zoom. This is a bit surprising since KDE is built on top of Qt, just like Zoom. All Qt apps work perfectly under KDE ... except Zoom!


What sorcery has Zoom devs added (or not) to Zoom that makes it so hard and unusable on Linux, in general, and KDE/Wayland, in particular?


Btw, I've heard my GNOME friends complaining too!

In short, they simply never added Wayland support


Fortunately it sounds like they are now doing that, though it's unclear when we might expect to see it

For a deeper discussion, including some of the many reasons this workaround is unacceptable, see


For more context, Zoom incorrectly implemented their screensharing on modern gnu+linux distributions which use Wayland. Zoom did not introduce Wayland support until March 1, 2020 version 3.5.361976.0301. This was broken upon release because they did not use the correct API (gdbus-org.freedesktop.portal.ScreenCast) which has been available since early 2018: This resulted in issues for multi-monitor setups, problems with HiDPI screens, unusable performance, and other glitches from the beginning, and now it is broken completely.

Many users are switching to affordable, reliable, backed-by-open-source options like, powered by Jitsi (plus, they didn't lie to their users about end-to-end encryption and get sued). The screenshot API exists only for the system to take screenshots (of course). It is very inefficient for video but what's worse is it is also completely insecure because in order for it to be publicly enabled, applications have full access to record your entire screen without explicit permission.


The correct API was designed for video, and gives the user control over sharing specific windows/apps or the entire screen, so no app gets to spy on your screen without your permission. So when Zoom created their  implementation they used the wrong API, and for the almost two years since then Zoom still didn't update, ignored the users with issues, did not monitor for deprecating APIs, and did not test upcoming gnu+linux distributions like Fedora to see that the API they use was incorrect, long been deprecated, and imminently disabled. This left many users and developers to do the testing and investigation for them, but still took nine months to be recognized. Finally, they are working on this now, so we will see how long the fix takes.

this is not solution but workaround. It's almost like saying I should install windows because it's not working on Ubuntu

Hi, thank you so much for this! I just updated to Ubuntu22 and I encountered this problem on our meeting.

Thanks heaps and God bless!

Please, this cannot be an acceptable solution 👎

This compromises the system. The solution must come from the developers. This issue is not resolved 🐛

This is not an acceptable solution. Zoom developers need to get on this ASAP. We are upgrading all of our workstations (we're a Canonical house) to 22.04 LTS and we need something better than a workaround. This could be a deal breaker for our organization.

The latest Zoom client (5.8) only permits me to share the whiteboard, not the entire screen as before.

Same here, and I'm on 5.10.


I found that dropping down to Zoom 5.6 works with Wayland on Fedora 34. 

I tried going to 5.6.7 on Fedora 35 with Wayland, no go.


 For background and a workaround that still uses wayland, see


The short version of the workaround is: do alt-F2, type "lg" and hit return; then enter

  global.context.unsafe_mode = true

and hit return; then escape to go back to things. You might want to reverse this (change "true" to "false") afterwards.

Be warned, this "workaround" along with Xorg workaround above, both also work around all the security present in wayland which prevents apps from spying on your screen without your explicit permission.


Same issue with Slackware x86 and x64 Current and OpenSUSE 😞 - Wayland support would be much appreciated!  Thanks in advance


i'm probably going to just cancel my corporate account, here i thought they were better than teams supporting linux. but then they got lazy. well. you snooze ya lose pal. i'm outtie! 


I've upgraded to Ubuntu 22 and now can share only the whiteboard. With Ubuntu 20 screen sharing worked well, but Ubuntu itself stopped working properly, I had to change it. Going down to Ubuntu 12+ Client doesn't solve the problem.

I'm also on Ubuntu 22 and can only share the whiteboard. Zoom version 5.10.4.


No need to switch over to Xorg from Wayland as your default display server.. While on Wayland you can just spawn Zoom with the following environment variable set: XDG_SESSION_TYPE=x11

Like this:

$ XDG_SESSION_TYPE=x11 zoom &


That'll only get Zoom to enable old fashioned X11 buffer stealing, which will only work with X clients


i.e. Wayland apps won't be available to share

this doesn't work at all for me.

This works well for my needs, meaning the windows I want to share (i.e. Citrix Workspace) are available with this workaround. Thanks!


EDIT: I was wrong, this workaround isn't reliable. Oftentimes my screen sharing fails. 


MX-21 has the same issue with the latest client 5.9.6 (2225)



Same problem on Ubuntu 22.04 with Zoom 5.10.7 (3311).


Please any Zoom's developer with any descent solution ?


I am having the same issue here as everyone else. Here's my config:

  • Ubuntu 22.04 LTS (64 bit)
  • Gnome 42.2
  • Wayland Windowing
  • AMD Radeon 6800XT
  • Zoom Client 5.11.1 (3595)


I have the issue on the latest Ubuntu as well and am using the x11 env var workaround currently.

XDG_SESSION_TYPE=x11 zoom-client &

I am also using the direct download app rather than the snap version.


I was unable to use the Zoom White Board. The material that others, including the moderator added did not appear.


Here is the solution that worked:  I edited custom.conf and then rebooted.

sudo nano /etc/gdm3/custom.conf