Showing results for 
Search instead for 
Did you mean: 

Need help updating the zoom app.


I just returned from a long vacation, tried to open a meeting I was hosting with a client five minutes before the meeting started and got the message: "Your app version needs to be 5.12.2 or higher to sign in.  Please contact your IT team to update your app." 


I'm not an IT expert.  I'm a single-person business.  My experience is that when an app has a software update, it provides a link in the same message notifying you of the need to update taking you to a page where you can download the new version, and when it downloads, you are able to click "run," and an installation wizard should open and update the app.  That is how virtually every other software company in the world does business from my experience, which admittedly is not very sophisticated.


I went online and found what I think is the most recent version of the zoom app for windows desktop and downloaded it.  Then I clicked run.  But no installation wizard appeared.  Instead the zoom app opened with the same old version and when I tried to login I got the same message telling me it would not open because my version was too old.  It told me to contact "my" IT department.  When I originally set up Zoom I know I did not have to read articles to do it.  As "my" IT department, I don't have any knowledge about how to get the product to work.  I am supposed to schedule multiple meetings today and I cannot do it.


Can anyone help me get the app installed?  I am a grump, but I absolutely hate how hard it is to get a Zoom tech support person on the phone in order to achieve basic functionality of the app I am paying for with a subscription.  It seems like I need to consider if there are better products out there than this.


Thank you to anyone who can help!




Hi Hank,


I had the same problem this morning when I tried to log into my Zoom account. I googled something along the lines of 'Zoom tells me I need to update my software', and your conversation came up on the Zoom Community website. I managed to fix my problem so I thought I would share my solution with you. It was quite simple - here's what to do:

1. On your pc, check what version of the Zoom app you are currently running. To do this, just go to 'Settings' and then 'Apps'. I had version 5.12.0 (8964).
2. Uninstall the app.
3. Save and close any open documents, files and apps.
4. Open your web browser (mine is Google Chrome) and in the top right-hand corner click on the three dots. Under 'More tools' click on 'Clear browsing data' and select 'Advanced' and 'All time'. Click 'Clear data'.
5. Close and restart your pc.
6. Open your web browser again and in the web browser panel at the top of the screen type
7. This is the official Zoom website. At the very bottom of the screen under 'Download' click on 'Zoom Desktop Client'. On the 'Download Centre' page you can see that the latest version is shown as 'Version 5.15.7 (20303) (64-bit)'. Click on 'Download'.
8. Zoom then does a clean install.
9. After installation, open Zoom and log in as normal.

It worked for me, so hopefully it will also solve your issue!

Regards, Vip.


I follow the procedures and am going on well.