Check out our new Work Transformation Summit page, and join our upcoming event to learn how leading organizations are building a smarter hybrid workspace for their employees.

Visit the page
cancel
Showing results for 
Search instead for 
Did you mean: 

iOS 15.4 beta - unable to sign-in using SSO - Content Security Policy unsafe-inline

vbhatia
Listener

I am using iOS 15.4 beta 3 (Released February 15, 2022 Build 19E5225g ) and am unable to sign-in using SSO. I am seeing error

 

Refused to execute a script for an inline event handler because 'unsafe-inline' does not appear in the script-src directive of the Content Security Policy.
 
 
From Apple's safari 15.4 beta release notes there have been Improvements for Content Security Policy 3.
"Added correct blocked resource violation reporting for inline script, inline style, and eval execution."
 
Does anyone know a workaround or if there is a fix coming for this?
1 ACCEPTED SOLUTION

YaBoiB
Community Champion

Hello,
My name is Brandon. Thanks for joining the Zoom Community! We can only support versions that are currently in production. The latest version of iOS that we support is version 15.1.3. Once the version you are on becomes the production version, we can support this for you, but it would most likely be better to work on this through a support ticket with our team. 

If this response was helpful for you, please do not forget to click on the accepted solutions button!

View solution in original post

7 REPLIES 7

YaBoiB
Community Champion

Hello,
My name is Brandon. Thanks for joining the Zoom Community! We can only support versions that are currently in production. The latest version of iOS that we support is version 15.1.3. Once the version you are on becomes the production version, we can support this for you, but it would most likely be better to work on this through a support ticket with our team. 

If this response was helpful for you, please do not forget to click on the accepted solutions button!

StefanCross
Listener

I am also experiencing this issue with my company’s domain. Running iOS 15.4 Beta 3. Was hoping Beta 3 would resolve, but it has not. 

CWade3051
Listener

I was having same issue and found a work around until they get it supported. Goto safari settings and disable JavaScript totally.  Then open zoom, choose sso, then your company and it should take you to a page that says since you have JavaScript disabled click continue, so click it and it should redirect to your company’s sso login page but it prob won’t show with JavaScript disabled, just go back to settings and re-enable JavaScript and then back to safari and refresh your company sso page to login, then it should work normally from there.  Not sure it will work for everyone but did for me after weeks of not being able to use zoom 🙂

YaBoiB
Community Champion

Hello @StefanCross , 

 

 Can you verify that this solution above is working for you? And if so can you please click on the accept as solution so that others that might be facing this issue can be assisted as well?  

 

Hello @CWade3051 , 

 

Have you by chance brought this to the attention of Apple support or Zoom support through a support ticket? This is important for both organizations since we do track all support tickets and work with our backend Engineers on issues such as this. Supported or not. 

If this response was helpful for you, please do not forget to click on the accepted solutions button!

Brandon

 

I have not had a chance to do that as of yet.  I was just trying to get zoom working for work this morning and once I figured it out thought I would post a response here so others could get in.  After work I will look into posting elsewhere. 

 

Thanks

 

CWade3051 

Thanks, this worked for me also. 

YaBoiB
Community Champion

Hello,
My name is Brandon. Thanks for joining the community!
If the solution that I have provided works for you, please click on the "Accepted as Solution" button in the bottom right corner.


If this response was helpful for you, please do not forget to click on the accepted solutions button!