Showing results for 
Search instead for 
Did you mean: 

Zoom will not add link to Outlook web meeting


The Zoom icon shows up in my outlook web appointments and it used to work to add a Zoom link.  Recently, when I click the icon and Add a Zoom Meeting, I started getting "Zoom is working on your Add a Zoom Meeting request" and then it just sits there.  I tried clicking on settings, under Add a Zoom meeting, and Zoom tells me there is a problem and read the article -- but there is no article and no indication of what the problem is. 

It works fine in my desktop Outlook, but I prefer Outlook in Chrome because I'm in Chrome all day anyway.  And it works in Edge, which I hate. 

I whitelisted Zoom in Chrome and turned off all my popup blockers for outlook and Zoom.  I've looked all through my Chrome and Outlook settings and cannot figure out what the problem is. 

If you have a solution, I would really appreciate it if you would share it with me please. 

Thanks muchly.

Zoom issue.png


Hi Rachel.  I do not have IE, I have Edge and it works in Edge, but I don't us that. My problem is in Chrome which is what I work in all the time. Is there a fix for Chrome?


The fix for this is.....You need to be logged into Zoom in order for the zoom meeting to populate. Chrome wants to open another window in order for you to log in, but the browser or the webpage does not indicate that in any way. So when you get to the screen shown below.....BEFORE YOU CLICK UPDATE, hold down the "Ctrl" key, and it will pop the screen that it needs to. Then click "allow" and sign into Zoom with your credentials OR through SSO. Make sure to check the box that says keep me signed it to mitigate the number of times you have to encounter this oh so stupid process. Zoom/Chrome should really fix this!



Thank you.  I will try this if I get the add-in error you displayed.


I discovered that I had to allow third party cookies for Outlook to add a Zoom meeting, even though I have Zoom as an exception to the no cookies setting.  So I allow them and then turn cookies off again after I set up the meeting. So weird and inconvenient!  They really need to fix that too.