Showing results for 
Search instead for 
Did you mean: 

Wayland screen sharing broken with GNOME 41 on Fedora 35




I recently updated to Fedora 35 with GNOME 41. This GNOME release restricts the screenshot API which Zoom has used for screen sharing on Wayland, so the screen sharing functionality no longer works (see here on Ask Fedora).


I require screen sharing for school, and I'm sure many others have a similar requirement/system configuration. With Wayland increasingly becoming a de facto standard on Linux, it is crucial that Zoom support Wayland screen sharing.


It's not a bug in xdg-desktop-portal-wlr, so I'm not going to create a pull request to add code that does nothing (if the client is behaving correctly...). There's already work on supporting to share only a region of the screen ( which should coincidentally also fix Zoom.


Simply running Zoom with "env XDG_CURRENT_DESKTOP=GNOME /usr/bin/zoom" should be enough to make Zoom think it's on Gnome while still keeping dbus working.


Edit: This should not be marked as solution! If any, provides a workaround for the issue, which has to be fixed by Zoom!

View solution in original post

406 REPLIES 406

Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hey Team, 


The Linux deployment has been slightly delayed for version 5.11.0, but it should be completed by tomorrow end of the day US time. Sorry for the inconvenience. I know that many of you have been waiting for a long time for this version to be released. I do not know the reason for the delay. 



If this response was helpful for you, please do not forget to click on the accepted solutions button!

could you fix the fact that it still says you need to use GNOME to screenshare in the next release? (though with a hack it "works" on any other desktop environment/window manager, but other users won't be able to see your screen)

It also doesn't make sense to place a random artificial restriction on screensharing when it is meant to work across all desktop environments

thank a lot mate for all the effort you put to make this happen. May Linux and the power of Free Software be with you.

We are still not done, they still have to remove that random restriction for gnome only

Tested on Fedora 36 Gnome 42 x86_64 with zoom version 5.11.1. Able to screen share a specific google chrome window. But the window does not show the "green border". Is this a known issue ?

Community Champion | Zoom Employee
Community Champion | Zoom Employee



 I have not seen this reported to date. I can look into it and see if we have any other reports of the green border not showing up on an application share. 




If this response was helpful for you, please do not forget to click on the accepted solutions button!

I've also seen this on full-screen shares missing the green border.


Since upgrading to 5.11.x, while screensharing in gnome w/wayland again is working:

I've also had a few cases of zoom freezing up while sharing, often when switching from full screen share to windowed share. Folks can still see and hear me, but the zoom UI is frozen, no changes, no response to input.

Okay. Thanks @YaBoiB 

Also the option to share a portion of the window is also missing.

Unfortunately that is impossible to fix, but you CAN fix the fact that screensharing doesn't work on all desktop environments (so pls fix it)

the reason I say that is because wayland does not really support layering (zwlr_layer_shell is an option, but not a great one, it only works on kde and wlroots at the moment) , so you can't layer that yellow box on top of the window, nor can you add it as a custom decoration or smth. 

@YaBoiB Is there any update on the "green border" issue ?. Anyone else managed to reproduce it ?

Community Champion | Zoom Employee
Community Champion | Zoom Employee

@ck1234, No updates that I am aware of but we were off since July 1st, so I will have to check on it and get back to you. Do you have a support ticket number that I can reference? 



If this response was helpful for you, please do not forget to click on the accepted solutions button!

@YaBoiB how do I file this support ticket ?


So, I _think_ it worked for a second or two (didn't get to check on another client) before it segfault'd


  1. Start Zoom
  2. New Meeting
  3. Share Screen
  4. Use system capture (complete with confusing screenshot, I think from Ubuntu?)
  5. Single Window
  6. *a window*
  7. Share
  8. [wait]
  9. kaput

It's just done it three times in a row

Update: Also consistently happens when sharing the whole screen


This on an entirely up-to-date freshly rebooted fc36 system.


Feels like delaying til the 3rd wouldn't have been a terrible idea…

Yeah I have the same issue on one of the laptops on Fedora (posted already here a few minutes ago), it works on the others so either a gpu driver issue or a library I don't have installed on that one. 


Well, you got me excited there for a second. It at first seems to work on Sway but then other participants don't see your screen at all as others have reported with KDE.

Zoom even uses the dmabuf variant of ScreenCast, which would be great if it only worked. Forcing it to SHM, xdg-desktop-portal-wlr complains about Pipewire being out of buffers the whole time, not sure what's going on there (and Zoom eventually crashing).

Would be interesting to know whether xdg-desktop-portal-gtk does anything different regarding screensharing than the other implementations.


All in all this is a very disappointing experience.

So you can at least try and share your screen on sway. When I trick zoom to let me try to share my screen like this


It lets me try to share my screen with the gnome-looking screen-share application window as an option. But selecting it just backs me out of the screen share window like it tried to do something but nothing happens. I even have xdg-desktop-portal-wlr but still no luck.

I mean fixing it so i can at least share a blank screen won't do me much good but I'm curious how you got your setup to work like it did.

same issue here on kde, except there is no share on the other user's screen, but on the client everything looks like it's working


Another data point:  when running zoom 5.11.0 (3540) on Fedora 35 as a Wayland app under Wayland and Gnome 42, I find that I can screen share.   However, there are problems with functionality still. 


The worst of them is that once I start screen sharing.  I cannot stop it!  The floating toolbar that allows control of these things shows itself for only a few seconds, but then  disappears and will not return!  (I can only use Gnome to stop the screen sharing but that does not work well).   Hopefully I am doing something wrong and there is a way to get this floating toolbar, or at least the major aspects of its functionality, back.   (But I don't think I am doing anything wrong here)


Does anyone else see this behavior?  (Or if not, can someone say how they stop sharing once they have started it?)


The above being said, it seems like the screen sharing can be used at this point (in my setup), since Zoom can be launched as an Xorg app  within Wayland  and running under XWayland,  where the screen sharing now works and also, the floating toolbar does not go away.     The screen sharing can be stopped and started at will within a single call. So I will probably be installing new Fedora distributions running Wayland on all my computers now.



Hey it seems to work now with the 5.11 version, thanks mates


After months of waiting for screen sharing to work under Wayland it is so disappointing do find that it only works with Gnome. Why is this? Do we have to wait many more months for it to be done properly so it works under KDE and other DEs? Can Brandon ask the developers why we have this restriction and how long it is going to take to fix it?


After some testing (all Fedora 36 laptops on GNOME wayland) one crashes on screenshare with no apparent reason, can't figure out why since the setup is close to identical, any idea where to start? the logs just show a code 7 but no useful information it appears. Should I reach support or someone already has a workaround?

This seems like a driver issue, maybe
Module with build-id 786ebbe150c63e27beb2957d717bece33431af6f
Stack trace of thread 46419:
#0 0x00007f3572957f8d __memcpy_avx_unaligned_erms ( + 0x157f8d)
#1 0x00007f34ddd11b04 _mesa_GetTexSubImage_sw ( + 0x311b04)
#2 0x00007f34ddb7a1ad st_GetTexSubImage ( + 0x17a1ad)

After today's OS update, zoom doesn't seem able to recognise screens and windows on Wayland, just shares the main display whatever my choice is. Unfortunately this is not mature enough to excuse the cost for a license since there are other tools that work.

Will keep an eye though

just wanna note, I updated today and it works! thanks @YaBoiB 


Any eta for supporting other desktops on an API that supports all of them?

Zoom 5.11.0 uses a cross-desktop API. The restriction on GNOME is artificial now, rather than technical.

yes I know, I posted that numerous times above, I just wanted to keep this issue at the bottom


Was able to download the Zoom 5.11.0 (3540) release on Fedora 36 + Wayland, and in preliminary testing, it looks like it has proper support for screen sharing now!

Don't give a picture to zoom that it's finished and working it still doesn't work on every other desktop due to an arbitrary restriction that they have to remove. People posting that is working will make zoom less likely to fix the issue

But we do need to give realistic feedback about what works and what doesn't, to give them the best possible understanding of where they stand, right? It's now working under some circumstances - that's huge progress, even if we are not entirely there yet.


Community Champion | Zoom Employee
Community Champion | Zoom Employee



 No offense, but that is a very untrue statement. Zoom has teams of developers dedicated to solving issues such as this one. We just have to prioritize like any other software company on the market. 



If this response was helpful for you, please do not forget to click on the accepted solutions button!

thanks for the response, I was pretty concerned that nobody from zoom was responding for a reason similar to that

Community Champion | Zoom Employee
Community Champion | Zoom Employee

@idkman , 


 To give you an understanding of how important this topic is to us here at Zoom. This topic has been the number 1 trending topic on the Zoom Community page since it started. Nearly every Zoom Community Champion reads this thread. Trust me when I say that we want this completely solved just as much as the Linux community does. We bring this thread up in our meetings every single time. I am in near constant communications with the developers. I may be the POC on this thread but there are many Zoom eyes on this thread. Including the lead developer. 


I say all of this to give you all peace of mind that we do completely care about every issue that is posted on the Zoom Community page. That is why we built this page. 




If this response was helpful for you, please do not forget to click on the accepted solutions button!

Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hello @idkman



 I apologize about the delay with me now. I started a new role back in July and it is keeping me even more busy than I used to be. I am going to DM you about something that I would like to discuss with you. 




If this response was helpful for you, please do not forget to click on the accepted solutions button!

"it has proper support for screen sharing now!"   


How do you stop sharing a screen though?


Are you saying you can do this in Fedora 36 and gnome?  I cannot do it in Fedora 35.    The toolbar disappears and will not come back.    Are you sure your zoom is running under Wayland and not XWayland?   I find it  works under XWayland but not under Wayland. 


Alright, 5.11.0 is a huge step forward for me. Using openSUSE Tumbleweed 64 bit (GNOME etc), I can now share entire screens without the unsafe_mode workaround, I can share individual windows (even if they are not currently visible on my desktop), and, most importantly, I can now do the same in a webinar, where previously not even the workaround helped. I checked this in actual meetings to verify that the actual content is being shared, not just a grey rectangle or anything. Thanks to zoom for *finally* fixing this - even though it sounds like there is some more work to do for other platforms.

Agreed. It's very important to give feedback on THIS ISSUE.


Those with problems on other Linux platforms should feel free to start a new thread. It's important to note flaws in the solution for this issue and not others.



flaws in others? idk about that, but what I do know is that I am going to start a new thread

track progress here:


This is just ridiculous. I'm on Gnome, an Arch-based distro (EndeavourOS), zoom updated to 5.11, and it still doesn't let me share because of some artificial limitations...

I'll leave it without further comment because I have nothing nice to say about those developers working for zoom.


still broken on kde & other desktops 5.11.1