Showing results for 
Search instead for 
Did you mean: 

Menus don't work with Linux client


With the last couple of versions of the Linux Zoom desktop client, I find that some menus (including the main menu and the audio/video selection menu) don't work: they appear for a fraction of a second and then disappear again. The last version that worked is 5.17.5. Versions 5.17.10 and 5.17.11 show this problem, which makes the desktop client unusable in practice. One of the institutions that host meetings that I attend has a very strict policy on using up-to-date versions of the client, so using version 5.17.5 may not be a usable workaround for much longer.


I am using Gnome/Wayland on openSUSE 15.5.


This looks similar to a problem reported on the Fedora forums at but openSUSE 15.5 uses an older version of mutter (41.9) than that reported there.


For completeness I have attached zoom logs for working and non-working versions, although I can't see any significant difference between them.


Does anyone have any suggestions about how to fix this, or whether there might be a fix coming soon?



I can confirm that the problem DOES NOT EXIST in latest version,

Looks like it is fixed in this version.  

I am seeing flickering though, so I suspect that the problem might come back.  Looks to me like the menu close functions aren't coded right.  

View solution in original post



I am grateful for your posting this.  I am on Debian/StumpWM and since the update I can no longer use Zoom.  If the menus appear at all, the menus disappear when any popout or menu is item used and it reverts to a full screen minimised version and the only way to try to get the menu back was kill the client.

I found this kludge fixed it.

Maybe will work for you too?

Thanks for the reply, but this looks like a different problem. I tried what you suggested, and it didn't make any difference.


I am pretty sure that this is specific to certain desktops. I see the same issue with Gnome/Xorg (so maybe not a Wayland-specific problem?). With IceWM it is OK but that is really not a great workaround though.


I had the same problem (on xubuntu). I noticed the main window was losing focus for the brief moment the menu was popping up. Changing my window manager focus setting from "focus follows mouse" to "click to focus" fixes the problem. Annoying, but usable.

Many thanks for finding this - changing the focus policy works for me  as well.


Although you deserve a lot of kudos for this, I'm not going to accept this workaround as a solution - the issue can only really be solved by Zoom developers fixing the Desktop client. If any of them read these forums, your finding should help them to narrow things down. I'll try to open a ticket with them about this.


Thanks again.

Thanks for posting.  I am on Xubuntu too and I have exactly the same problem.  Hopefully someone will fix it soon.

Cheers user42, have a virtual beer on me.

I was having the same issue on Fedora w/ XFCE.

Your well discovered workaround worked for me as well.


And I do agree with other users, this is a workaround not a solution . . . we are waiting Zoom developers.


The last two zoom upgrades give me a Linux client whose menus don't work.
The menus appear for a fraction of a second and then disappear.
Zoom is unusable.


I had to downgrade to 5.17.5 (2543) to get the menus working again.


I am using Ubuntu 20.04.6 LTS on an HPZ440 workstation.


I boot Ubuntu without the default desktop environment (via systemctl
set-default, then at the console I use "startx"
that brings up Xorg and the no-frills vtwm window manager.


Zoom worked fine up to version 5.17.5 (2543) and hasn't worked since
because of the above menu problem.

Yes, it sounds like you are having the same problem as user42 and me. I have managed to open a ticket with Zoom about this using my company account, we will see if the Zoom developers respond.


In the meantime if you have set a focus-follows-mouse policy in your desktop settings, you can try to change to a click-to-focus policy to see if that helps as well. In the ticket I opened with Zoom, I wrote:



With a "click to focus" setting the Zoom client behaves correctly, however this is not an acceptable workaround. The Zoom client should be usable with any reasonable desktop configuration.


I'll keep this post updated with any progress on the ticket. If anyone else reading this who has a paid-for account is having the same problem, perhaps they could try to take it up with Zoom support as well? That way they know that I am not the only person who is having a problem here.

Thanks for this solution. I am using Linux mint and I have the exact same problem. Changing my settings to "click to focus" worked.


They responded to my ticket, asking for screenshots. Since screenshots can't really illustrate the incorrect behaviour, I gave them a couple of short videos showing the difference between versions 5.17.5 and 5.17.11. Let's see what they get back to me with.

I have no idea if the ticket is visible to anyone other than me, but just in case anyone else can see it the ticket number is TS0858206 

Thank you very much for following up on this, it has been driving me nuts! I found the issue for me was that I had my focus set at "focus strictly under mouse". If I change to "focus follows mouse" then that works as well as "click to focus".

Thanks for that. Could you tell us which distro/version of Linux and which desktop you are using?

I'm using Kubuntu 22.04 LTS on a MSI Stealth GS66.


As others have indicated switching to "click-to-focus" does rectify the issue, but also utter changes how a user interacts with their desktop environment.


An alternative is increasing the time before the focus follow the mouse.  While the popup does still disappear, I've found that increasing the time does give me enough time to make the change I need (audio/video) without altering how I interact with my desktop environment.


The last that I have heard from Zoom on the progress of my ticket about this issue was on 25 March, telling me that the issue was with their team, and asking me to wait for an update from them. I haven't heard anything more from them since, but I'll post here when I do. I guess that we just have to be patient, and stick with verison 5.17.5 in the meantime.


Same problem here... Debian 12, XFCE4 and focus follows mouse.  Changing to click-to-focus is a non-starter for me; that policy makes the desktop unusable for me.

I've downgraded to 5.17.5 for now


I can confirm that the problem DOES NOT EXIST in latest version,

Looks like it is fixed in this version.  

I am seeing flickering though, so I suspect that the problem might come back.  Looks to me like the menu close functions aren't coded right.  

Thanks for the heads up, a quick check shows that the issue seems to be fixed in this version for me too. I'll wait until the next time I have a meeting to be certain.

The behaviour of the menus was always a bit strange for me, time and a few more updates will tell if the problem has really been fixed.