cancel
Showing results for 
Search instead for 
Did you mean: 

Mic develops an echo only when sharing (I think new Windows 21H2 update broke virtual cables w/Zoom)

parksanim
Observer

Currently having issues with my microphone, receiving audio into Zoom that came via Virtual Audio Cable, but only when sharing something with sound enabled.  The mic works just fine when not sharing.  It also works fine if I do not use a Virtual Audio Cable / OBS Studio.  Unfortunately, I need the OBS and Virtual Cable to add exciting effects for my classes -- running Zoom just plain-jane is workable, but not the end goal.  I will note that my entire set-up works just fine on another computer at home, and has for a year.

 

See video here, and pay attention to what happens when I share:

https://youtu.be/l25b4H7K3wA

https://youtu.be/l25b4H7K3wA 

 

I think the recent Window update may have messed things up with my virtual audio cable and how Zoom "hears" it, but only while I share?  This problem does NOT happen if I simply go directly from my mic into Zoom.  It only happens when I route through a VB Cable (or Voicemeeter Banana).  All diagnostics for the VB audio products are clean, with OK driver test results.


Currently, my setup is a behringer mixer with mic into the computer via USB.  I am feeding that directly into OBS Studio.  I send that out via VB Audio Cable A Input, then use the VB Audio Cable A Output into Zoom's Mic.  Zoom's Output is to my headphones.  (Note:  I've used other programs, like VoiceMeeter Banana to feed the audio, and same echo problem occurs in share, so it's not an OBS settings problem).

So I'm at my wits end as to why I am getting echo when sharing?  I'm running the same set-up on a different computer at home, and no problems.

This problem situation is happening on a Windows 10 21H2 updated Asus notebook.

1 ACCEPTED SOLUTION

parksanim
Observer

Ok, I think I might have somewhat solved it.  I could not get the problem fixed through OBS, but I am able to send my audio through Voicemeeter Banana now, and just combine it separately with my OBS video (along with a video sync delay filter to match it).  I can now share the Voicemeeter Banana tweaked audio in Zoom, and have no echo issues.

The problem SEEMS to possibly have been the Intel Smart Sound Technology audio drivers, so I just uninstalled them and turned any off which seemed to want to reappear.  For whatever reason, these drivers do not seem to play well with my laptop and VB-Audio Cables.  I also suspect the MyASUS software, which tries to take control over mics and sound, may be somewhat of a culprit involved in the mess, too.  Right now, I have also turned off the Asus sound reduction software within that app (because it introduces a delay, anyway).  

I'll keep monitoring how it works, next week.  I tried several times, and it seems to be working.  If it is all good through next week, I will mark this as an accepted solution -- disabled and/or remove that Intel Smart Sound Technology in Device Manager.

View solution in original post

7 REPLIES 7

Chito
Observer

Hi,

In the video you posted, you mentioned that the issue does not exist in your home setup. Is your home setup also updated to Windows 10 21H2?

 

Have you tried using Voicemeeter's device check to see if the audio drivers were installed correctly?

Yes sir, thank you for the reply.  I did use VoiceMeeter Banana's check, and initially had an issue, but it was fixed by using their tool to uninstall and reinstall.  No errors in Voicemeeter banana's driver check tool.  Unfortunately, my Zoom share with audio problem has not changed.

 

Another suspect could be the MYAsus program or some other Asus-oriented utility that may have been installed with the Windows 21H2 update.  When I was having the problem for the last 2 weeks I decided to completely refresh windows and reinstall. It seemed my problem had gone away, after a short check immediately after a full Windows refresh, but then after Windows updated itself again to the newest version (and I also found some Asus programs updated themselves) then the problem appeared again.  I do not have these Asus programs on the working computer because that is a home-built desktop with a different companies main board, as well.  I've tried uninstalling the aces program and it didn't seem to do anything after a restart that fixed it. I still have the same issue.

 

My home desktop computer (works great) is also on version 2182 of Windows 10, however, it is Windows 10 pro and my notebook computer that currently has the problem is Windows 10 Education.

 

I would also like to reiterate that this echo problem only happens when I share in Zoom and simply sending the audio to zoom for regular use does not cause the issue to happen even when using the virtual audio cables. so there seems to be something happening only while sharing which is hearing both my microphone and a copy of itself twice?  I also wanted to mention that it doesn't matter what kind of microphone I use with this computer it produces the same echo effect when sharing, so it is unrelated to the current main microphone I use or its driver.

Hi,

I tried to replicate this issue, however the conditions of an Asus machine on Win 10 Education I cannot reproduce. As with your home machine, I also did not experience this when screen sharing. Have you tried screen sharing with and without the share audio button? I'm wondering if it is catching your "monitored" audio as well as your broadcast audio.

 

I'm assuming you're using a win 10 education on the laptop as it is a work provisioned machine? I apologize that I'm unable to provide further insight into this.

I'll give it a try in a few days, when I return to work.  In the back of my mind, I seem to remember trying that, to no helpful effect.  But I will try again.


I agree that it appears to be catching 2 audio streams.   I have speculated that the MyAsus software may cause a driver issue (and perhaps replace or damage a driver) once installed, as it has some control over sound/mics. I have attempted to shut off or remove all of that.  I still have problems with this double-sound issue while sharing, using either OBS or Voicemeeter Banana to feed my audio, so it's not either of those which is 100% the problem. I might add that I am not very familiar with how Windows keeps changing around the Record, Playback, and other tabs related to Mics, under settings.  I have tried every different setting there than I can think of.

Thank-you for helping so far.

Chito,

Here is another YouTube video where I share the audio with and share without audio, as well. As you can see, I only seem to have the problem when Shared Audio is enabled.  

https://youtu.be/oF2mSvlsrwA

That's interesting to know, however, I'm not sure what to do with it, next.

parksanim
Observer

Ok, I think I might have somewhat solved it.  I could not get the problem fixed through OBS, but I am able to send my audio through Voicemeeter Banana now, and just combine it separately with my OBS video (along with a video sync delay filter to match it).  I can now share the Voicemeeter Banana tweaked audio in Zoom, and have no echo issues.

The problem SEEMS to possibly have been the Intel Smart Sound Technology audio drivers, so I just uninstalled them and turned any off which seemed to want to reappear.  For whatever reason, these drivers do not seem to play well with my laptop and VB-Audio Cables.  I also suspect the MyASUS software, which tries to take control over mics and sound, may be somewhat of a culprit involved in the mess, too.  Right now, I have also turned off the Asus sound reduction software within that app (because it introduces a delay, anyway).  

I'll keep monitoring how it works, next week.  I tried several times, and it seems to be working.  If it is all good through next week, I will mark this as an accepted solution -- disabled and/or remove that Intel Smart Sound Technology in Device Manager.

View solution in original post

Hi, It's good to hear that you've isolated the issue and hopefully this becomes a longterm solution. Please keep us updated if this is the case.