cancel
Showing results for 
Search instead for 
Did you mean: 

Intune MSI config

dfairley
Listener

Hi,

 

I have an Intune LOB MSI setup with:

/quiet /norestart ZoomAutoUpdate="true" ZConfig="EnableSilentAutoUpdate=1;ZoomAutoStart=1"

 

I added ZoomAutoStart after I first deployed though. I've since pushed a few updated MSIs and they deployed okay, but the ZoomAutoStart setting isn't taking effect. Zoom isn't starting on boot. Are the config options only applied if it's the first time installing?

 

Cheers.

1 ACCEPTED SOLUTION

So the solution is to pull AutoStart from ZConfig? The documentation says "To enable additional options, append the ZConfig parameter to the end of your install choice.". That's why I added it there - because I already have ZoomAutoUpdate as an option...

View solution in original post

3 REPLIES 3

YaBoiB
Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hello @dfairley,
My name is Brandon. Thanks for joining the Zoom Community!

EnableAutoUpdate

  • For EXE, it is true by default

  • For MSI, it is false by default

  • The app will not auto-update if the current Zoom version is higher than the stable global version and lower than the latest version. Only if the user clicks “check for updates, “the app will update. If the Zoom version is lower than the global stable version, the user will see an updated banner on the Zoom app home tab. If the user doesn’t click update it, Zoom will auto-update to the stable version when the user restarts the Zoom app.

  • If you set EnableAutoUpdate to false, the “Check for Updates“ option won’t show up.

Try this script here 

  • { msiexec /i ZoomInstallerFull.msi ZoomAutoUpdate=true ZConfig="EnableSilentAutoUpdate=true }

  • EnableSilentAutoUpdate: (Additional Notes)

Default policy is enabled.

This policy depends on EnableClientAutoUpdate, if EnableClientAutoUpdate is disabled, EnableSilentAutoUpdate will not work, even if it is enabled. (For msi package, EnableClientAutoUpdate is disabled by default. For exe, it is enabled)

If this policy is enabled, client will auto update itself silently.

If this policy is disabled, client will auto update itself and prompt users the update dialog.

If this policy is not set, client will use the default setting.

Let me know if the results are useful for your MSI needs for your users. 

 

I hope that this is helpful. 

B!

 

If this response was helpful for you, please do not forget to click on the accepted solutions button!

YaBoiB
Community Champion | Zoom Employee
Community Champion | Zoom Employee

Sorry, I forgot about your AutoStart question as well. I assume that you know this but just want to be thorough. 

 

Auto-start with Windows: Disabled by default. To enable, append ZoomAutoStart="true" to the end of your install choice.

Example: { msiexec /package ZoomInstallerFull.msi /lex zoommsi.log ZoomAutoStart="true" }

If this response was helpful for you, please do not forget to click on the accepted solutions button!

So the solution is to pull AutoStart from ZConfig? The documentation says "To enable additional options, append the ZConfig parameter to the end of your install choice.". That's why I added it there - because I already have ZoomAutoUpdate as an option...