Showing results for 
Search instead for 
Did you mean: 

Zoom Rooms, Logitech MeetUp camera not working in Google Meet


Hi All, I have an interesting issue here.

We have a NUC PC running windows and on there we've got Zoom Rooms running. 
Connected to this we have a Logitech MeetUp camera. The camera is being recognised in Windows so that's all fine. 

When we start a Zoom call, all is fine and the camera works. However! When a Google Meet call is started the camera doesn't work. 

What I've checked? Till now I've only checked with a new cable as the one used wasn't looking all that great. I'm not sure what else to check. Does anyone have an idea what I could try?



After thinking about it some more I have tried the following:
- Windows update, make sure we're running the latest version
- Zoom Rooms update, make sure we're running the latest version

- Checked the permissions for the camera in Privacy and Security settings. 

- Tried another USB port

- Checked if camera is working with Google Meet in Browser

- MeetUp Camera firmware update to latest version with Logitech Sync app


Nothing has worked. 
So the camera is working with everything except a Google Meet call. This is running through the interoperability wit Google Meet and has worked before. Actually, it's working with one of the three rooms but two are not working.


This seems to me a permissions issue as everything else seems to work just fine.