Showing results for 
Search instead for 
Did you mean: 

People can't join my meeting

Not applicable

For some reason, Zoom keeps not letting participants join, citing "The host has another meeting in progress". While I did hav the meeting OPEN, this has never been a problem before and has always allowed participants into the waiting room. Waiting room is enabled, as well as the setting to allow participants to join before the host has arrived. I don't know what to do. EDIT: I'd also like to point out that I even tried leaving the meeting and having them try to join, but it just switched to "Waiting for host to start meeting."



Did you ever find a solution to this problem of participants not being able to join giving the error "The host has another meeting in progress."  I am having the same problem, HELP!!

I am having the same problem. Have asked for help but so far no response.



I am having the same problem

Did you get a solution?




Please provide support for this.  Clients and family members have both reported this issue to me when trying to join my meeting. I tried to log on with my work account on another device and got the same message.

This is preventing me from using Zoom (I switch to Teams or Google Meet) and I'm not sure I want to renew my subscription.


Community Champion | Zoom Employee
Community Champion | Zoom Employee


I have seen this happen before as well!


(If you want the official technical reason for this, please see this article: the TLDR version is that Non-business accounts cannot have more than one meeting at a time. )


I can tell you that the most likely reason this is occurring is one of the two following scenarios:


1. The prior meeting being left open by the host. If you need to host a concurrent meeting as a non-business account, please ensure you have fully closed out the previous meeting upon leaving it. You can do this by clicking "End Meeting For All" instead of the "Leave Meeting" button.


2.  The second reason this could be happening is because someone else started a meeting on your account without you being in that meeting. This can happen if you have enabled "Allow participants to join before host". If this is causing issues, make sure you disable this option so that users cannot start a meeting on your behalf. This can be problematic if they started a different meeting than the meeting you wanted people to join. More information about this feature can be found here:


Please let me know if this resolves this for you! 




Neither of these situations exist in my case. People are getting the same message as above. I leave that meeting, close zoom, reopen it and send another invite - however it’s a different meeting ID with different password, and people still can’t join!

Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hi Eloise!


Yes, of course, if the information here didn't resolve your issue, you can use our other support resources:

Hi Micah,

This doesn't apply to the difficulties I am having. I am not logged on nor is anyone else that would allow for Zoom to think a meeting is already in progress.

This continues to happen, as recently as last Saturday.

Please send more solutions for this as it doesn't really feel like Zoom is replying to this issue. Is there a better HELP or CONTACT US link that can be used. This platform seems like a weak way to address user issues.

Thank you,


Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hello, if you are starting the meeting and it has a different meeting ID and pw, then you may be clicking "New Meeting" from the home screen of the Zoom app, this will cause the issue.


Instead, you should be sure you are only joining the prescheduled meeting by clicking on the meetings tab of the Zoom App and selecting the upcoming meeting.


You should also ensure that no other meetings are running simultaneously (either because they were started and left open, or because you allowed other people to join before host). 

thats not applicable in my case as my settings prevent this; nevertheless I continue to have this embarrassing  problem that zoom refuses to address. We need a fix, not  more of the party line answers.

Ok folks, I don't know if this will solve the problem for everyone, but this is what I did to address it.  I have a recurring meeting that I would send an electronic link to certain folk,  other  folk I sent just the  the meeting number and the password via a brochure.   When I started my meeting only one of these two groups could get on the meeting. If I started the meeting from the link that I sent out- the folk that I had not sent that electronic link to, but had the same meeting information and password on the brochure, could not join the meeting. (So frustrating)

I discovered that  Zoom has an invitation link for my recurring meeting that was different.  When I would start my meeting from the Zoom web portal it automatically used that invitation link.  I discovered that the link I was given by zoom that I used in the electronic link WAS NOT THE SAME  as the invitation link on the web portal.  (this is totally messed up)  Because of this Zoom thought I was starting a new meeting whenever (my participants) would try to join the meeting using the meeting number and password.  My participants would receive "host has another meeting already in progress " while it was the current meeting that they were trying to join. Here is what I did to address the problem and salvage my professional integrity:


If you have a meeting that repeats as I do,

1. Go to 

2. Click on your meeting information. 

3. After you click on your meeting information, click the green shield, in the upper left hand corner.

4. After you click the green shield- you should see a link that says "view invitation link," click and you will now be able to view the information.

5.  Copy and send this invitation link to your participants. 

6. Start your meetings from the above invitation link or

7. Your participants  will now be able to join your single meeting without receiving a message that you have two meetings going at the same time.


Since I have done this, I have not had any more issues with people receiving a message that I already have a meeting in progress.    

Hope this helps- 


Same problem here:

- no other meetings active

- Guest 1 attends through the link in the calendar invite

- I open the meeting with its specific name and time (only one scheduled so no confusion possible) in the iOS app

- I see Guest 1

- Guest 2 tries to join through the email link and gets the message that another meeting is is progress

- odd thing: when I copied the meeting details to send by email, there were 2 different passwords in the auto-generated text (copied below with some anonymization)

- I have a business account (but probably not much longer)


[NAME] is inviting you to a scheduled Zoom meeting.
Topic: [NAME]'s Personal Meeting Room
Join Zoom Meeting
One tap mobile
+31707006526,,8134812151#,,,,*[SIX NUMBERS]# Netherlands
+31202410288,,8134812151#,,,,*[SIX NUMBER]# Netherlands
Dial by your location
        +31 707 006 526 Netherlands
        +31 20 241 0288 Netherlands
        +31 20 794 0854 Netherlands
        +31 20 794 6519 Netherlands
        +31 20 794 6520 Netherlands
        +31 20 794 7345 Netherlands
        +34 917 873 431 Spain
        +34 84 368 5025 Spain
        +34 91 787 0058 Spain
Find your local number: LINK

I am having the same issue- so frustrating and not easy to fix. I went to settings, tried youtube tutorials but the problem persists. Zoom if you are listening-help.

I found a solution, please read my 10/3/2022 response to myself.


I am having exactly the same problem described for the last few weeks, even since I upgraded ( think (imagine that!)... I am a counselor and offer sessions and talks online and this is becoming a nightmare... obviously, the issue is becoming pandemic.... Please help! (As the others, the possible issues you described do not apply in my case). 

Please see my reply, posted 10/3/2022



Has anyone figured out how to resolve this? I’m having this exact same issue.

Please see my reply to myself posted 10/3/2022


Thank you thorche for your post.  I have been dealing with this issue and today it became ridiculous.  My participant could not enter the room.  I did a number of things to address this issue, and I'm not sure why it is working now, but I think one of these steps made the difference:

I signed into my account online with zoom - went to  Then I went to my profile and settings
I turned off the option for to "allow attendees to join meeting before the host"

(this is in the "schedule a meeting" section)


I started the scheduled meeting and did two things:

Hit the "security" icon on the bottom of the zoom screen and made sure "enable waiting room" was checked

Clicked the green shield icon in the upper left corner , which showed the meeting id and passcode, as well as the meeting link.  I copied the meeting link and sent it to me participant so they could just click the link and join the meeting.  Thanks again for this tip thorche!


Anyhow, I think the key step may be the turn off the "allow attendees to join before host" option in settings. 
Zoom - please address this problem in a clear way for people.  It ruined a scheduled meeting of mine and it's obviously a problem for others too.


My issue is with using the instant feature for the private meeting room (PMI). no one can join once I've opened the meeting. They get the very same message as everyone else are having with regular invite meetings.


I have a related problem. Nothing happens when my Zoom guest clicks on Launch the meeting on their end Tried three times in a row. No joy. Never had this problem before. SOS.


Hi all! 


Thank you for your contributions to this thread. have some tips to share regarding the issue of a Zoom host having another meeting in progress. Our support team has created an article dedicated to this problem: Zoom Host has another meeting in progress. I suggest checking it out for specific guidance. Just follow the instructions provided in the article to address the issue. 



Zoom Community Team

Carla (she/her/hers)
Zoom Community Team
Have you heard of Zoom AI Companion?


This is the same solution we have all already tried and been given. The article is incorrect, it does not only affect web or desktop, affects mobile app too.


User schedules a meeting using the zoom app on mobile (in my case, iOS). User then sends the meeting invite via email. Participant clicks on email and is told that the user has another meeting in progress. The meeting organiser waits patiently for the participant to join the meeting. The participant asks the organiser why they are in a different meeting. But only one meeting has been set up.


In the meantime, over a period of years, Zoom ignores the issue and presents the same solution without ever properly understanding the problem.


I am also getting this regularly. It's causing real damage to my business at the moment. What is the solution? The solution provided here is, as has been stated, not correct and unhelpful!


Hiya, its sad to see that this problem with zoom has been going on for over two years now.
The solutions being offered are not practical or simply do not resolve the problem.
Consumer law protects in this case.
If as a customer (of which I am and many are) has problems such as the ones described above, yet the solutions that are given do not work or are not applicable, and still no resolution is reached and the problem persists (which it is)... is the responsibility of the company (in this case zoom) to approach each person individually, offering them a refund on the product theyve purchased as well as loss of any earnings.
Today, at 10:00a.m I lost another £50 (approx $58) as a result of people not being able to get into the Yoga class meeting I had organised.
Last week £30 (approx $38) lost on the same problem.
So far £80 (approx $88) in lost revenue.
I, personally believe this money needs to be paid back to me by zoom as the issue is not with me and all solutions offered have failed.
I await you getting in touch.
You have my email.