Showing results for 
Search instead for 
Did you mean: 

Zoom doesn't start when I join the meeting using a link.


Whenever I click on a link to join the meeting, normally I'm supposed to get a popup asking if I want to open zoom, and then I click yes & then zoom opens. Now it no longer works. The popup just doesn't appear anymore, Zoom also doesnt open. Because of this Im also unable to log in to Zoom using Google or Facebook since Zoom no longer opens. What should I do? I tried on both newer & older versions, I tried the latest but it still didnt work.


Zoom Moderator
Zoom Moderator

Hi @xuellont can you ensure you don't have pop-ups blocked within your browser? For example, as Zoom uses your browser when clicking on a hyperlinked meeting link, which you will be prompt to join from your defaulted browser. However, if popups are blocked or aren't allowed for, you wont be prompt to open the client and join. 

Zoom Community Moderator

Have you heard about Zoom AI Companion? ➡️ Check it out!