What's New at Zoom? Join our upcoming webinar to get you a first-hand look into some of our exciting new product and feature releases.

Register Now
cancel
Showing results for 
Search instead for 
Did you mean: 

Wayland screen sharing broken with GNOME 41 on Fedora 35

intrlocutr
Participant

Hi,

 

I recently updated to Fedora 35 with GNOME 41. This GNOME release restricts the screenshot API which Zoom has used for screen sharing on Wayland, so the screen sharing functionality no longer works (see here on Ask Fedora).

 

I require screen sharing for school, and I'm sure many others have a similar requirement/system configuration. With Wayland increasingly becoming a de facto standard on Linux, it is crucial that Zoom support Wayland screen sharing.

1 ACCEPTED SOLUTION

It's not a bug in xdg-desktop-portal-wlr, so I'm not going to create a pull request to add code that does nothing (if the client is behaving correctly...). There's already work on supporting to share only a region of the screen (https://github.com/emersion/xdg-desktop-portal-wlr/pull/156) which should coincidentally also fix Zoom.

 

Simply running Zoom with "env XDG_CURRENT_DESKTOP=GNOME /usr/bin/zoom" should be enough to make Zoom think it's on Gnome while still keeping dbus working.

 

Edit: This should not be marked as solution! If any, https://community.zoom.com/t5/Meetings/Wayland-screen-sharing-broken-with-GNOME-41-on-Fedora-35/m-p/... provides a workaround for the issue, which has to be fixed by Zoom!

View solution in original post

362 REPLIES 362

I made sure to check that before posting my comment and the upcoming release notes werent posted yet. 

The fact that it's not in the upcoming release notes is very concerning, and if they don't add it even after promising to add it (and us waiting for like 8 months), I am going to stop using zoom

They say something vaguely about screen sharing

 

  • Support for screen sharing and dual screen sharing fixes

I wouldn't be surprised if they hid the fix away, not exactly something worth advertising that they haven't supported wayland for like "the life of zoom up until now"

YaBoiB
Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hello All, 

 

 The release notes for the Wayland fix have been posted in the Linux Release notes

 

Please know that after this is released I will be attempting to get as much of your feedback as possible, so please respond to this thread if you have any. 

 

As always, thank you to everyone in this thread for their time and patience. It is truly appreciated. 

 

Regards,

Brandon 

If this response was helpful for you, please do not forget to click on the accepted solutions button!

This is great to see, thanks Brandon.

I'm on KDE plasma desktop , so hoping that the fix works there too. Will be testing on Monday for sure

hopefully they fixed the issue of zoom crashing (segfault) every time u try joining a meeting in kde lmao

> Resolved an issue regarding sharing content on Gnome 41 with Wayland 

 

If this has been properly resolved GNOME (any version) shouldn't be relevant: It'll work on any platform, inc KDE and the likes of Sway, that implement the standard screenshare API. I'm sure this is simply is a miscommunication, but, given the history of this issue, potentially a concerning sign.

 

(to be really pedantic, if you must mention GNOME - could zOoM kindly get the workmark right?)

 

Hijacker
Listener

Any news about the 5.11? 😅

Support chat report: due to some bugs the release has been postponed to July 3rd. We must therefore wait until July 3 to discover the next procrastination date.

Perhaps by then we will even get updated release notes, also: Release on a Sunday?

Yeah, so nobody will bother about it on a sunday night 😁

YaBoiB
Community Champion | Zoom Employee
Community Champion | Zoom Employee

@MarcoHijacker , 

 

 Zoom has always done its software releases on Sunday nights. 

 

Brandon

If this response was helpful for you, please do not forget to click on the accepted solutions button!

Now, I don't want to start getting silly - but as far as I know the 20th wasn't a Sunday

And in fact they postponed it to hold the habit 😅

phils1
Listener

I can confirm from my side that Zoom really has implemented this now properly and for me, it is working as expected.

Many kudos to @YaBoiB 

linuxdev
Listener

The rpms on the download center look like they haven't been updated.  The webpage claims that you're getting 5.11.0 but if you run rpm -qpi on the rpm, it's still 5.10.7.   

The same here.

idkman
Attendee

idkman_0-1655830086145.png

wow fixed a lot (I am on 5.11.0 btw, with kde plasma)
pls remove this check, If you really fixed it, it should work on all DE's

edit:

THERE IS A WORKAROUND

firstly quit zoom in the tray, then open terminal and type this in,

XDG_CURRENT_DESKTOP=GNOME zoom

(you can also add that env variable to the desktop file to not do this with terminal every single time until they fix it)

and you should have fun with screen share, I have no idea why zoom forgot to remove this check, but nonetheless still disgusting to see the Linux port being neglected like this (still even after 8 months 🤦)

Where did you get 5.11.0? I go to the download page and it still only mentions 5.10.7. Also, I wish they didn't do those gatekeeping checks. I run Debian unstable, so Zoom's compatibility check is usually wrong. I wish they were more like Discord -- screen sharing hasn't had issues and none of these checks I have to work around.

in the zoom client, go to about zoom, and then it should say update available (click it), it will bring you to the download page, then download the one for ur distro and it is magically the new version, I have no idea why.

This was on arch linux, so your luck might vary

I tried that earlier (and just now) as well. No luck. It says I'm up to date. I guess they are rolling the update out to some % of users first.

Does screen share actually work after that? Confirmed?

I'm trying it on wayland, and the recipient only sees a black screen

Also, when recording the session, only a black screen is seen too.

I am on kubuntu 22.04

no it didn't

seems like the screenshare thing itself probably uses that variable somehow

MarcoHijacker
Listener

Maybe last users commenting didn’t see:

 

“Support chat report: due to some bugs the release has been postponed to July 3rd.”

that is false, I have 5.11.0 on my computer right now

I tried to download it this morning and the 5.10.7 was present. I actually checked back seeing the 5.11 right now. Maybe support operator was uninformed at this point, but they told me release date was postponed. Anyway, will test the release once back home. 😉

YaBoiB
Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hey Team, 

 

 I am waiting for confirmation from @SivenZ that the release is in the 5.11.0 version. Still, some of you are correct that we release the software in waves for capacitance issues on the servers, so some may already be on 5.11.0, and some may be on 5.10.7, but please know that 5.11.0 will be coming to you very soon. 

 

We are optimistically waiting for this Team's feedback and want to thank you all for the kind words and assistance with this undertaking. According to my visibility, the release went out on the 5.11.0 version on June 20th. 

 

Thanks again, 

Brandon

If this response was helpful for you, please do not forget to click on the accepted solutions button!

vaslabs-ltd
Listener

I have also tested with 5.11 and it seems to be working flawlessly. 

I have to point out that when issues like this appear , it still shows that some companies don't understand the Linux community. Just show a warning and let people still test it on their distros anyway.

Anyway, for us this is good news and thank you, we'll be doing an internal testing and if all good we'll probably get a pro license.

EDIT to clarify after some people reporting not working:

I'm on Fedora 36 and tested with somebody on the other end. I have 2 monitors and shared one of them and it worked. I will do more testing until the end of the week (as it's nigh time now here)

I don't think this is zoom not understanding the linux community, it's just zoom making a really really dumb mistake, by only supporting the GNOME desktop environment on an API that intentionally supports all wayland DE's. 

idkman
Attendee

I did some more testing, and screensharing is still broken, checking on another person's computer, all it says is [Insert name here] has started screen sharing with no actual screenshare

very disappointing indeed (I will restart my computer and check if that helps tho)

edit: still broken 🤦🤦🤦🤦🤦🤦, this update did not fix anything

I'm having this same issue.

mnasledov
Listener

So I installed zOOM 5.11.0 and verified that screen sharing works on my workstation. I'm running Debian unstable (bookworm/sid) with GNOME 42.2 / Wayland. Thanks for finally fixing this. (zOOM because they called GNOME "Gnome")

 

I really wish the fix could have been released sooner as a hotfix. I've had to ask co-workers to assist me with presentations as I couldn't share my screen and didn't have time to deal with workarounds.

did you check on another person's computer????

I am using KDE plasma and it is still broken, even with that workaround (cuz zOOM devs forgot that GNOME is not the only thing around)

edit: I am going to try modding the binary file to remove the check, if I succeed, I will post it here. 

I think you may be able to modify your /etc/os-release file to fool it. 

 

I did some digging and I think the binary uses this file to figure out which distro someone is running.

 

$ strings /opt/zoom/zoom | grep /etc/os-release
/etc/os-release

Alternatively, one could make an LD_PRELOAD hack that overrides open(2) and opens an alternative os-release version so one wouldn't have to modify files they shouldn't have to be modifying.

the problem isin't /etc/os-release

[it actually checks /etc/lsb-release don't ask me how I know]

but it's the fact that it is detecting GNOME through XDG_CURRENT_DESKTOP, and not allowing people to screenshare on non GNOME desktops with an api that is compatible with nearly ALL wayland desktops

zoom also appears to be doing some funky stuff with the system proxy settings (through gsettings and stuff), but I trust that they are doing it with a good reason...

I agree with this; it works for me, on 5.11.  I think I checked all the bits this time; sorry for my previous testing mistakes.  I confirmed that my desktop env was Wayland, I checked for updates from the client to confirm it was up-to-date, and I connected to my meeting from a second device and tested sharing.  The new sharing option is the one we've all be waiting and asking for, the native one, and the old, broken options are gone.

 

I note that I had to download the RPM twice.  On my first download, I got 5.10.7, which isn't shown in the filename, but I noticed when dnf was installing the RPM file.  I started it, anyway, and checked for updates to confirm the internal version number.  I went right back to the download page, did the exact same thing, and got a new RPM, which was 5.11.something. So, that's weird, but I got what I wanted by just being stubborn. Also, I notice the version number is still listed as TBD on the release notes page.

 

Last thing: I think the time may have passed on this issue.  I mean, it's been a long time.  I've found the web-based client to be more convenient and performs well. At this point, it bugs me more that the web-browser client doesn't support file sharing, which the only Zoom feature I've used that works on the native client but not the web-browser, than that the native client didn't allow sharing.  I do screen sharing regularly, but only occasionally send files, so naturally my focus has shifted.  So, thank you.  But, after all of this, I only use the linux client when I know I want to share files, which is rare, since there are so many other ways to share files.  I wonder if this is why more users didn't bother with this major bug?  I know I wouldn't have if I had started using the browser-based client 2 years ago.

What is the output of "rpm -q zoom" on your system with 5.11, then?

Well, I didn't run that exact command, but I used dnf to install it, which displays that basic pacakge information during the install process.  That's what I was trying to say in my post.  So, I'm sure it would say that if I ran it.

YaBoiB
Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hey Team, 

 

The Linux deployment has been slightly delayed for version 5.11.0, but it should be completed by tomorrow end of the day US time. Sorry for the inconvenience. I know that many of you have been waiting for a long time for this version to be released. I do not know the reason for the delay. 

 

Brandon

If this response was helpful for you, please do not forget to click on the accepted solutions button!