What's New at Zoom? Join our upcoming webinar to get you a first-hand look into some of our exciting new product and feature releases.

Register Now
Showing results for 
Search instead for 
Did you mean: 

Microphone keeps switching




I've never had this problem before but my computer seems to have 2 or 3 audio options that I don't fully understand.

1. Nvidia

2. Realtek


I think that one is for the inbuilt speaker in the screen while another one is when I plug in a mic and speaker probably.


The third option while in Zoom is system.


Anyway, in my Zoom session a couple of minutes ago, a screen kept appearing that the audio output had been changed and the sound kept switching from the speaker in the screen to the headphones every few seconds

I tried forcing Zoom to stay with one system  by making a choice in audio options, but this got overridden and the problem started again


After a few minutes, only the speakers in the screen worked and the headphones were dead which was hard as I had to take the headphones off and then could not easily use the microphone attached to the headphones


But why did I get this problem today? I have a really important Zoom meeting on 14Oct and I need to fix it before then


Thanks for any help in advance




Zoom Moderator
Zoom Moderator

Hey @SafeTex, sorry for the delay in response to your discussion! 


Are you still having this issue? If so, I'd love to help you get it resolved. 


Zoom Moderator 


Hi, help! I'm having this problem when I use zoom on my PC also. It's so inconvenient!

Hello- My mic keeps switching and it shuts down my camera. I have tried restarting my computer and reinstalling zoom but that didn't work. I would appreciate your help. 



@CarlaA I have a similar issue - audio keeps switching between my USB microphone and my external webcam microphone - worked fine previously, any thoughts?  thank you.

Thank you for your comment. I have experienced exactly the same problem, that the audio keeps switching between my USB microphone and my external webcam microphone. It usually works this way: I have set the auido input to my USB mic. When I start to speak after I have been unmuted or have unmuted myself, Zoom uses my webcam mic (I have heard this on audio recordings; no message about this on the screen), but after some seconds the audio input changes from the webcam mic to the USB mic. This doesn't happen all the time, but quite often. The interesting thing is that this problem started the 5th of October, only 2 days before SafeTex posted his comment about the similar problem. The problem started after I updated Zoom. I have tried to change all my settings, but cannot find any solution. I think there must be a problem with the Zoom update. Please tell me if you still have the problem.

I haven't used Zoom recently but the problem was never fixed. It just disappeared for the moment

oops I clicked on your post as a solution by mistake and now can't seem to cancel that



No ideas. the fault seems to have fixed itself for the time being but I never got to the bottom of it

Hi @ST1


Within your Zoom Desktop Client Audio settings, try setting the microphone to the desired device and do not select the box for "Automatically join audio by computer when joining a meeting". 



Let me know if that helps! 


Zoom Moderator 


I am having the same problem. I unchecked the "Automatically join audio by computer when joining a meeting" box and have selected the speaker (Pom Gear Stereo) I wanted to use.  I still have the problem of it switching between RealTek high Definition (computer speaker) and Pom Gear.


If there is a solution to this problem, I would appreciate a reply.

Where is the dislike a comment button? Is this a Mac problem or a zoom app problem? Changing auto volume does not do anything for which microphone is being used. It simply adjusts the volume of mic depending on how loud you are speaking. Why would you think that this would fix the problem?


Having same problem. The solutions suggested by Zoom Moderator CarlaA don't help. I too think this started as of the last update. Zoom constantly switches between the microphone on my closed laptop and my high-quality external microphone, popping up windows as it does. The microphone I've manually chosen in the "Audio Preferences" is the external but Zoom takes control and rapidly switches back and forth so that I come through so broken up that no one can understand me. I bought the external mic because even having my computer open and off to the side the built-in mic on the laptop doesn't pick up. The only way I'm able to use zoom at the moment is to run one session on my computer for video+speaker and a second as a call-in on my phone to be my "microphone." It would be nice for Zoom to trace this down and fix it. One solution is that Zoom could disable the auto-switching on the mic audio so that users actually do have control over their input source.


the solutions mentioned don't work for me either


Audio keeps switching from Mac speakers to my airpods even when they are in the case across the room. It started happening occasionally and now it's every 10 minutes. I lose audio completely for about 30 seconds (the other person can't hear me either) and then it rights itself. 

This issue is increasing. Today sound was interrupted about TEN TIMES IN AN HOUR. A huge message in white text tells me that the microphone/speakers are switching to another device and then about 30 seconds later, the message goes away and the sound comes back. My airpods are across the room in a case - there is no reason at all why Zoom should suddenly try to switch to them. Please fix.


I am having the same issue, and it does appear that this bug was created in the last release of Zoom.


Same problem here.  Started with plugging a usb webcam and swiching to its video and mic via zoom settings.


I came on here looking for a solution but looks like there isn't one. This is a problem for me and my colleagues every time we meet. Think we will need to find an alternative.


Same problem--  mine switches every few SECONDS!!  pls FIX THIS, Zoom!


Switch to web version. That fixed it for me


I'll pile on here too. Zoom, please fix this.


I'm the same person as CathrynL earlier in this thread. After extensive back and forth with Zoom technical support who couldn't solve the problem, I found a way that did fix it. I was having the problem on a Mac and the problem started with the app update from Zoom when MacOS (12) Monterey was released by Apple. I was running MacOS (11.6) Big Sur. I didn't want to update to Monterey immediately as it always takes a few updates before the new MacOS version is stable enough for my personal tastes. Eventually I checked and saw that version 12.2.1 was available and decided to upgrade to that version. The switch from 11.6 (latest version that was available) to 12.2.1 fixed the problem for me. Good luck to all. The bug in the Zoom app is terrible to deal with. If you write to tech support directly for help and stick with it they will try to help you. Recommend giving the chance to try.

I have a 2015 mac book pro running version 10.15.  Are you saying we need to jump to OS 12.2.1 to fix this zoom mic toggling glitch?  I am a standup comedian and just watched a recording if a gig as I kept seeing on the screen as I was performing that notice of the default microphone toggling between my the built in mic. with the one I chose for the zoom event: handheld SM58 mic via my rodecaster soundboard via usb   That glitch clipped so many punchlines.  UGH!! Not good for my comedy biz.  Do I have to upgrade to fix it?  I would think that zoom could fix it at their end, so it doesn't toggle.

None of the solutions that Zoom had me try worked. They were not able to help me though they did try. I understand your pain in dealing with the bug. I don't know whether it will work for you but  what worked for me was updating to MacOS 12.2.1 on my 2020 MacBook Air.

Thanks for this!  I am sooo motivated!  Will see if my old mac can update to 12.2.1

Thanks for taking the time to help 🙂 


This started happening to me all of a sudden last week.  Zoom refuses to pick the default microphone that I selected in the configuration when I join a new meeting, although the config itself seems to remember this is the intended default.  Very frustrating.

I worked extensively with Zoom on this problem when I had it. None of the things they suggested worked. I finally updated to OSX Monterey and that fixed the problem for me. Apparently this is a rare problem  relative to the millions of Zoom users so Zoom hasn't pursued finding the bug and fixing it. Recommend upgrading to the latest version of the operating system on your computer. If that doesn't work, suggest that you go directly to Zoom tech support. They were responsive in trying to help though in my particular case they didn't find a solution for me. It was when I updated to the latest version of the OS that my problem resolved. Good luck!


The microphone switching made Zoom a nightmare for me. During my switching period I had to login to every Zoom on both my computer (for the camera and to share screen) and on my phone for audio and mike. The key to making this work is to mute your audio on the computer so that all of the sound is handled by the phone. It is a bit to keep up with as you have to run the video settings on the computer but the audio on the phone. That's 2 devices each with an audio mute and video on/off. 


Good luck and I hope you find a resolution as I know how frustrating it is!!


Some progress seems to have been made on this - the system is not actively switching among available mics for me. But, every 10 seconds or so, it is popping up a note telling me my default microphone has changed to my external mic (a Røde USB model), and that is annoying. I'm still on Big Sur too, and have to be for a bit longer yet for reasons of other tools that are not going to survive in Monterey.  Zoom! Help!




I just had my worst Zoom meeting ever🤐

I kept losing sound in my headphones and in 2 hours , I was unable to see any logical explanation for the problem or its general behaviour
Sometimes ticking a specific speaker option would work, but at other times it didn't.

The system also continually offered me either 3 or 4 choices of speaker but why it toggled between 3 or 4 was unclear

At other times, it would flash up a warning of a change of speaker, I'd lose sound in my headphones for a few seconds, but then it would come back. At other times though it did not come back and I'd have to try all the options, but could only get the speakers in the screen to work. At other times, I could eventually get the sound to come back to the headphones, but only after clicking the 3 or 4 options available maybe twenty times until one suddenly worked.

A nightmare 😑