Showing results for 
Search instead for 
Did you mean: 

Can't share screen on a mac even after enabling under security & privacy


All of a sudden I just can't share my screen anymore on Zoom. The error message says to grant access via System Preferences > Security & Privacy, but I've already enabled Screen Recording for Zoom (see attached screenshot), so I'm not sure what other settings I should change.

I don't have any problems sharing my screen on other softwares (e.g. Cisco Webex or Windows teams), so this seems specific to Zoom.

For context, my OS is macOS Monterey version 12.4 and I'm running the latest version of Zoom. I already tried deleting and reinstalling Zoom but nothing changed.



You can try below steps:


Disable Remote Management
Switch to an Administrator Account
Connect Your Devices to the Same Network
Extend Display Sleep Timeout

J Wick


Hi Jimmy, thank you very much for your answer, unfortunately your fix didn't work. 


For context: 


Remote management is not enabled

I'm already logged on my macbook as an admin

I don't have secondary screens attached, I just want to share my macbook's screen

Tried extending it to no avail


One more thing. If I go to zoom -> settings -> Share Screen and I tick Automatically Share Desktop, I can share my screen but it only shows the background of my desktop, with no files on it and no open programs (even if I move to a different tab)



I too have a whole lab of iMacs with this exact issue. Did you ever find a solution? I tried everything under the sun with no success. I ended up wiping one iMac and reinstalled the OS. It functions properly now. But I still have all the rest to deal with now. These machines are managed and supervised using Jamf Pro.


Hi Brettw,


I have a very strong feeling Jamf Pro itself is the problem. It solved itself after deleting an reinstalling all profiles under System Preferences -> Profiles.


Let me know if this helps!