Introducing the new Zoom Community Champion Program where we recognize our most engaged community members for their contributions.

Learn more and join
cancel
Showing results for 
Search instead for 
Did you mean: 

Anybody else having problem with Logitech webcam with the new update on MacBook Monterey?

RR2
Attendee
106 REPLIES 106

RR2
Attendee

my cam is c922 Webcam Pro it lost its great video quality when I would only do Zoom. So it's only a zoom problem.

 

Hi @RR2 

 

Can you ensure you have "HD" selected in your Zoom Setting Video tab?

Hey, this is the same person who posted this. Yes, I did all the procedures (HD, Auto Light, and that other one) I even Uninstalled/Installed the zoom app.

another with same issue... zoom needs to fix this.

rommeldivina23
Listener

 I tried following all the procedures (HD, Auto light, and touch up) on how to improve your video quality. I even unistalled zoom and install it back again. However, I still have the same results. Everything was fine before upgrading to MacOS Monterey but after that I lost the quality of my C922 Logitech Pro great video quality in Zoom. It's still good when I FaceTime or Photo Booth. How do I fix this? Thank you.

rommeldivina23
Listener

 I forgot to mention that when I would toggle the HD, it’s good quality for a second and then switches back to bad quality without me clicking the toggle box

Have you tried toggling the Ratio button next to HD also?

 

Is your camera plugged directly into your computer, or via a USB hub?

Yes, i've tried toggling everything a lot of times.

 

My c922 logitech camera is usb port so therefore i needed an adapter to turn it into USB-C for my 2020 Macbook Pro but even before MacOS Monterey it was great and there was nothing wrong with with.

 

Now, my camera 's quality when I do zoom is just grainy and the background is light red. It looked like a nuketown...

Yes I have the exact same problem. Same camera. All fine until upgrading to Monterey

My adapter is not cheap it's an apple brand

robcresswell
Listener

I'm having the same issue on a Logitech C925e. Video is fine on other software (facetime, photo booth) but absolute garbage on Zoom since Monterey

stuew
Listener

Same issue with Logitech C925e on 2019 16" MacBookPro. Video blurry and dark. Video fine in Facetime. Was good before Monterey.

discothreat
Listener

Same issue.  C922s on 2021 14" Macbook Pro. Like permanent filter applied. Actually looks better with HD unchecked.

Okay I’ll try it and see if it’s better

Having same issue with my 925e after upgrading OS. I got blurry and also light lines in screen.  Have tried this one, but not working. Hopefully will get other options in here ..

Update: Wow! I tried it and the quality is back to normal now. You have to keep the app open. Thank you so much!

Thanks for the link discothreat! This corrected the issue for me as well and will work for the near term.

 

This is not desirable long term for me because it's another junk app that I have to keep running taking up resources and menu bar space when the camera works fine for all other video apps. The driver should be enough. So hopefully they fix the real issue soon so we don't have to cover it up.

Installing Logi Tune fixed my problem on my C922!!

After installing Monterey my webcam downgraded from HD.  Disabling the HD toggle on Zoom made it better but my wide-angle view became crappy. After installing Logi Tune, things went back to normal. It's probably a format or codec issue/bug with Monterey.

 

This worked!! Thank you 😄 

jakemauer
Listener

I'm experiencing the same issue with a Logitech C922 and Zoom 5.8.3 after upgrading to MacOS Monterey 12.0.1 .

 

This is NOT simply that HD mode is "off" in Zoom.

 

Zoom seems to be instantiating the video stream at a low resolution, regardless of whether or not you toggle HD Mode. The only thing that seems to fix it, temporarily, are loading an app that properly instantiates a high-resolution video stream like LogiTune or even the Logitech Gaming Software, which is what I was using previously as a workaround. 

 

So for now I have to launch my zoom meeting, turn on my video in zoom, then go to Logi Tune and open it so it shows its own video preview, which kicks the video stream into actual high def. I have to do this every time I toggle the video in Zoom or whenever I join a new call. 

 

 

Update : @jakemauer above is correct. Same thing is happening to me. Opening LogiTune in parallel to Zoom is a bandaid solution. I wonder when Zoom devs can fix this.

That's the fix I also apply, but this is annoying and extra step. I wish zoom kick in high resolution at start.

jdag
Listener

I have this issue too, and have found a temporary workaround completely by accident. As I was trying to figure this problem out while in Zoom I happened to check out FaceTime and noticed it would correct the Zoom image.

 

1) Have Zoom open and your external webcam active.

2) Open an app that uses the external webcam, such as FaceTime or Photo Booth.

3) Swap between the MacBook's built in camera and the external webcam.

4) Go back to Zoom.

 

Apparently, activating HD in another app seems to give Zoom a kick in the pants. I say this is temporary because if you turn off your camera you have to repeat the process.

 

Add this problem to the USB-C hubs not working and Calendar being incredibly slow when using Exchange accounts and I am now following 3 different bugs that have all cropped up since "upgrading" to Monterey. I deliver online training for a living. The Zoom issue is not insignificant to me. I may have to reinstall Big Sur.

Vitali
Listener

This is not resolved at all.

Some strange work-arounds that make zoom crash more often than not (like using another app to force zoom into HD mode).

I can toggle HD mode in zoom, but it just looks dark and blurry. If i open any other video app. it works just fine. 

robcresswell
Listener

@RR2 Can you remove the "accepted solution" please? It isn't a solution at all, nothing has been fixed, its just a hack.

2CBG
Listener

I have the same problem, I change my settings on C922, login into Zoom, C922 has reset to default  and cant be changed.

RR2
Attendee

Update:

after corresponding with the representative with zoom about this matter. It came down to the point that he wanted me to make an upgrade because it has HD when you pay for it and they will give you that. He also said that the reason why the video quality is like this is because zoom is being used all over the world and they have to degrade the video quality for free users. They said that it’s just too much and they couldn’t handle it and they have to do it like that… So, when you pay for the upgrade they will give you the HD.

@RR2  As @robcresswell says, this support person is completely wrong.

 

I am on a corporate paid account as well and have this problem. And it would not make sense for this issue to be corrected by running facetime briefly or Logi Tune if it was a service capacity issue.

robcresswell
Listener

@RR2 that's absolute nonsense and it's disappointing that the support person you spoke with has misguided you.

 

This is a common issue with this Logitech camera, as many people have confirmed. Please don't spread misinformation about requiring paid Zoom accounts and please update your Zoom support person to explain the issue.

 

I'm on a paid / corporate account and suffer from this issue, for example

Vitali
Listener

Yah, this is nothing to do with bandwidth. Im also on a premium corporate account. This does not happen with the same camera in Zoom on Windows. And it does not happen in other video calling apps on Mac OS Monterey either, Google Meet, Facetime, Teams all look fine. The problem should be somewhere in the Zoom Mac OS client. 



EDIT: Might be something to do with using camera through external USB hub that only support USB 2.0. I have mac Macbook Pro M1 connected to a dock. But still, works fine in all other apps, and it worked fine in Big Sur.

wintpe
Listener

im having exactly the same issue with the 922 pro on linux, when using the latest version of zoom. 

when i downgrade to a version, i happened to keep the rpm for the capability of selecting hd returns, and picture quality is restored.

this i a change that has happened in the last year or so,  as its only the second time im ever used zoom, ie xmas day covid secure present unwapping   as one member of the family has covid.

 

i found out because just before we started our meeting i stupidly clicked the update button.

 

but luckly i found an old version and proved itsvthe update that broke it, nothing else, its the zoom code thats broken, 

 

regards peter

This sounds like a different issue. As many people have commented, the option to pick HD isn't gone or disabled, it just doesn't work; regardless of Zoom settings the camera is incredibly blurry under OSX Monterey on Zoom, when it was fine on older versions of OSX.

 

It's been several months at this point so I've little hope that Zoom or Logitech will bother fixing it.

deregtd
Listener

Logitech C925e.  We're definitely on a paid enterprise account.  HD is enabled (can't even uncheck it).  Same symptoms as everyone else -- I can leave LogiTune running and toggle video on and off periodically to get back to good quality video.  But this is pretty abysmal.  @wintpe What version did you downgrade to?  I'll have to give that a shot.  This current situation is untenable and pretty embarrassing.

DavidWessel
Listener

I have a Logitech 920c and a Macbook with Monterey and an enterprise Zoom account.  Recently I have been suffering occasional flashes or flickering in the video but it seems to occur only when I have checked HD in preferences.

 

 

Robyn
Listener

After much effort, time with help deskers, and uninstalling and re-installing software, I found this is a known problem which Zoom appear to have no interest in solving.
Alternatives are Google Meet and Skype.

nickv
Listener

I'm also experiencing the same low-quality video issues using:

Zoom 5.9.0 (3377)

macOS Monterey 12.0.1

Logitech C925e webcam

This webcam setup works correctly with HD video in all other apps on my mac... Zoom is the only app that consistently shows blurry video, regardless of any zoom video settings being toggled. Specifically, I can confirm that the "HD" video toggle in this version of zoom appears to do absolutely nothing (if anything it makes the quality worse when turned on).

 

EDIT:  I upgraded zoom to 5.9.1 (3506) and the problem is still present. However, using logitech's logitune app (as suggested previously in this thread) does seem to provide a usable albeit annoying work around.

Robyn
Listener

I uninstalled the current Zoom version and reinstalled version 5.7.8 and problem solved.  Use google to find downloads of previous Zoom versions.  My version of Zoom was fine and then the problem occurred when I upgraded.

I tried this, but it didn't solve the problem.