Introducing the new Zoom Community Champion Program where we recognize our most engaged community members for their contributions.

Learn more and join
cancel
Showing results for 
Search instead for 
Did you mean: 

Zoom fails to start with undefined symbol: drmGetDevices2 on Debian

vsespb
Listener

Today I've got message that my version outdated and I should upgrade, otherwise it won't work. I upgraded to 5.11.3 (3882). After that zoom fails to start with:

 

ZoomLauncher started.
Zoom path is: /opt/zoom
cmd line:
Start subprocess: /opt/zoom/zoom sucessfully, process pid: 16139
/opt/zoom/zoom: symbol lookup error: /opt/zoom/zoom: undefined symbol: drmGetDevices2
Something went wrong while running zoom, exit code is 127.
ZoomLauncher exit.

 

I have Debain 9 with Gnome.

 

I checked all libraries - all of them installed:

 

libglib2.0-0
libgstreamer-plugins-base0.10-0
libxcb-shape0
libxcb-shm0
libxcb-xfixes0
libxcb-randr0
libxcb-image0
libfontconfig1
libgl1-mesa-glx
libxi6
libsm6
libxrender1
libpulse0
libxcomposite1
libxslt1.1
libsqlite3-0
libxcb-keysyms1
libxcb-xtest0
ibus

 

Btw, as a workaround - it there an archive with old but working versions?

 

3 REPLIES 3

KristaSmith
Listener

one of my clinicians had the same problem yesterday--she said it began working late afternoon but wasn't sure why it didn't work. She missed a client session because they couldn't figure out how to connect. 

doczoombat
Listener | Zoom Partner
Listener | Zoom Partner

In case anyone else hits this: drmGetDevice2 and drmGetDevices2 was added to libdrm  as of version 2.4.75.  libdrm part of the OS, not distributed with Zoom's software.  The previous version of Zoom (5.10.7) does not used this new API, so if you can a download a version of Zoom that predates 5.11, it should work with the older libdrm.  I really wish Zoom would stop switching to newer APIs because not everyone can update/upgrade their OS to the latest.  I am effectively stuck on 5.10.7 until I do a complete OS upgrade, which will not happen anytime soon.

Bort
Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hi @doczoombat 

This issue regarding the drmGetDevice2 dependency should be resolved in this weekend's release. That should help you continue using Zoom without having to upgrade your OS. 

 

Hope that helps and please make sure to mark the solution as accepted if this information is what you needed.