cancel
Showing results for 
Search instead for 
Did you mean: 

Microphone keeps switching

SafeTex
Listener

Hello

 

I've never had this problem before but my computer seems to have 2 or 3 audio options that I don't fully understand.

1. Nvidia

2. Realtek

 

I think that one is for the inbuilt speaker in the screen while another one is when I plug in a mic and speaker probably.

 

The third option while in Zoom is system.

 

Anyway, in my Zoom session a couple of minutes ago, a screen kept appearing that the audio output had been changed and the sound kept switching from the speaker in the screen to the headphones every few seconds


I tried forcing Zoom to stay with one system  by making a choice in audio options, but this got overridden and the problem started again

 

After a few minutes, only the speakers in the screen worked and the headphones were dead which was hard as I had to take the headphones off and then could not easily use the microphone attached to the headphones

 

But why did I get this problem today? I have a really important Zoom meeting on 14Oct and I need to fix it before then

 

Thanks for any help in advance

 

 

70 REPLIES 70

David-Hubbard
Listener

I am having this problem too

 

RussLowenthal
Listener | Zoom Partner
Listener | Zoom Partner

Same problem here - every few minutes. It makes zoom almost unusable. I'm on 5.11.11 (8425) on a Windows 11 pc

 

billy1
Listener

I am having the same issues!

perfectpitch22
Listener

Like others, I came here looking for a solution and instead find there doesn't appear to be one.  My selected speaker and mic inputs keep switching between all available options.  Not only this, but each time they switch the "Professional Sound" option I've previously selected is disabled. Please suggest a fix Zoom.

Bodhi
Listener

I am using Zoom on Mac and used a USB Microphone and then had similar problems - from time to time I got a notification screen that the USB Microphone used switched to the built in microphone of the MacBook. Then after a couple of seconds, it jumped back to USB Microphone - leaving my Meeting Recording with unpleasant and clearly noticeable audio differences while speaking.

 

I will now try the following (maybe solution?) :

 

In the Zoom Meeting Audio Options (where you can mute or unmute yourself and where you can set your used microphone for the meeting) there is an option to chose "Same as System Settings" - if you chose this one, the microphone used, should be fixed on the System Settings Microphone. I went into the System Settings and chose the USB Microphone and did not experience any switching for a while.

 

But I haven't yet tried this on a longer meeting - so have to see if this works in the long run or not.

Bodhi
Listener

Okay bad news: I just tried it for a longer meeting - the switching keeps happening, even if system settings are the source of the chosen microphone. 

comtec101
Listener

Had this same problem. Constantly switching between loptop mic and blue snowball mic every second. Turns out my USB cable for my blue snowball was bad. Swapped to a new one and issue is gone.

TKinDC
Listener

Same issue. Mac Pro (intel based) using the latest version of app and OS. Completely new Yeti nano. Will try to do the cable trick.

DAX
Listener

Same issue with Windows. My Headset is connected with Docking Station. When my desk neighbor in the office speaks, the standard microphone automatically changes from headset to microphone in the notebook. This results in short interruptions and I get a pop-up message (see screenshot). How can I prevent the microphone from being changed? 





HibsMax
Listener

update: go into control panel sound settings, select the recording tab, disable all input devices you don’t want to use. That way Zoom can’t flip flop. 


I have the same issue on Windows 11. I want to use my Beats headphones for speakers and my Tula microphone. That was working, but then Zoom kept switching to my webcam microphone even though it was sleeping. I disconnected my webcam and then Zoom kept switching my mic between my Beats headphones and my Tula mic. Apparently, nobody on the Zoom call could hear a difference, but for me, the sound through my headphones kept changing (even though Zoom was reporting a mic change). Argh. It's good that this doesn't affect how people hear me, but the constant popups and changing sound in my ears is extremely annoying.

Why does Zoom not have a setting so use a specific headphone and mic combo and just leave those settings alone? I don't want it to automatically switch for me. I have Auto Adjust disabled, but that didn't change anything.

SafeTex
Listener

Hello

The only solution I found for this was to return to SKYPE;

The moderator tried to help but her advice does not seem to work for most of us and she has disappeared from the discussion.

So Zoom is out of the question for me at present.

Ditto, Zoom desktop client is currently unusable due to audio issues; switching microphone AND speakers, so I cannot effectively speak or listen.

Workaround, I use ONLY Zoom video on desktop PC, connect via Android tablet for audio, USB wired headset to tablet.

Audio works fine in this format.

LisaV2
Listener

My zoom is switching microphones as well.  We bought a multiple mic system and I change the audio setting and then sometimes it switches back to my internal mic.  I have an apple upgraded to the latest Ventura OS.  Very frustrating,   I wonder why Zoom cant fix this.  

Endnoter
Listener

Same problem here.  I had to choose my iPhone microphone and then things worked.  Forget about the camera microphone, or my desktop mic.  Zoom just switches back and forth every second between them (and the default system mic).  Running Ventura 13.0.1 on a desktop 2019 Mac Pro (not the laptop) with 96 gigs of memory.  This is a terribly inconvenient problem and am looking for a fix soon!

CristinaMuntean
Listener

Zoom is literally killing me. 

These days I am shooting my online course via Zoom and recording my new podcast. In the middle of a lesson or episode Zoom switches the mics and I need to either stop untill his mightiness comes back to my proper mic, or I need to start recording the lesson again. 

I never had this problem in three years since I am using Zoomr egularly. The problems started after the list absolutely mindless app integration dump that Zoom executed earlier this month that killed my computer and workflow. I don't have money to buy a more expensive laptop and upgrade to the latest Windows version, for Christ's sake. Why, why are you doing this to your users when we are already so stretched and you are already not doing your job right in connecting with people and companies usiung the Microsoft products? This is an absolute killer job and if it doesn't get fixed soom I will need to leave Zoom altogether. 

@CarlaA @zoommoderator

billy1
Listener

I think I have it figured out. I had to delete all the available devices, as Zoom or Windows 11 auto-scrolls through them for some reason. I went to Settings / Sounds and deleted every "Output" speaker and "Input" - microphone device except for podcasting headset and external microphone. This worked for me, and I hope it works for you! 

 

CristinaMuntean
Listener

Hi @billy1 thanks a lot, that sounds like a way around the bug. I scanned my Zoom system, both in browser and on the desktop, and I couldn't find the Settings / Sounds you described. Could you be so kind as to indicatewhich version you are using and whether you are using Apple or different hardware / system? Thanks a lot, much appreciated!

billy1
Listener

changes are made in Window 11, not Zoom.  Settings / Sounds / Input-Output. Only keep what you need. 

openmindshypno
Listener

hey everyone - I had to come here to realize that the switching from my realtek to my yeti microphone only happened on zoom calls.  As a hypnotherapist this REALLY wasn't working for me!  I literally just realized that my headphones microphone does NOT do this back and forth so I have found a resolution but I'd love to find out why this is happening in the first place.  With so many of us experiencing the same issue it clearly is something on zoom's end and the responses that I've read through as solutions haven't made an iota of difference.  Maybe try YOUR headphone microphone??  It has worked beautifully for me.

 

RickM1
Listener

I think this is less of a Zoom issue and more of a Macbook thing. Try turning off handoff on your Macbook and your iPhone one. Also on iPhone one turn off continuity camera. 

I haven’t t had the issue since doing this. 

on Macbook

system settings -> general -> AirDrop & Handoff

 

on iPhone

settings -> general -> AirPlay & Handoff

Not a Mac thing, happens on Zoom running on Windows PC

willjoe2442
Participant

Follow these steps:
Click on the Windows icon.
Type "sound" in the search box and open the sound control panel, or click on Control Panel and select 'Sound'
Click on the "Recording" tab.
Select "Microphone" and click on "Properties"
Select the "Enhancements" tab.
Check the "Disable all sound effects" box.

 

Regards,

Will

What? I don't have any of that my Chrome OS running Windows 7?

 

FieldsForest
Listener

I am having the same issue for the first time. i plugged my headset into a different USB port and it seems to work now, but I am now out of USB ports to try if the problem starts again. I'm on an HP, so it's not just a Mac issue.

SafeTex
Listener

Hello

 

Does anyone get this too with other programs like Skype? I've started to get it there too and it's getting worse whatever the program. Could this be a much wider issue across Windows

fron8861
Listener

Hello,

It seems like you're experiencing audio switching issues during your Zoom session. This problem can occur due to various reasons, such as conflicting audio settings or driver-related issues. Here are a few troubleshooting steps you can try to resolve the problem before your important Zoom meeting:

  1. Update Audio Drivers: Ensure that your audio drivers for both Nvidia and Realtek are up to date. Outdated drivers can sometimes cause conflicts and unexpected behavior. Visit the respective manufacturers' websites to download and install the latest drivers for your audio devices.

  2. Set Default Audio Device: Right-click on the speaker icon in the system tray (bottom-right corner of the screen) and select "Open Sound settings." Under the "Output" section, set your desired audio device (e.g., the speakers in your screen) as the default playback device. This will prevent automatic switching between devices.

  3. Disable Exclusive Mode: In the Sound settings window, click on the "Sound Control Panel" link on the right side. In the Sound properties window, navigate to the "Playback" tab and double-click on your desired audio device. Go to the "Advanced" tab and uncheck the "Allow applications to take exclusive control of this device" option. Click "Apply" and "OK" to save the changes. Repeat this step for all your audio devices.

  4. Adjust Zoom Audio Settings: Open Zoom and go to the settings menu by clicking on your profile picture, then selecting "Settings." In the settings window, navigate to the "Audio" tab. Under the "Speakers" section, select the specific audio device you want to use (e.g., the speakers in your screen). Ensure that the "Automatically adjust volume" option is disabled. Click "Save" to apply the changes.

  5. Test with a Zoom Test Meeting: To ensure that the audio switching issue is resolved, join a Zoom test meeting (https://zoom.us/test) and verify that the audio output remains stable without any automatic switching. If the problem persists, continue troubleshooting or reach out to Zoom support for further assistance.

Remember to perform these troubleshooting steps ahead of your important Zoom meeting to allow time for any additional solutions or support if needed. Good luck with your meeting, and I hope these steps help resolve your audio issue.

"In the Sound settings window, click on the "Sound Control Panel" link on the right side."

Don't see any "Sound setting window" or "Sound Control Panel."

Are you referring to Windows or Zoom?

Thanks fron8861

I've had another stab at solving this problem today using your advice but I'll now have to wait for my next Zoom meetings I also bought a new set of headphones and mic with a USB connection instead of the jacks but then saw that others have had the same problem with a USB connection. Similar problem on Skype too and I see that people have it on Macs so it's something pretty general, but what?

Oh PLEASE! You've got every OS on Every Computer with Every possible workaround and thats the best you can come up with Drivers? Which of course shifts the blame back to us doesn't it?

David_R
Listener

Discussion w/ Zoom tech support yesterday, "uninstall Zoom, use ZoomCleaner, then re-install." 

Did all that, no change-switches randomly among microphones and speakers.

I think I added this already, but this happens ONLY on PC.

Work-around, I log into meeting on PC but disable PC audio, log into meeting on Android tablet over WiFi, audio works fine, and video on PC works fine, meetins goes OK. But still . . .

perpetualv
Listener

For me the answer seems to be in fron8861's post - turning off "allow 

To do this:

<windows-R> Control Panel

Sound

Double click on your preferred audio device

Click Advanced tab

Uncheck "Allow applications to take exclusive control of this device"

perpetualv_0-1691060409739.png