cancel
Showing results for 
Search instead for 
Did you mean: 

[Linux] Regarding Nvidia+Xwayland/Wayland

lolsniperftw
Listener

Hello,

 

I have opened a ticket regarding an issue I had with Zoom crashing on Nvidia when using Wayland session (and also at the same time filing a bug to Nvidia https://github.com/NVIDIA/egl-wayland/issues/63 in which I discovered it is an issue on Zoom's end). The reason I am trying to use on Wayland is because Xwayland is showing a blank window when opened (which turns out is an issue on Zoom's end as well).

 

The support representative I talked to in the ticket was helpful and tried to get a response from the engineering team (which never came) regarding the response I received from Nvidia in the github issue I linked here.

 

Direct link to the response I received from Nvidia: https://github.com/NVIDIA/egl-wayland/issues/63#issuecomment-1204312146

 

So I am raising it here as well just in case it can lead to a more helpful response. I am not expecting an ETA of course but just acknowledgement that it is being worked on.

10 REPLIES 10

JPLeB
Listener

I'm experiencing this issue as well. Zoom needs to upgrade its version of Qt from 5.12 to 5.13. As is, they're shipping an old buggy version of this library to users, which might have other issues besides this one.

Another thread where people have reported this same issue:

https://community.zoom.com/t5/Meetings/The-latest-Zoom-client-not-start-on-Linux/m-p/70035

 

Looking at when the fix was merged to Qt, it seems the appropriate version should be 5.15 and not 5.13.

So I did more digging into QtWayland and QtWebEngine source code and it seems that implementing the fixes to Zoom will be more complicated unless they skip ahead to Qt version 6.3.

 

The QtWayland PR only begins to appear in 5.15 : https://github.com/qt/qtwayland/blob/5.15/src/client/qwaylandwindow.cpp#L251

 

and the Chromium PR that made it into QtWebEngine only made it in 6.3: https://github.com/qt/qtwebengine-chromium/blob/9a8385241542eaad285501be6dc66d96a76c20aa/chromium/co...

 

JPLeB
Listener

Fellow "video application used by millions of people" OBS recently upgraded to Qt version 6: https://github.com/obsproject/obs-studio/discussions/6481

 

Seems good to not be stuck on a deprecated version of a GUI library. I hope this is in the works at Zoom.

Yeah I know about that.

OBS were always up to date regarding the Qt version I believe.

I will be surprised if Zoom makes the jump from 5.12 to version 6 but it is required to get everything to work unless they backport some of the changes to the version they use.

gameking505
Listener

I've been having an issue with Zoom crashing and I finally landed on this thread to find the root cause. This is disappointing. Seems like nvidia users on wayland are out of luck if we want to use Zoom.

 

lolsniperftw - let me know if you ever found a workaround

daveman1010220
Listener

Is there any work-around that will help a Linux+Wayland+Nvidia user to work with Zoom at this time?

Nope.
Right now you can either switch to X11 or use Zoom on the browser (Firefox should work fine afaik).

Thanks for the info. I'll try the browser. There are good reasons to begin switching over to Wayland. Zoom is the only application that is giving me any problems, so I can't justify not switching anymore.