Showing results for 
Search instead for 
Did you mean: 

Turning on virtual backgrounds in Linux


I am experiencing difficulty in enabling virtual backgrounds on the Zoom application for Ubuntu Linux (Version 5.17.1). Despite the computer being capable (as proven by successful background modifications in Microsoft Meetings), I cannot achieve the same in Zoom.

Attempts Made:

Searched for the ZoomMedia.ini file, including in /etc/zoomvdi/ and ~/.zoom, but it was not present.
Tried the find command (sudo find / -name ZoomMedia.ini) without locating the file.
Considered creating a ZoomMedia.ini file, but lacked specific configuration details for virtual backgrounds.

Could somebody please provide guidance on how to enable virtual backgrounds in Zoom on Ubuntu Linux? Specific instructions on locating or creating the ZoomMedia.ini file, if necessary, would be highly appreciated.


Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hi @Mex,

       Thank you for reaching out to Zoom Support! Please review the following ( :

  1. Check In-App Settings:
    • Even though it's not officially supported, see if the virtual background option is available:
      • Go to Settings > In Meeting (Advanced) > Virtual Background.
      • If you see it, switch it on and see if this will allow the VB to start working

  1.  Locate & Edit the ZoomMedia.ini File (if needed):
    • If the previous option wasn't there, here's how to edit the ZoomMedia.ini file:
      • Find the file: Use the command sudo find / -name ZoomMedia.ini. If not found, please also check ~/.config/zoomus.conf.
      • Open it: Use a text editor (e.g., sudo nano ZoomMedia.ini).
      • Add a line: Find the [FEATURE] section and add SMARTVB=1.
      • Save and restart Zoom.

  1. If Unable to Locate, then Create ZoomMedia.ini (if necessary):
    • If the file doesn't exist, create a new text file named ZoomMedia.ini in one of these locations:
      • ~/.zoom
      • /etc/zoomvdi
      • ~/.config/zoomus.conf
  • Add this content:
    • [FEATURE]
    • Save and restart Zoom.

If this information helps resolve your problem, please like and accept as a solution so that this content can help future client questions.

Compatibility Note: Not all Linux systems and hardware fully support virtual backgrounds yet as this depends greatly on the GPU, RAM, OS versions, drivers, etc. 



Already tried the first step, that's why I was looking for ZoomMedia.ini (which doesn't exist on my machine). Added the line to zoomus.conf, and now I can add backgrounds if (and only if) I turn on green-screen, this is not an ideal solution though as the green-screen I have is smaller than the frame of the video so what's outside of the screen still shows defeating the object of doing it al at. And there is no blur option.


If I go in through the web interface, both blur and (no green-screen) background replacement work without issue, so it's clearly not an issue with the computer. I know I can use the web interface as a workaround, but I'd prefer to use the official program for Zoom and my browser for other web stuff.


Is there anyway to get the software to do what it's meant to do?

Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hi @Mex,

    Can you please provide the following so we can verify the system requirements located here,

  • Please provide your:
    • Device Make/Model - 
    • GPU/Processor - 
    • RAM amount -
    • OS Version - 
    • Zoom desktop app version - 


As I said above, it's not a hardware problem as it works fine via the web interface. It's an issue with the Linux software (Version 5.17.1 as stated in the OP).