Showing results for 
Search instead for 
Did you mean: 

Zoom Room Freezes


Having issues with Zoom Rooms on a newly installed Dell Optiplex.


We never reach the main screen, when the application starts we get a blue screen that says "Connecting" and has a spinner to show that it is loading. This spinner freezes shortly after it starts and we are stuck on the "Connecting" screen.


We have left this for over 24 hours to see if it's a slow connection issue, but it stays on this. The only thing we can do is CTRL+ALT+DEL to exit out, as any buttons on the screen do not work.


We have tried reinstalling (both 64 ad 32 bit versions), changing the DNS on the machine, flushing the dns on the screen, removing all USB devices from the machine, tried over different internet connections but all have the same issue.


Attempted to downgrade as well, however the downgrade process doesn't seem to work.


Noticed a few posts on here having similar issues, so don't think it's an issue with our setup, but at the same time I can't see any issues on the Zoom status page. Anyone have an idea for fixes?



The downgraded kicked in after I done another reinstall, and it took it back to v.16, this resolved the issue