Showing results for 
Search instead for 
Did you mean: 

Zoom Doesn't Recognize my External Camera




I am using a Win 10 laptop. I have an external Logitech webcam that is not working on Zoom. It works fine with other meeting clients like Google Meet and GoToMeeting. The drivers are updated. I have tried on different laptops and different USB ports without any luck. The problem is just with Zoom. I can see the virtual background, if selected, but there is no image.  No other app is using the camera. Any suggestions?




Community Champion | Customer
Community Champion | Customer

Hi @NJ11 


This may be a security setting, where Zoom did not gain permission to access your camera in Windows.


Please check your Windows Camera Privacy Settings and ensure that Zoom is listed as an allowed application - as below:




If that makes no difference, try right-clicking your Zoom icon and choosing Run As Administrator. 


Hope this helps. Post back with any news.




Hi Rupert. Thanks, but it is still not working. I have tried on  two different computers.

Community Champion | Customer
Community Champion | Customer

Hi @NJ11 


A few more things:


Which model Logitech webcam do you have - something like a C920 or a Brio?


Could you make sure you are running the 64-bit version of Zoom:


And could you try toggling off your Hardware Acceleration options under Video > Advanced in Zoom.







Hi Rupert.

I am using Logitech C270HD.

I reinstalled the 64-bit version. 

There are 4 options under  Hardware Acceleration - I deselected all of them together and then one at a time.  Still no luck.

Appreciate your time

best wishes

Community Champion | Customer
Community Champion | Customer

Hi @NJ11 


Okay then. A few more steps/questions...


Is the camera listed in Zoom - and does it just show a blank or grey image (if you don't have Virtual Background? Or is it not even listed?


If it is listed in Zoom, can you try boggling the HD and Radio options under your video preview.


Are you also looking for Zoom to use the camera for microphone? Could you try selecting a different microphone source in Zoom, then restart Zoom.


You mentioned Google Meet and GoToMeeting. Can you ensure all those apps and tray icons are fully closed. Then close Zoom fully, including system tray. Then disconnect and reconnect the camera. Then open Zoom. 


Could you try downloading the Logitech Webcam Settings app and maybe looking for a default-reset for the camera:


Does the webcam have an LED light on it when in use in other apps - and does that light come on when in Zoom?



Hi @Rupert 

I am not using the camera for microphone. Camera is listed in Zoom and shows a flickery image when no virtual background is selected (see attachment). The light on camera comes on when selected same as it does on other apps. 

GoogleMeet and GoToMeeting are not running in the background. I have also switched off Zoom completely and restarted without any luck.

There is no option to reset camera in the logitech setting. The setting, however, has two options - Standard and Widescreen. The Standard option gives me the flickery image like the one attached. The widescreen function works fine. One issue could be that Zoom is using the camera as standard and not widescreen (not sure if it is a possibility or a setting that I can change - I am just guessing). Probably this camera is not compatible with zoom.

Best wishes

Community Champion | Customer
Community Champion | Customer

And you have tried flipping the HD and Ratio settings under your video preview?





Yes I did


I have this problem too.  It looks like Zoom has had this problem for a number of months.  I've seen no posts about actions to fix.  Unfortunately I'm moving away from Zoom as a result.

I just uninstalled the current Zoom version and reinstalled version 5.7.8.  Problem solved!  Use google to find downloads of previous versions.  My Zoom was working fine until I upgraded.

Definitely a Zoom problem. I had to downgrade back to 5.6.4 to get the camera working again. 

The camera worked fine before a Zoom update sometime last year. Now, it's recognized but shows a gray background. Version rollback fixed it.

How do I Downgrade to an earlier Version?