Showing results for 
Search instead for 
Did you mean: 

Unable to screen share in ubuntu 22.04


I installed zoom on my freshly installed ubuntu 22.04 LTS and I faced a issue where i was only able to share whiteboard instead of my screen and there is no option other than that. How can i enable screen share? Is there any problem because ubuntu adopted wayland instead of xorg?



Same problem here with latest zoom version (5.10.4) on ubuntu 22.04. LTS. No screens/apps displayed in Screen Sharing. 

I am also facing the same issue I updated my ubuntu yesterday and when I want to share my screen there is only one option in basic WHITEBOARD and in the advance options there is a portion share, I tried with portion share but it only shows a black screen, but I am able to see to my video during screen share on the black screen

Zoom community please tell the solution of the problem, is this from your side or the Ubuntu side. Thank you 

Community Champion | Zoom Employee
Community Champion | Zoom Employee

My name is Brandon. Thanks for joining the Zoom Community! This is a known issue as others have described. Zoom has created a Support article regarding this issue here This article was created to keep everyone up to date on any changes or any future fixes. 


I hope that this helps. 




Brandon (he/him/his)
Zoom Community Champion
Have you heard of Zoom AI Companion?

This is a useless "fix".  We're still stuck with the same issues.  

Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hi @toddpedlar


 We are working on a more permanent solution in the 5.11.0 version that should be released on June 20th. Please standby for that release. 




Brandon (he/him/his)
Zoom Community Champion
Have you heard of Zoom AI Companion?

The issue with Ubuntu 22.04 is using a display feature called wayland. Wayland is not supporting to screen share by default. In previous ubuntu version we had xorg for display feature. If the above command outputs, wayland, then your system is using wayland.




I just realized that I was launched into Wayland after the upgrade to 22.04... If I log in into GNOME XORG, zoom screen sharing  is possible.. I did not use wayland before. I had also a few other problems with multiple monitors, which are gone in xorg. 


I have the same problem, also on Ubuntu 22.04 on Wayland. Screen Sharing used to work on Ubuntu 21.10 , also on Wayland (but only for the whole desktop, not single app windows), but not on KDE Wayland. On Xorg it always works, but it is extremely painful to switch the display server every time just to open a Zoom meeting. I would appreciate a timely solution to this problem.


One workaround I found is to join the meeting from a browser (Chrome and Firefox both work), then you can share the whole desktop or single windows. This is good enough for the time being, but not very comfortable and has higher system load than the standalone Zoom app.

Thanks for the workaround... That might help me until zoom receives a bugfix.


same as me, there's no option for any windows. hope it would be fixed as soon as possible.


ubuntu 22.04



Having the same issue on Ubuntu 22.04 LTS with the latest Zoom desktop client version 5.10.4 (2845)


Reporting same issue with Zoom, Webex and Skype - affecting all share screen functions - not just a Zoom problen - Wayland ? Trying Gnome



try to do this

Search to the custom.conf in /etc/gdm3/


sudo nano /etc/gdm3/custom.conf

uncomment the line
#WaylandEnable=false to be WaylandEnable=false


then reboot



Thank you for the solution! it works for me. everyone should try this

Thank you very much. You just saved me from rolling back to 20.0.4.

Thank you for the fix, it worked for me, 

Everyone try this.

It helped me, but now my video is gone. Webcam showing black screen

Thank you so much! It was the solution.

Thank you bro! It work for me! You're cool!

It works for me! But now switching between desktops doesn't work

It can be solved this way, I followed the instructions on this webpage when gesture of three fingers swipe for switching between desktops doesn't work on linux ubuntu

This solved the problem in Zoom for me, but unfortunately it created another problem: my whole screen turned yellow (similar to this:

I managed to fix it by changing the colour options in Ubuntu 22.04 by going to Settings > Device Colour Profiles,  then removing the colour profile for my monitor, and replacing it with "Colourspace: sRGB". Now my screen is functioning normally, and Zoom is also functioning normally.

Thanks man, this was really helpful!

Works for me. Thank you very much.

Your easy-to-use method saved my time, I spent more than a week trying to fix this issue but without success. Thank you so much!

This worked finally. Take it as final solution. Thanks


nice. It worked.

This worked for me.

  • Zoom (3738)
  • Ubuntu 22.04.3 (Kernel: 6.2.0-35-generic)


Thanks man, this helped!

created account just to say THANK YOU!


I have the exact same issue on 22.04 LTS - only whiteboard sharing available, nothing for screen sharing.  Zoom also frequently crashes while attempting to use the "share" feature. 

  • Restart your system
  • There is gear icon (bottom right side) on login screen
  • Which have two options. First one is Ubuntu which is Wayland by default and another one is Ubuntu on Xorg.
  • You have to go for Ubuntu on Xorg

thank you for providing clear GUI instructions for how to switch!

Thanks a lot, it's work!

The Xorg solution works, but the Zoom developers should still try to get it to work on Wayland as well, as it is the new default and Xorg will be deprecated sooner or later.

this is the correct answer. thank you so much.
best answer



Same thing happened with me. I wanted to share the screen and record it. It Just didn't show any option except whiteboard. It allowed me to share part of screen. When I watched the recording it showed nothing but just blank screen. Because of this I switched back to Ubuntu 20.04 immediately...!


Is there a solution that does not involve reverting to