cancel
Showing results for 
Search instead for 
Did you mean: 

Blackmagic Ultrastudio Mini Recorder

Geoh
Listener

Hello all:

 

I am new to the Community.  Thanks in advance for any help.

 

I have been using a Blackmagic Ultrastudio Mini Recorder to connect a Nikon D750 successfully with Zoom on a 2019 Intel MacBook Pro for over a year.  Current software is Monterey 12.1.  All was fine.  However, after updating to Zoom 5.9 and 5.9.1 I no longer have connectivity. Blackmagic Ultrastudio Mini Recorder still shows in the available cameras, but no longer has available video.  Only show a black screen. 

 

Has anyone had a similar issue and found a fix?

60 REPLIES 60

RJ_Phillips
Listener

I am having a similar issue... someone please help fix this!

I have tried using Terminal to resign Zoom as in the past to no avail.

 

Geoh
Listener

Found a workaround using OBS (Open Broadcaster Software).  It's free and easy to set up.  Now my Nikon D750 is running HDMI through the Blackmagic Ultrastudio Mini Recorder into my MacBook Pro.  In Zoom, I select OBS Virtual Camera and Zoom 5.9.1 is working.

Just downloaded and tried this solution. It didn't work  . . . any other ideas?

We have a slightly different set-up to you, but passing through OBS VIrtual Cam before Zoom fixes our fuzzy green scrambled video issue.

AntonM
Listener

Help…same issue! 

revgirrl
Listener

I started a trouble ticket with zoom, but only solution so far is to go back to 5.8.6 and not upgrade. This isn't sustainable for long. I will post if I get a solution . . .

D2Motivate
Listener

How do you find version 5.8.6

 

 

Thank you but link says access denied.

So sorry. I got the link from zoom support. Perhaps you can start a new trouble ticket with them for the real problem and get a working link from them for in the meantime.

GCP
Listener

Same issue with UltraStudio HD mini. Mac OS 12.1; Zoom 5.9.1 (3506)   I have six clients with various BMD configurations. Yikes! 

I will tell my support person that I'm not alone, but perhaps we should all start trouble tickets so zoom fixes the issue? My problem is with my Macbook Pro running Mojave 10.14.6, but I really do think this is a zoom problem.

I had a similar issue with Zoom and mini recorder. Zoom did not enumerate all the different formats that the mini recorder can support. I was able to download version 5.8.4.2421 and it now works again. You can get it here: https://zoom.us/client/5.8.4.2421/Zoom.pkg

I was using v5.8.6 as a workaround just fine until I had to use the Zoom Events platform. It will force you to upgrade before you can join the lobby for any event. My last 2 gigs used Zoom events so I was forced to find another way to solve this. I tried using terminal to resign Zoom app and that didn’t work either. I ended up using another brand video capture box. The Aja U-tap works just fine so I’ll be using that until this is fixed. 

AndrewLo
Listener

Same problem here with Zoom 5.9.0 and 5.9.1. 
Running MacOS Monterey with a BlackMagic Studio Camera and BlackMagic UltraStudio 3G Recorder. 

PhilAmand
Listener

Same problem here with a BM Studio recorder. I've also tried with a Decklink 8k Pro installed inside my Mac Pro with the same issue.

recursivecodes
Listener

Same issue here. And I can't downgrade on my corporate machine.  Fix, please?

hkjazz
Listener

Did ZOOM version 5.9.3 improve this issue? I'm considering to update to new version.

It did not fix it for me. I get a green screen instead of my camera output.

Yep Inalso get a fuzzy pixelated green screen! Immensely frustrating!! 

This is exactly what I am seeing too.  Works fine with my Wirecast, Teams, OBS. etc.

Did get something like this?

That is the type of image I get with the Recorder 3G in Zoom 5.9.x. It works fine in 5.8.6.

Yep that’s it!! Grrrrr

Exactly same for us. So frustrating.

Nope no such luck sadly. Ive bought a Logitech Brio as an interim fix but the quality is not as good as I need.

nope

+1 on did not fix anything. Ending up with fuzzy green screen.

Didn't work for me for 5.9.3

Did not fix this issue for us either. We're going to try going back to version 5.8.4.2421

fredfred27
Listener

I am using a Blackmagic Recorder 3G for video input. It works great under 5.8.6, but gives me green static under 5.9.1 and 5.9.3. I am running Catalina 10.15.7 on a 2019 16” MacBook Pro. My Blackmagic drivers are up to date (12.2.2). Hopefully this can be solved on Zoom's end.

I'm getting the same messy greenish screen. My workaround is to use ManyCam for my BMD camera because it works fine that way. Good thing, because ManyCam didn't use to support BMD, but now it does.  I worked with a zoom tech for awhile to try to fix the problem, but alas it is still not fixed. I've also pointed them to this message board in case others would like to help their techs troubleshoot the problem.

 

THanks revgirrl.....Zoom needs to wake up here! @Zoom...why so long for a fix impacting MANY users?

I found a workaround that works for me on MacOS:

 

OBS to Zoom via NDI for MacOS

 

Download OBS: https://cdn-fastly.obsproject.com/downloads/obs-mac-27.1.3.dmg

 

Install OBS: obs-mac-27.1.3.dmg

 

Instead of watching the video below, you can just read my shorter instructions after the video link.

 

Video guide found here: https://www.youtube.com/watch?v=yuwJ84f6E4I

 

My shorter instructions:

 

Download two installers found here (direct links to both below for the versions available on 2/1/2022): https://github.com/Palakis/obs-ndi/releases

 

Install this runtime:  https://ndi.palakis.fr/runtime/ndi-runtime-4.5.1-macOS.pkg

 

Then install this plugin:  obs-ndi-4.9.0-macOS.pkg

 

Download NDI Tools for Mac (found at bottom of this page): https://ndi.tv/tools/

 

(NDI/HX Driver for Mac is included now in the above installer and not separate as stated in the video guide.)

 

Install: NDIToolsInstaller.pkg

 

Open OBS

 

Under Sources below click the + and add your input device

 

Tools > NDI Output Settings > Check mark Main Output > Main Output name: OBS > Click OK

 

Start NDI Virtual Input

NDI (on top tool bar at right) > YourMac.LAN (OBS)

 

Start NDI Video Monitor (You only need to do this to set up and check if all is working. Don’t need to open it in the future.)

NDI (at top LEFT by NDI Video Monitor menu) > YourMac.LAN > NDI Virtual Input

Check that video and audio are coming through as you want.

 

Install Zoom: https://zoom.us/download

 

Open Zoom

zoom.us > Preferences > Video > NDI Video

zoom.us > Preferences > Audio > NDI Audio

 

Hopefully all is working well.

 

Now that we are set up. Close NDI Video Monitor, NDI Virtual Input, OBS and Zoom.

 

To start up a new meeting:

 

Open OBS and make sure your device is the source

 

Open NDI Virtual Input and at the top RIGHT of the tool bar: NDI > Select YourMac.LAN (OBS)

 

Open Zoom and make sure the video and audio preferences are for NDI and are working.

 

Join a meeting and enjoy.

Thanks. I tried OBS and it didn't work for me, but ManyCam is super easy and is working great. No instructions needed for ManyCam. You download it, click the + in the source frame, then webcam and the camera shows up. Easy peasy! Then in zoom just choose ManyCam broadcasting the BMD camera. It was also easy to adjust the resolution to get a sharper picture.  <https://manycam.com/> ManyCam has a free version, but you can also buy an inexpensive lifetime subscription to remove their logo from the video. Best to everyone! 

Thank you for the advice but way too complicated for me! Where is the promised "plug and play" future?

MightyBS
Listener

Still reporting the same issue.  Something I have found is that some signals work.  For instance my Sony camera and my MacBook Pro output produce this green garbled image, but the output from my Raspberry Pi works just fine.

 

Additionally OBS, BM Media Express, etc show the picture fine where Zoom does not.  At this point I've downloaded an older copy of Zoom where it works to get by for now.

 

In this thread seeing ManyCam as a suggestion makes me want to check that out.  I've also used the OBS Virtual Cam successfully, but I don't always want to be using OBS when I want to use this camera with Zoom.

MikeStarkov
Listener

Same issue on macOS Monterey 12.2.1 M1 Max, Zoom 5.9.1