Showing results for 
Search instead for 
Did you mean: 

Latest update messed my last meeting


Device: Computer (Windows 10 x64)
Version: Latest (related to this date)

Hello everybody!

I'm just a Zoom user and aways as client. Last time i needed to enter on a important meeting Zoom aplication messed up everything with his last update! To let everything worst the update it's fully required, then the update failed at installation. Tryed again and same result. So i decided to unninstall and download the installer from official website. Everything was fine until the installation. But... the apliccation it simple does'nt start anymore!!

It's anyone else having the same trouble? Someone could give a help please?



I have the same problem, I've found no solution.


Is anyone else having the same trouble?



Last week, I started a thread within this forum, and there have been some "me too" replies to it.

I installed an older version, and it works fine.

So, rather than trying to update, to see if the problem has been resolved, I use the older version.


In my case, i cannot downgrade the application because a message shows up telling me the update are required to join the meet. Probably because the host uses the latest version and worked for him. The only way to join a meeting it's through my phone. So frustrating for me.

I have the same problem and found the same solution. But yesterday zoom client automatically updated itself and again - it didn't start. Fortunatelly, it is still possible to install an older version and use it.

Where/how did you find the older Zoom version? And how have you ensured against an auto install of the later Zoom Version?

I've had the same problem and have determined my old imac with OS 10.15.7 needs to be macOS 11.0 or higher. 


Where did you find the older version of Zoom and how have you ensured the newer version of Zoom won't auto install?