Introducing the new Zoom Community Champion Program where we recognize our most engaged community members for their contributions.

Learn more and join
cancel
Showing results for 
Search instead for 
Did you mean: 

New: extension to enable “original sound” on Chromebook / others using Web client

MarcSabatella
Listener

If you use the desktop client for Zoom to share music, you probably know about the “Original Sound” option to disable echo cancellation, noise suppression, and other music-killing audio processing.  You may also have realized this option is not available on the web client - so, no luck on Chromebook.

 

It turns out it is possible to get this functionality using a free Chrome extension that I developed.  See:

 

https://chrome.google.com/webstore/detail/original-sound/ffhniinhbjmjakiabdojmfehdhnbcmdh

I developed this for my own use but am pleased to share it with all.  Feedback welcome!

4 REPLIES 4

PurplePianoCat
Listener

Thank you so much! I will check it out. Much appreciated. You should join the music teacher groups and let them know on Facebook!

Thanks - I did post this there already last week 🙂

AlanDorn
Listener

Hi Marc

Thanks so much for developing and sharing this.  I'd like to understand it properly to make sure I have Original Sound when I need it!  If I open the extension and disable the processing, will this be the default next time I start a Zoom meeting?  Or does it need to be done within the Zoom meeting each time?  And is there any way of telling from within the Zoom meeting whether the processing is disabled or not?  Many thanks, Alan

Good questions!

 

Unfortunately, I didn't see a reliable way to make the settings apply by default.  So you have to do it for each meeting where you want this.  Also, keep in mind the change doesn't take effect until you select a new input device - e.g., from "same as system" to "internal mic" even if that's not actually a change.  But then it remains in effect for the duration of the browser session even if you make further input device changes - probably even if you change meetings although I haven't tested that.

 

As for being able to tell if it worked or not, I don't have a better answer than to do a test.  Echo cancellation is very simple to check - just try playing some audio on your computer through the speaker (eg, watch a YouTube video) and ask others in the meeting if they can hear it.  If yes, you successfully turned off echo cancellation.  Or log in for yourself on another device (keep that device muted and use headphones!) and do a sound check before starting the meeting if that's convenient.  The voice optimization is tougher to characterize, but for me, if I play a sustained chord on the piano, with the voice optimization *on*, the sound cuts out ways too fast, - I guess it's misinterpreted as background noise.  But also, just playing music normally will sound garbled - a little like being underwater - if voice optimization is on.

 

A couple more things to mention while I'm at it.  First, if you turn off echo cancellation, you need to be listening to the meeting itself via headphones, or else there will be echo.  I usually set my system sound to my speaker but select the headphones within Zoom.  Second, a recent change in the Zoom app makes the Original Sound dialog not appear when you run the extension from within the meet - it is showing up on the main Zoom window, not the meeting window.  So you need to switch back to the main window to work with the dialog.   In theory it should work to just run the extension from the main window before you even enter the meeting, but it doesn't.

 

So it does take a bit of practice to get the routine down, but it's worth it!