Showing results for 
Search instead for 
Did you mean: 

Join Before Host is enabled but not working


Hi.  For the Zoom account for my synagogue, Waiting Rooms are disabled and Allow Participants to Join Before Host is enabled.  But it doesn't work.  Participants who attempt to log in before the host still get the "Please Wait for the Host to Start this Meeting."  Some setting must have changed but I can't figure out what.  Any idea why?  Thank you.


Community Champion | Customer
Community Champion | Customer

Hi @ljmossc77 


Are you using the Personal Meeting (Personal Room) in this account, or a separate meeting?


They have separate settings.


Do you have "Allow participants to join anytime" enabled on the actual meeting, either way?




Hi Rupert.  We always use the Personal Meeting Room.  Never do separate meetings.  So I have never looked at settings on the actual meeting but maybe you've given me something to explore.  Thanks.

Rupert, I have allow participants to join any time, and still it takes them all to the waiting room. It seems there is a new security requirement... (see below). I need to have all company users to get into the meeting with out waiting room or passcode. Please help

Require that all meetings are secured with one security option

Require that all meetings are secured with one of the following security options: a passcode, Waiting Room, or "Only authenticated users can join meetings". If no security option is enabled, Zoom will secure all meetings with Waiting Room. Learn more
Per new security guidelines, you cannot change this setting. Please contact Zoom Support for more information.


I have the same issue across multiple Zoom accounts. One paid and two free. Other accounts with the same settings work fine.


I have the same issue.  I also have multiple Zoom Accounts.  All paid.  3 work correctly based on the setting of "Allow users to join before host" but the 4th one always displays "Waiting for host to join".  I have validated the meeting settings and also the personal meeting room and from what I can see, they are correctly set up. 



You're not alone. I manage multiple paid accounts, and I see this problem, but only with one of them. I've set the "Allow to join before host" at both the meeting and account levels, but with the problem account, users still see the "Waiting for host to start", even though the meeting should be available. With that account, we just expect hosts to login and start, but they shouldn't have to.

Like the commenter a few months back, they're all paid accounts, and the settings look okay to me. It's not clear why  the one account doesn't work.


Is there any solution? 
I tried multiple scenarios, but all with the same result: "waiting for host".  It's a bit frustrating


Hi, I've got the same issue. We were able to join the meeting and suddenly today it is asking for the host to accept each participant. 
Has anyone solved the issue?



Faced with same issue
This helped for me
Meetings -> Personal Room -> Edit -> Options "Show" -> Check "Allow participants to join anytime" -> Save


Hey everyone, I have finally made it work on mine. 
Zoom required to have a security option in PRO accounts. 
Security option to choose is: 

"Only authenticated meeting participants and webinar attendees can join meetings and webinars", I've also added meeting name and company. 
Then, ENABLE waiting room and select all options that make users bypass waiting room.
Do enable:

"Allow participants to join anytime"

"Bypass the passcode when joining meetings from meeting list"


Hope this helps!!