Ready to set up and use Zoom, but aren't sure where to start? Begin with our onboarding support experience for everything you need to get started.

Get Started
cancel
Showing results for 
Search instead for 
Did you mean: 

"Failed to detect your microphone" message spamming

shayg
Observer

Hi,

 

Using linux client v5.9.3.

When I open the client and connect to a meeting with my mic disconnected, I get tones of those messages.

The only way is to switch tty and kill zoom as the whole X server slows down.

 

Can you fix?

11 REPLIES 11

Fahim_Shahriar
Observer

Same problem! Pretty annoying.

Nikos
Observer

same here, linux mint 20.3 (cinnamon edition, clean installation). zoom 5.9.3 (1911).

I don't have any mic or camera connected to the desktop, and these messages keeps on appearing (zoom cannot detect your microphone...)

 

thx in advance for fixing.

 

best

eet6646
Observer

Same thing is happening to me, crashes my laptop

 

Edit:  Figured out how to stop it for me. Essentially, it  starts spamming when there are 0 microphones to be found. I re-enabled my built-in laptop microphone and put it on mute, now when I unplug my external mic, it falls back to built-in and squelches the error. Very annoying.

embeddedt
Observer

I have the same issue with 5.9.3 on Arch. This notification spams the system and the only workaround is to always have a microphone plugged in.

dwetterau
Observer

I have the same problem on a pretty simple Ubuntu setup. Whenever I use a KVM switch to change my webcam to a different computer, Zoom just sits there and spams this message.

 

If I'm not in a meeting I don't understand why this message is coming up at all, let alone spamming me constantly and requiring me to kill Zoom every time.

alexfornuto
Listener

Zoom, this is a widespread problem. The messages steal focus when appearing and disappearing so one is unable to do anything else until they all clear or kill the Zoom client. Please prioritize this.

embeddedt
Observer

I worked around the issue by adding this at the bottom of /etc/pulse/default.pa (or a file in default.pa.d for distros which have that folder):

 

load-module module-null-source

 

This creates a fake microphone that will be used if the real one isn't present. It completely solved the issue for me, but Zoom needs to fix this on their end.

frankp1
Observer

I started getting the same problem this month with v5,9.3 on an old machine with no mic or camera, running Ubuntu 20.04. I have been joining Zoom meetings for almost two years on this device with 16.04 and then 20.04. It's only recently that this started happening. The constant bombardment of those messages won't even let me escape them by logging out of the meeting. The problem persists onto other windows and workspaces, and won't even let me log out of the session. I have to force shutdown with the power control switch on the box. Embeddedt suggests a command line workaround, but I am not comfortable working in a terminal. If anyone can tell me exactly how to run a CLI fix in 20.04, it would be greatly appreciated. 

You can try opening the terminal and pasting the following command into it, then reboot your machine. You should have a new, silent microphone called "Null Source".

echo "load-module module-null-source" | sudo tee -a /etc/pulse/default.pa

 

I pasted the command you provided in the terminal. When I rebooted and joined a meeting, the app worked as expected. Other than having to rename myself, it was the same as before this month. Thanks for your help, embeddedt. I hope Zoom fixes this soon to save others the trouble of trying to find a solution themselves.

embeddedt
Observer

Not sure when the issue was actually fixed but I no longer need the PulseAudio workaround I described in 5.10.4.