Showing results for 
Search instead for 
Did you mean: 

Zoom + OBS + Voicemeeter Integration


I am trying to fully integrate OBS, Voicemeeter, and Zoom on a PC so that all programs are properly functioning at a high level. I have done this in the past with no issues; this was how we set-up for much of early CovidBut now all my audio other than my Mic is badly garbled out of Zoom. Internally, everything looks and sounds right, but when I broadcast in Zoom: all my secondary audio (music mainly from Streamdeck or Spotify or in OBS video files) is awful. It is as if Zoom cannot correctly accept my single feed from OBS through Voicemeeter. I do not want to just go OBS to Zoom with VB cables because then I lose all the great functionality of Voicemeeter entirely, and I love Voicemeeter ease of use and control of multiple audio channels.


I have tried the various audio settings in Zoom for Live performance options and nothing has fixed this yet.

I am very experienced in both OBS and Voicemeeter, and with nothing working, I added the VB A&B cables to patch in that way (I should not have to with Voicemeter Banana) but am having difficulties setting up the VC Cables to work effectively in Zoom. On my PC headset monitor, everything sounds and integrates perfectly, and sounds great, but once I log into Zoom, and turn on virtual camera, the audio signals are terrible. All videos feeds are perfect. I cannot figure out what I am doing incorrectly with audio and Zoom. Zoom seems to be the obstacle here.

I think I have watched every video on this subject online, and searched through Udemy, too. Nothing helps. 



You might try changing the audio buffers in VoiceMeeter. It’s possible to use different buffer sizes for ASIO, WAS and other audio types. Try increasing the buffer sizes in VoiceMeeter and then selecting the higher latency (larger buffer sized) audio output. VoiceMeeter has documentation here:


I figured this out. It was a Zoom issue and a me issue.


I had early on went into Zoom audio and changed the settings to "Original Sound for Musicians" thinking that would fix it. It did not, it seemed to make no difference. Well, that's because in Zoom's wisdom, turning it on in the settings is insufficient, you have to go in the bar on the top left of the interface and turn it on again. I thought that since I had already selected the option in the audio settings, that clicking the tab was turning it back to off, not enabling it. Those Original Musician settings that I selected have to be selected again in the bar on the left top when you leave the settings interface. My opinion: when I turn something on, it's on, it does not need an additional confirmation 'on' to enable it. I thought that must be turning it off, that clicking it would change the status. Missed the : as an indicator of status: off.


I figured out it was Zoom when I tried to run everything in Google Meet and it was perfect out of the gate. Then I knew it had to be some kind of Zoom setting. When I ran Zoom for all of my VM + OBS webinars in 2020 and 2021, these were not options. My guess is in ordinary audio default, Zoom is trying to block my audio background as needless background noise.


I wasted a lot of time digging through multiple programs to laugh at how I missed such an obvious little notice. Anyway, I hope this saves some other poor sap from tearing down his entire audio framework thinking his brain fell out of his head and he no longer knows how to set up basic audio in VM, OBS, and Zoom.