Showing results for 
Search instead for 
Did you mean: 

Wayland screen sharing broken with GNOME 41 on Fedora 35




I recently updated to Fedora 35 with GNOME 41. This GNOME release restricts the screenshot API which Zoom has used for screen sharing on Wayland, so the screen sharing functionality no longer works (see here on Ask Fedora).


I require screen sharing for school, and I'm sure many others have a similar requirement/system configuration. With Wayland increasingly becoming a de facto standard on Linux, it is crucial that Zoom support Wayland screen sharing.


It's not a bug in xdg-desktop-portal-wlr, so I'm not going to create a pull request to add code that does nothing (if the client is behaving correctly...). There's already work on supporting to share only a region of the screen ( which should coincidentally also fix Zoom.


Simply running Zoom with "env XDG_CURRENT_DESKTOP=GNOME /usr/bin/zoom" should be enough to make Zoom think it's on Gnome while still keeping dbus working.


Edit: This should not be marked as solution! If any, provides a workaround for the issue, which has to be fixed by Zoom!

View solution in original post

406 REPLIES 406

I agree, I am pretty sure they got rid of it in 5.11 and then added it back in 5.12 (big brain zoom) 

I am running (vanilla) Fedora 37 and I also see this error message.


For those people who upgraded to Zoom version 5.12.x & found that screen sharing under Wayland stopped working, I have discovered a fix that worked for me.


Set EnableWaylandShare=true in ~/.config/zoomus.conf


After I upgraded from 5.11 to 5.12, screen sharing under Wayland stopped working for me, with the error box about sharing under Wayland only being supported under specific versions of Linux. Checking ~/.config/zoomus.conf I discovered that this setting had been set to false. I set it to true & Wayland screen sharing now seems to work.



I tried that solution and it seemed to work, at least with a few trivial tests.  Thanks for the tip!


Note: if you still have problems with screensharing on linux, test with the web interface, and in different browsers, to see if it's really the zoom client.


My case: screensharing with zoom client and zoom in firefox didn't work, and I ended up here.

BUT it worked with chromium, which had a different dialog for choosing the window/screen to be shared and... it worked.

So finally, my problem seems to that the OS/GNOME screensharing (used by zoom and by firefox) is broken, and the one embedded in chromium (which only allow sharing tabs) is working.

And finally, the answer for me was to launch:

systemctl --user start pipewire.service 

This service was inactive, so I need to start it. Perhaps I'll make it launch at start.

You can use systemctl --user enable {service} for that