Showing results for 
Search instead for 
Did you mean: 

Wayland screen sharing broken with GNOME 41 on Fedora 35




I recently updated to Fedora 35 with GNOME 41. This GNOME release restricts the screenshot API which Zoom has used for screen sharing on Wayland, so the screen sharing functionality no longer works (see here on Ask Fedora).


I require screen sharing for school, and I'm sure many others have a similar requirement/system configuration. With Wayland increasingly becoming a de facto standard on Linux, it is crucial that Zoom support Wayland screen sharing.


It's not a bug in xdg-desktop-portal-wlr, so I'm not going to create a pull request to add code that does nothing (if the client is behaving correctly...). There's already work on supporting to share only a region of the screen ( which should coincidentally also fix Zoom.


Simply running Zoom with "env XDG_CURRENT_DESKTOP=GNOME /usr/bin/zoom" should be enough to make Zoom think it's on Gnome while still keeping dbus working.


Edit: This should not be marked as solution! If any, provides a workaround for the issue, which has to be fixed by Zoom!

View solution in original post

406 REPLIES 406

Community Champion | Zoom Employee
Community Champion | Zoom Employee



 If you would like to put in a Support ticket for kde I would be happy to monitor it and help the Support Technician with guidance. 




If this response was helpful for you, please do not forget to click on the accepted solutions button!

where do I do that?

Community Champion | Zoom Employee
Community Champion | Zoom Employee



 On a web browser when you log in to your Zoom account. Go to the support button on the top right-hand side. That should take you to this link if it is not different for non-Zoom employees.



If this response was helpful for you, please do not forget to click on the accepted solutions button!

Hey Brandon,


Here's a ticket I've created:




Can someone please say how they manage to stop screen sharing once they have started it?

(Sorry for the bold but I posed this before with no comment so I am trying again.

I find I can screen share in Fedora 35, Gnome 42, but once I start sharing, the toolbar one uses to manage it disappears in a few seconds and there is no way to stop screen sharing (I can turn off sharing in Gnome itself, but this is not understand by Zoom).


Note: this is only when using pure Wayland. When I start start Zoom in XWayland within Wayland, the toolbar does not disappear and I can stop sharing once it is started.)

Qt tries setting that popup window to an always on top window and fails (gnome mutter does not support window layering, it only works on x11) so then if you click on something else the window with the stop button goes in the background. On something like kde it works properly i think

Community Champion | Zoom Employee
Community Champion | Zoom Employee



 I spoke to the developers and they stated that the fix (5.11.0) was for the  Linux OS system (Fedora 35, Ubuntu 22, Centos 8 streaming and above), and they are still doing some tests on KDE on Wayland and will resolve the issues facing KDE & Wayland in a later release version. This was in reference to my questions surrounding the green border issue. 


I hope that this is helpful. 




If this response was helpful for you, please do not forget to click on the accepted solutions button!

good to see that it's being worked on, and you guys do seem more competent than most other companies when it comes to linux and that's good to see


Community Champion | Zoom Employee
Community Champion | Zoom Employee



 Thank you for the kind words. Our support group works very hard to keep "all" of our users informed. No matter what OS. 


Kind Regards,


If this response was helpful for you, please do not forget to click on the accepted solutions button!


Thank you, Zoom developers and @YaBoiB. Glad to see this matter has finally been addressed. I have had the opportunity to download and test (Fedora 35, GNOME 41) and everything works as expected.


Good news that KDE is being worked on. Thanks for keeping us informed.


This is still not working at all. I can see only 'Use system capture' (is there anything to do with it?), 'Whiteboard', and 'Content from 2nd Camera' under Advanced. I used to have 'selected area of the screen' in the previous version but it is also gone.


Zoom 5.11.1

Ubuntu 22.04 LTS

Gnome 42.2 on Wayland

use the "use system capture" option, that's how you share your screen lol

Sure I tried that but nothing happens. I can click 'Share Screen' again and again. I don't see that my screen is shared or 'Stop Sharing' button or anything.

Steps I use:


1) Click on Share Screen (green button at bottom)

2) Double-click on Use System Capture (or alternatively single-click on Use System Capture, then click on "Share")

3) Choose "Single Window" (to share just one application window) or alternatively choose "Entire Screen" then "Built-in display" (to share the entire screen)

4) Click on the "Share" button in the upper-right corner


NOTE: your main Zoom window will disappear (allowing you to work directly on your applications). You will see a mini-menu at the top center of the screen with two choices: "You are screen sharing" and "Stop share". Hover over the "You are screen sharing" to make the Zoom menu reappear.

This is what I try. When I click "Share" in step 2) the sharing dialog disappears and I'm back in the main window. Then I can click the green "Share Screen" button at the bottom. I can do 1) and 2) in a loop forever, but never reach 3).


Do I have to install something or change some settings or anything else? What am I missing here? 😞

What happens if you double-click in Step 2 rather than single-click followed by Share?


I'm attaching a screenshot of what I see.

I'm also wondering if your dialog window is hidden under another window. I have a taskbar to display all my windows, and when I double-click on Use System Capture, a new tab appears in that taskbar showing a gear followed by the words Screen Share. In my system, that dialog window automatically appears on top, but it might be under another window in your case.

Also, belt and suspenders, you should make sure you have Zoom, not just any 5.11.1.

I updated my Zoom this morning and I can't download any other version than the one you wrote. I can't even download older versions (I thought of downgrading first).


||/ Name           Version      Architecture Description
ii  zoom   amd64        Zoom Cloud Meetings 


When I double-click in step 2 the same thing happens: nothing. The screen share dialog you linked doesn't pop up at all, the Zoom share dialog disappears and I get back to the Zoom main window.


I also thought that the screen share popup doesn't come in the foreground but also checked that with only Zoom running and nothing else on the desktop, moved the windows around, minimized them, etc. with no luck. The popup is just not there.


The last thing I thought of is my laptop docking station that has a kernel module and some daemon running in the background, so connected everything to the laptop directly and uninstalled the dock's drivers and software. Still no luck.

So for all the people blocked out by the artificial gnome desktop limitation for screen sharing, we have this problem if zoom launches thinking it is *in* a gnome desktop environment. I believe it uses XDG_CURRENT_DESKTOP or something like that to try and connect to screensharing to launch the client. But if the XDG-CURRENT-DESKTOP values does not match the value used to launch the daemon that allows screen sharing then the logs from /var/syslog will probably output something along the lines of "failed to get DBUS wayland-screenshare"

I don't even have a /var/syslog but I do have journalctl so I tried that and this is what I got

kwin_screencast: Dropping a screencast frame because the compositor is slow

it did that a few times before it stopped, I guess this is causing zoom to get confused somehow

sorry /var/log/syslog

I don't have a /var/log/syslog lol

what value is your XDG_CURRENT_DESKTOP env variable set to?


i think that is the same problem that the non gnome window managers struggle with too, but again I think it is based off of a mismatch between where your screenshare service is running and what zoom is trying to use.

I think what might resolve your issues given you are on a gnome window manager, would possibly be to somehow reinstall your window manager to get the environment variables in the right order again.

Your xdg sharing screen thing is in a broken state for some reason 

Try rebooting and trying again, if that doesn't work I'm gonna blame it on ubuntu being bad lol

Finally got it working! I got some ideas from


Even though xdg-desktop-portal-gtk was installed I actually had to install xdg-desktop-portal-gnome and reboot. After that the screen share popup appeared.


For the record, I didn't set any environment variables, but my XDG_SESSION_TYPE=wayland. In ~/.zoom/logs/zoom_stdout_stderr.log I found this:


Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
Linux Client Version is 5.11.1 (3595)



Thanks for your help!


Setting the env variables is a fix for other desktop envs other than gnome due to a dumb mistake on the zoom devs parts, if u are running gnome don't worry about it 

Community Champion | Zoom Employee
Community Champion | Zoom Employee



 Is this the thread that we are working on Screen sharing for Fedora 42? I have an update if I am in the correct thread. If not, will you tag me, please? I have so many threads that I am following that I get lost sometimes! 😂



Internal Reference ZOOM-316546

If this response was helpful for you, please do not forget to click on the accepted solutions button!

For Fedora 36, yes. Would be interested in a update.

Unfortunately, I'm back again. Zoom screen sharing is broken again on my Ubuntu. What happened is that my SSD died and I had to reinstall everything from scratch.


This time I have Zoom 5.11.3 (3882) and all xdg-desktop-* packages are installed, so everything looks right. (Last time the dist upgrade didn't install xdg-desktop-portal-gnome and that caused the screen sharing not working.)


What I'm experiencing now:

1. "Use system capture" is available in the Zoom share window.

2. The system share dialog opens and I can select the entire screen or a window.


When I share something, it seems that I'm actually sharing but the green border doesn't appear and the participants complain that they can only see a black screen.

What am I missing again?


@YaBoiB why is this not possible to download any older version? At least I could try if the last working version, 5.11.1 still works for me.

"no green border" has been acknowledged as a known issue. 

Will need gnome/wayland support before it shows up again on zoom.

Eventually when it does it probably won't be a "green border" ..


Track it here -> and 

Community Champion | Zoom Employee
Community Champion | Zoom Employee

@iszekely , 


You can download an older version by pasting this link (Debian/Ubuntu) to your OS. Here are some other source links to assist you. 

Oracle / CentOS /RedHat / Fedora



Other Linux OS 


Note that these are all 64-bit installers. 


To share with everyone how to revert back to older versions by changing the version in the link here is 5.11.0 (3540) so that you can compare


Let me know if there is anything more that I can do to help. 





If this response was helpful for you, please do not forget to click on the accepted solutions button!

Hi Brandon,

Thanks for sharing the older versions with us. I tried and I can confirm that is working on Ubuntu 22.04.1 LTS.

Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hi @iszekely


 Just to make you aware, there were some screen share fixes in the release this past weekend. Did they help you with the issues that you were having? Please see here what @Bort stated. 



If this response was helpful for you, please do not forget to click on the accepted solutions button!

Just tried screen sharing on KDE plasma with 2 monitors at 1920x1080

Sharing current screen or 2nd screen . The controls appear half way down the screen and i cannot move it. I can no longer see my video camera window. It's very difficult to know what is being shared.

If i use the "dual monitors" setting on zoom, then starting a meeting opens 2 windows of myself. pretty sure that isn' t the intended function.



I had that issue too!

you can press the windows (or super) key and click (+ hold) to move it around

I don't have two monitors so I can't say anything about your other issues