Ready to set up and use Zoom, but aren't sure where to start? Begin with our onboarding support experience for everything you need to get started.

Get Started
cancel
Showing results for 
Search instead for 
Did you mean: 

Time Zone Missmatch

thm22
Observer

Hi, 

The Zoom client does not display the correct time zone for my meetings. 

In https://outlook.office.com/mail/options/general/timeAndLanguage in my Outlook profile, the time zone is set to UTC-8, Pacific, which is correct. I am in Los Angeles.

In my Outlook client (Version 2111, Build 14701.20262), under Options, Calendar, Time Zones, the time zone is Pacific, UTC-8. The meetings are displayed at the correct time. 

On my computer with Windows 10, Version 10.0.19043.1466, the time is set to set automatically, the time zone is set to manual, it's set to UTC-8, Pacific, adjust to daylight savings automatically, and Windows Time service is running.

In my Zoom profile, the time zone is set to UTC-8 as well.

Zoom picks up the calendar items from my Outlook calendar, and send Windows notifications at the correct UTC-8 time. 

However, the Zoom client displays the meetings in its list of meetings in UTC-0 time.

The client from RingCentral does the same, displays it in UTC-0 time.

Both Zoom and RingCentral apparently get the calendar entries from the Outlook calendar, and get the actual time zone setting from the system, but the Zoom client application in its Meetings section does not display them correctly. 

 

I am at a loss. How can I fix this? 

9 REPLIES 9

ChristineGraham
Community Champion

Hello!  Sorry for any delay in responding.

 

The first think that I would look at is the users Zoom timezone,.  This can be set in their profile.  My guess is that their Zoom timezone isn't set correctly.

 

Hop this helps 🙂

Manny5429
Community Champion

@thm22  Updating the time zone of my  Zoom profile via web worked for me. It just didnt happen instantaneous. You need to log out from your desktop app and log back in. Maybe try a couple of times and see if it works. 

Go to Profile - Personal - Time Zone (Edit) match with you 

If this answer helped solve your question/issue, please hit the -Accept as Solution- button below.

thm22
Observer

Hi Christine, Manny, I did this. I checked the profile time-zone setting and it was correct. I changed it and changed it back to Pacific, but no effect on the client calendar entries. I logged out and killed the app, and restarted and re-logged in, with no effect. The times of my meetings in the client are still not correct. The meetings get imported from Outlook 365. These meeting show the correct time on the iOS app, but are off (in UTC 0) on the Windows app, 

HuckFinn-ZP
Community Champion

Hi thm22,

Can you check the current version of your Zoom App.  If it is still not in the latest version 5.9.6, can you try updating it and check again if that will resolve the issue. Hope this helps.

thm22
Observer

I just updated. I am on the latest version 5.9. 6 now and have still the same problem. (btw. the notification reminders from Zoom for upcoming meetings come in at the right time. It's the display of meetings in the "Meetings" tab in the client app that displays the wrong time). 

Manny5429
Community Champion

@thm22  Can you try clicking the Refresh icon (Upper left hand corner in the Meetings tab) 

Manny5429_0-1646250635876.jpeg

 

If this answer helped solve your question/issue, please hit the -Accept as Solution- button below.

thm22
Observer

I did this. The client refreshes, but still all meetings are in the wrong time zone.  I clicked the + button there and added a meeting through Outlook, and then refreshed. The meeting is scheduled at 12:30 PM PST, then shows up in the Zoom client at 8:30 PM. The Zoom client is 8 hours off. (The computer is at PST which is UTC-8). Somehow the Windows Zoom client runs at UTC-0, ignoring the OS (Windows 10) time setting . There is no setting in the Windows Zoom client to adjust that, as far as I know. 

HuckFinn-ZP
Community Champion

@thm22 , Can you try reconfiguring your Calendar Integration.

Below is the support link that you can follow.

https://support.zoom.us/hc/en-us/articles/360000488243-Setting-up-calendar-and-contacts-integration#...

Hi @thm22,

Have this answer or solve your issue? If so, don’t forget to mark the reply as an accepted solution! Thank you.