Check out our new Work Transformation Summit page, and join our upcoming event to learn how leading organizations are building a smarter hybrid workspace for their employees.

Visit the page
cancel
Showing results for 
Search instead for 
Did you mean: 

My MacOS is too old - is there download for High Sierra 10.13.6

Daniela2
Listener

I'm trying to download zoom meetings on my iMac desktop. My operating system is High Sierra 10.13.6. It says zoom requires 10.14 or higher. Is there an old download that zoom can send me? I need to use zoom for my assignments. Thank you. D

1 ACCEPTED SOLUTION

Rupert
Creator

Hi @Daniela2 

 

You can manually download old versions by manually editing the URL below with the version number you want.

 

You can find the version numbers in the Release Notes - also below.

 

https://zoom.us/client/5.8.0.1780/zoomusInstaller.pkg

 

https://support.zoom.us/hc/en-us/articles/201361963-Release-notes-for-macOS

 

 

View solution in original post

4 REPLIES 4

Rupert
Creator

Hi @Daniela2 

 

You can manually download old versions by manually editing the URL below with the version number you want.

 

You can find the version numbers in the Release Notes - also below.

 

https://zoom.us/client/5.8.0.1780/zoomusInstaller.pkg

 

https://support.zoom.us/hc/en-us/articles/201361963-Release-notes-for-macOS

 

 

Thanks Rupert - it worked! 🙂

 

Thanks! I can Zoom again on my old iMac from 2007 with OSX El Capitan (10.11.6)

عبدالملك
Listener

ماشاء الله انامسلم انت مسلم😀