cancel
Showing results for 
Search instead for 
Did you mean: 

Can't upgrade to Zoom 5.11 on Ubuntu

GregE
Listener | Zoom Partner
Listener | Zoom Partner

Starting today (August 24th 2022), when I try and join a meeting on my Ubuntu 22 machine, Zoom says "You need to be 5.11.9 (4300) or higher".  However, I just downloaded the latest .deb file and installed it.


Here are my steps to make sure:

- sudo apt remove zoom

- the /opt/zoom folder is now gone completely

- sudo apt install ./zoom_amd64.deb

- I made sure that zoom_amd64.deb is the file I downloaded today

 

After I install, if I "cd /opt/zoom", and "cat version.txt", it says 5.11.9.4300

 

However, when I launch Zoom and go to Help->About , it says 5.10.7 (3311).    When I run "ps -ef | grep zoom", the processes listed are from the /opt/zoom folder.

 

To summarize:

- removing zoom removes the /opt/zoom folder

- installing zoom creates the /opt/zoom folder and the version.txt in that folder has the correct version

- when I launch zoom, it has the older version number.

- the zoom that launches is from the /opt/zoom folder (not some other location)

 

So it seems like the installer is wrong or that it's not registering the correct version number.  

 

Anyone have any thoughts on things to try?  

4 REPLIES 4

GregE
Listener | Zoom Partner
Listener | Zoom Partner

I think I solved my own problem.   What I had to do was this:

- close the Zoom UI

- ps -ef  | grep zoom

- I then "kill <pid>" for each of the zoom processes.   After killing one or two, the other ones also were killed

 

Then I ran:

- sudo apt remove zoom

- ps -ef | grep zoom to make sure everything was dead

- used my file browser to go to /opt/zoom, and I ran "ZoomLauncher"

 

Now Zoom reports the correct version number.  I have no idea why this fixed it or how uninstalling would have left and older version though.

Hopefully this helps.

jwmh
Listener

This doesnt fix my issue   I"m running Ubuntu 18.04 (32bit).  I dont have an /opt/ directory [that I'm aware of}.  The client available for download for Ubuntu 32bit, is:

`zoom_i386.deb`

and when I run $ dpkg -I zoom_i386.deb, it gives me:

(that is dpkg dash captial-i, for show the .deb pkg info)

"...

Package: zoom
 Version: 5.4.53391.1108
 License: see https://www.zoom.us/
 Vendor: Zoom Video Communications, Inc.
 Architecture: i386

..."

Also when I goto Zoom - About, I see:

"

Version: 5.4.2 (53391.1108)

Copyright...2020 ...

You are up to date.

"

But,

attempting to join a meeting tells me I need a newer version 

😠

 

Jameswalter
Participant

Download the latest Zoom version here: https://zoom.us/download?os=linux
Install GDebi (if it was not installed yet)
sudo apt install gdebi
Go to a folder where zoom_amd64.deb was downloaded
Right click ⇢ Open with Other application
Select GDebi Package Installer. Click Select.

 

This may help,
James

@Jameswalter 

No, that's not related.

Nobody has any problem actually INSTALLING THE AVAILBLE .DEB pkg.

The problem is this:

ZOOM, INC. HAS FAILED TO RELEASE AN UP-TO-DATE 32BIT DEBIAN BINARY.

The only available release (listed on the page you linked to) is *NOT* up-to-date.... and thus, AFTER_INSTALLATION, when attempting to join a mtg... one receives the error.

***THE PROBLEM CAN ONLY BE FIXED BY ZOOM, INC. LINUX DEVELOPERS.***

The versions available to download at https://zoom.us/download?os=linux are, respectively:

- for 32bit deb:

5.4.2 (53391.1108)

But compare to the version avail on 64bit deb:

5.11.9 (4300)

...

see the problem?  ZOOM, INC. CAN FIX THIS.  THIS IS *NOT* USER ERROR.