Showing results for 
Search instead for 
Did you mean: 

Alexa Show 8 no longer supports "Alexa join my Zoom meeting" command


Up until about 2 weeks ago, the Alexa Show 8 units would connect to a scheduled Zoom meeting by just saying "Alexa, join my Zoom Meeting". Now, Alexa responds with "try asking me to open Zoom on a device that supports Zoom". Why has support for this feature been broken? I have 3 elderly, blind, or handicapped individuals in our congregation who rely on this simple command. Typing in the meeting ID and passcode is impossible for them, so this has been a huge loss. There also seems to be some change to the ability to link Zoom to their gmail calendar. Are the new instructions detailed somewhere? All 3 of these units are registered in my name, but it now appears that I can only link them to MY gmail calendar, not theirs. If I try to link to their gmail calendar it gives me some kind of permissions error.  Is that true also?



Have you found any answers to this question?  I have the same issue for a member or my congregation.


We are having the same issues for about 2 weeks. I hope this will be resolved. This was working great for my 90 year old mom. We have a weekend and a mid week meetings  and it was running perfectly for her until now.


I don't have any easy way to contact Zoom Support, so I posted it here, hoping they can track down the problem. Do they still support Zoom on the Alexa Show 8 and 10, or don't they? Who broke it, Amazon Alexa or Zoom? A lot of elderly and infirm ones are going to be missing meetings unless we can get this resolved.


What does work yet is saying "Alexa, open Zoom". Then, you can tap on the Join button, tap on the down arrow in the meeting ID box, select the Meeting ID from a previous meeting, and then you have to manually enter the passcode. This is too much for most of them to handle, especially the ones with memory issues. 

I don't understand "you can tap on the Join button, tap on the down arrow in the meeting ID box..." since I don't find a down arrow in the meeting ID box-- which has no symbols at all.  I may well be missing something.  That would be easier than entering all those digits but so far I don't see the arrow.

This only works after you have manually logged in once, and then the meeting ID is saved. After that you should see a down arrow that will bring up the meeting ID for you.

Again, I just don't understand what it means to "manually log in." Do you mean log in to the zoom meeting once by keying in the meeting ID and PW, then you will see the arrow next time you try to join that meeting?  Thank you.

Yes, tell Alexa to open Zoom, tap on join, type in the meeting ID manually the first time, along with the passcode, to join the meeting. Then, the next time you go to join there should be a down arrow you can tap, which will show the previous meeting ID. Select it, and then you still need to manually enter the whole passcode.

Thanks for your tolerance. I have tried several times. I join a meeting— as a guest— by keying in meeting if & pw, then join the meeting and then leave & return to echoShow homepage. Return to zoom. Request “join “. There’s no arrow. Is that a bad sequence?

I think I see the problem: perhaps it is because you are logging in as a guest, instead of having an account? Every Android -based device I have seen so far saved previous meeting IDs that you can pull up easily the next time. What we really need is a brother or sister who works for Zoom to escalate this complaint.


I have the same problem with 3 members of my church's Alexa devices. t looks like it is possible to start the zoom meeting for the elderly person by going to My Settings in the web browser Zoom account, going to Collaboration Devices, clicking Launch Controller and then clicking Join Meeting. It starts the meeting on their Alexa device without them having to do anything. 

I tried that just now on an Alexa Show 8, but the unit comes up as "offline" until you say "Alexa, open Zoom". Is there a way to bypass that, or am I missing something?

epre001, could you elaborate more on how to set this up? Where did you find instructions on how to add the Alexa devices to Zoom? Are you logging into the church's Zoom account, or the elderly person's?


Same symptoms, exactly.  And I don't understand Alexa's oral reply from the Echo Show. Alexa is suggesting an alternative, but what that alternative is... I cannot fathom.  Why has it quit working and is there hope for return?  


If Alexa can't open a meeting-- as it formerly did and the documentation still says it will-- what is Alexa asking me to do when Alexa replies, "try asking me to open Zoom on a device that supports Zoom" ?   Does Echo Show support zoom or not?


I'm having the same problem with my Amazon Echo Show 8. It was working fine about a month ago and now she can't find or do anything with Zoom commands.


Here's what I get:


Alexa, open Zoom --> That video service is not yet available on this device"

Alexa, open Zoom meeting --> Hmm I don't know that

Alexa, join Zoom meeting --> Sorry, I'm not sure about that.


Any advice???? I've tried all the things above that people have said.

Community Champion | Zoom Partner
Community Champion | Zoom Partner

please review the zoom support article below.  maybe what you request has to be exact.

Getting started with Zoom on Echo Show – Zoom Support


thanks,  eliot

Hi Elliot, appreciate your speedy reply and desire to help. I already read that article and tried all those prompts. I just updated my Echo Show 8 software (didn't know you can/had to do that) but it didn't change anything.



Eliot, the problem is, as you can see by multiple postings by not just me but many others, it WAS working just fine until about 2 weeks ago. Around the end of May, either Zoom changed something or Amazon Alexa, because the command "Alexa, join my Zoom meeting" no longer works, although that command is one listed in the documentation you linked to.

Community Champion | Zoom Partner
Community Champion | Zoom Partner

hi keydriver,


not sure which version of amazon alexa you have. 


maybe the problem is the latest amazon alexa version for ios 2.2.540769.0 which came out about 1 week ago or maybe this version will fix the issue.


if you have alexa app version other 2.2.540769.0, you might consider updating from the app store.


as you mention, it may also be a zoom client issue.  you may want to completely remove zoom client by using zoom clean and then reinstalling the latest client 5.14.11. 

 Uninstalling and reinstalling the Zoom application – Zoom Support


thanks, eliot

Zoom seems to be working OK on the computers run by the meeting host.  Problem is with joining from an Echo Show by requesting Alexa to make the join, which Alexa formerly does but does now denies having that capability.  Is it possible to "remove zoom client" from the Echo Show, and then reinstall it?  It would seem the Echo does not even have a zoom client.  Or help us understand how to kill and resuscitate it.  The cited article does not.


We have the Amazon Echo Show 8. We never installed any app or anything. We used to just say " Alexa open Zoom meeting " and then say the meeting ID and than tell Alexa the password. Simple as can be for my 90 year old mom to stay connected with all the meetings. I hope she will be able to do this again soon.


Happening to us too on Show 8 with latest software Three bedridden sisters who are unable to navigate or press buttons. Alexa, Help!

Sorry to hear that. I'm wondering if this is a Zoom problem or an Amazon problem. Any ideas? 

I personally think it's an Alexa/Amazon problem since Alexa previously dealt with connecting to a requested meeting when Alexa was orally given the meeting ID and PW, making the connection to Zoom meetings.  Alexa now responds to such an oral request by telling the user (with an audible response) to try to join via a device which supports joining Zoom meetings.  WHY Alexa quit handling the connection would seem to be an Alexa/Amazon problem since it's still possible-- with many more detailed steps, not orally-- to join a Zoom meeting without using Alexa (which used to be SO simple).

All documentation still says Echo Show 8 WILL connect when asked via Alexa-- but it quit some weeks ago with no warning.  Now Alexa replies to try to join via a device that supports this-- which in theory Alexa/Echo does support.  It seems to me to be an Alexa failing but no way for USERS to figure it out and correct it.


Has anybody got zoom to work again with echo 8?

The "Alexa, join my Zoom Meeting" command is definitely broken, and nobody from either Amazon/Alexa or Zoom has cared enough to comment on it. However, I have had fairly good success by:

1. Create a Google/Gmail account in the same name the Zoom account is under.

2. Paste the entire Zoom link, with the encrypted passcode in the link as well as the separate meeting ID and passcode (as I don't really know which one it is using). I could only get this working again for my in-laws when I had a complete link WITH the encrypted passcode.

3. I have linked the Google calendar to the Zoom account, both in the Zoom advanced settings at, and on the Alexa 8 units settings screen.

4. If everything is linked correctly, at the appropriate time you can say "Alexa, open Zoom", and hopefully on the left side of the screen the event will show up, with a blue "Join" button underneath it. Just tap on "Join", and it should log you right in.

It's definitely not as easy for elderly, handicapped, or the blind, but at least it seems to work. If anyone has anything to add, or anything I have missed, please join in!

My compliments!  You make me happy there is SOME work-around.  It's a bit complicated, requiring use of Google Calendar and linkage of the calendar to Zoom.  Not generally a user of G-calendar.  Getting that set up, then linking G-Calendar dually but separately to Zoom and to Alexa (for Windows Echo Show) is a substantial complexity.  Perhaps I'll try it.  Regardless, many thanks for a serious and detailed contribution!  (Where is Amazon?  Where is Zoom?   ???)

Just a little follow-up to my instructions above, I was still having issues with getting the Alexa Show 8 working for one 100 year old brother, so I ended up having to bring the unit home to fight with it. Everything I checked looked good, his Alexa Show 8 was linked to his calendar, and the events even showed up when you asked Alexa to show you your calendar, but the events never came up in Zoom. I logged into his Zoom account, and verified that his Zoom account was linked to his Google Calendar also. Still no events showed up in Zoom. So, at my wits end, I went into the Zoom settings on his Alexa Show 8 and logged out. When I logged back in to Zoom on his unit, it asked me to pair the device to his Zoom account by going to I first made sure that I logged into HIS Zoom account on my PC, not my account or the KH account, and then I went to and typed in the pairing code. Voila! That was the trick! Evidently I had failed to pair the Alexa Show 8 correctly to his Zoom account in the past. At least that is what I'm supposing, as it is working great now and I delivered it back to him. If you are saying "Alexa, open Zoom", and the meetings are not showing up on the left hand side of the screen, with a blue "JOIN" button underneath the event name and time, give this a try!

Oh, and I need to add: ignore my instructions below about adding the "Zoom for Google Workspace" app. I don't think it is necessary, and it actually creates a Zoom event for the user's account, not the KH/Church account. It is still necessary to paste the entire Zoom link, with the encrypted passcode, into the "add description or attachments" section of the calendar event you are creating.

Maybe this is where I have gone wrong. I did not have it located in  " add description " I only had it placed in the calendar.

. I will try this. I have spent so much time on this with no success. My mom loved so much to see the meetings but unfortunately has been taking the meetings only by phone now.
I hope this works...

Yes, you need to paste the entire Zoom link into the description section of the calendar event, and I have found it works best when it includes the link with the encrypted passcode, as in this picture.

Thank you Keydiver! I see the meetings are highlighted in red on the calandar now. Hope it works..

I guess Jw Stream for  circuit assemblies does not work with echo 8?


If you haven't seen it, see the substantial contribution of keydiver2 today, 8-20-23.  It's a way to simplify the joining procedure at the Echo 8-- after all prep work has been done to set it up.  A bit complicated, but it may be worth it to the user of the Echo.  


I must add: I also installed the "Zoom for Google Workspace" app to my Windows 10, which allows you to select a Zoom Meeting vs a Google Meets meeting when setting up the event in your calendar. I have tried so many things that I'm not sure if this was the missing piece of the puzzle or not. What I don't know, and I'm still searching is this: when you select "Zoom Meeting" instead of a Google Meet, it responds by asking for a Zoom login. Which Zoom account? The owner of the Zoom meeting, or the person who is trying to log into the meeting? I very often got an error code 404 when trying to get past that point. It was very frustrating, and not much support that I can find. Maybe someone can help????

You are over my head.  I am happy you have arrived at a process which works for you.  A bit too complicated for me-- we lost the simplicity when we lost the ability just to ask Alexa and have it done!  Too bad that without notice the feature was pulled and not replaced.  Zoom continues to get more complicated to accommodate enterprise level applications.  It was a nice ride.


Ensure the Alexa app has the latest software updates. Check if the Echo Show 8 is ready for a software update. Uninstall the Alexa app. Power off the device it was installed on briefly before reinstalling the app.




Thank you Will. For me, an ignoramus, please break it down a bit.

            "Ensure the Alexa app has latest software updates." Does this mean
there is an Alexa app on the Echo Show? If that is the meaning, I
was under the impression Echo Show updates are automatic-- the Show
has occasionally told me there is an update pending and I have updated
then following the instructions. Is there something else to do to
check that the Show is ready for an update-- and what to do?

                  "Uninstall Alexa app:"  Take it off the Echo Show or off of the iPhone I use
that has Alexa? If that means take Alexa off the Echo Show, how do I do that?
If it means take Alexa off the iPhone, I think I can do that but
wouldn't reject guidance!

            "Power off the device ..." must mean, in my case, the iPhone, then
turn it back on and reinstall Alexa. After Alexa is back on iPhone,
then what next?

             I greatly appreciate your substantive guidance already given.