cancel
Showing results for 
Search instead for 
Did you mean: 

Teams direct guest join in a room with USB/HDMI capture

EWBen
Newcomer
Newcomer

Teams direct guest join is a great feature to have within Zoom Rooms but we've encountered a bit of an issue in rooms that have a USB/HDMI capture device.  The USB capture is used for local content share via the HDMI cable and for that purpose it works fine.  However, Zoom Rooms (and Windows running on the Zoom Rooms PC) sees the USB capture device as a camera.  Not a problem in Zoom meetings because we just set the default camera in the Room settings on the controller and the Zoom meeting always uses the actual camera.

But when joining a Teams meeting, Teams seems to make its own choice about which camera to use, does not follow the default set in Zoom and has decided to use the USB/HDMI capture as a camera for the meeting and not the room's actual camera.  It is also the case that there is no way to change the camera Teams has selected, even when the room is in the waiting room before being admitted to the Teams meeting, the settings cog doesn't do anything and you can't change any devices.

 

Anybody else got this issue? Anybody have a solution to force Teams direct guest join to use a specific camera  or follow the Zoom default camera? Or alternatively stop USB/HDMI capture devices being seen as cameras?

 

Thanks,

12 REPLIES 12

bstrelko
Community Champion | Customer
Community Champion | Customer

Can you let us know which OS and version of Zoom Rooms you're using?

Also, please provide the model of capture device you're using.

 

Does the issue persist when the capture device is not receiving a signal, or only when content is plugged in?

Is your Zoom Rooms config set to auto-share content when detected upon hot-plug, or is sharing initiated manually (when in ZR mode)?

 

We have many capture devices in our environment and have not run into this issue - can try to replicate.

The issue occurs regardless of if something is HDMI cable or not.  Occurs for us with Inogeni and Magewell.  Also the same issue occurs in rooms with two cameras - Teams guest join always ignores the Zoom settings for default camera and chooses the other one, resulting in manually having to unplug that camera first to get Teams to use the camera we want.

 

collab-dan
Newcomer
Newcomer

Zoom and Teams interop is essentially broken for more complex deployments.. see below which seems to be  the official Zoom standpoint.

This feature is ok if you've got a simple room bar system.. but IMHO best switched off unless you have the time to run test calls / or can troubleshoot all of your room standards.

 

Interop when not fully supported by zoom can also introduce the risk of sudden incompatibilities / issues but YMMV

"

Zoom Interop for Microsoft Teams is only supported in Zoom Rooms with a single camera, single microphone and single speaker. If the Zoom Room has multiple cameras, microphones and/or speakers Microsoft Teams may select the wrong camera, microphone or speaker to use, respectively, and this cannot be changed during the call due to Zoom Interop limitations. The Microsoft Teams meeting will only appear on the first display of the Zoom Room. A second or third display will not show additional Microsoft Teams meeting participants or shared content.

Note: Screen sharing to a Microsoft Teams meeting requires access to the Microsoft Teams client. No wireless or wired HDMI screen sharing is available through the Zoom Room while joined to a Microsoft Teams call using Zoom Interop. Do not connect devices (e.g. a laptop) to the wired HDMI input of a Zoom Room before or during a Microsoft Teams call using Zoom Interop - it may lead to unpredictable results."

_

Marty DiBergi: Why don't you just make ten louder and make ten be the top number and make that a little louder?
Nigel Tufnel: [pause] These go to eleven.

Yes, I accept this really is a limitation/problem with trying to use Teams guest join in a complex room and it doesn't really have the functionality to handle that (either because Microsoft don't provide it or because Zoom can't be bothered to implement it) but guest join is much more user friendly than the alternative which is BYOD mode. 

We run an office space housing multiple different companies so end up having to support meeting room AV for a user base that is about 48% Zoom, 48% Teams and 4% Google Meet. We have Crestron  Zoom room systems in some rooms that have a USB switcher and have used BYOD mode extensively.  When it works, BYOD is better, but it does require more effort for user setup, sometimes it just doesn't work (mainly on macs) and relies on the user having to adjust their audio/video settings in Teams.  Guest join is much simpler in that regard.   

EWBen
Newcomer
Newcomer

So I think we've 'solved' this.  Teams guest join uses which ever camera is listed at the bottom of the list of cameras on the Zoom Room settings tab.  So regardless of which device is set as the default camera in Zoom, Teams ignores that and uses the device at the bottom of the list.  If that is the USB/HDMI capture, it uses that.  If it is a secondary camera it uses that.

In order to 'fix' it, we simply uninstalled the desired/default camera in Windows device manager, rebooted and then reconnected it.  That causes Zoom to re-order the devices as it places the most recently installed device at the bottom.

 

zoomcamera.png

We have are having a similar issue, we've had a Zoom Room for a couple years now but just recently experienced this. Was curious if it had to do with a recent update.  Did your fix of prioritizing the camera at the bottom hold up?

EWBen
Newcomer
Newcomer

So far yes.  I can't admit to having tested/used it extensively since we discovered the 'fix' a few weeks ago and the room pictured above was out of action for a while due to a separate issue with the Shure kit and Dante audio not working.

Thanks for the feedback, we are trying it out on our system as well.  When did you notice it stopped working?  We've had our Zoom Room for a couple years now and just recently we noticed it. 

EWBen
Newcomer
Newcomer

Not sure.  We've probably only had direct guest join enabled for about a year, prior to that always stuck with BYOD mode to facilitate Teams.  In our event space, I'm pretty sure DGJ has always picked the wrong camera, since the start.  We just got used to manually disconnecting the undesired camera before starting the Teams DGJ meeting until recently and this potential fix/solution.

Yeah, we have just gotten lucky.  Hopefully there will be an eventual fix, as we have a capture card sending video in one room, and a couple rooms with usb whiteboards that come up as a camera device on teams. 

ZBeto
Zoom Employee
Zoom Employee

Hello! 

If the HDMI source is not actively being presented (the part that isn't supported), a Windows PC ZR should indeed ignore the HDMI capture device.

It seems like the ZR software has a fix for this, as there was a change recently that resulted in the Teams client software still selecting the capture card as a camera. It will be released with the July release of Zoom Rooms PC client.

In the interim, disabling or removing the capture card would be workarounds. Or as shown above

Hi ZBeto,  thank you for the update.  Look forward to the July update.