cancel
Showing results for 
Search instead for 
Did you mean: 

granting camera and microphone permission

ewb16
Newcomer
Newcomer

I recently upgraded my old Mac laptop and am now running Mojave 10.14.6    Zoom used to work fine, but now I cannot grant permission to Zoom to use my camera and microphone.   I can see and hear everyone at a meeting, but they cannot see or hear me.   Zoom tells me to go to my computer's settings, then privacy, and check the box for Zoom indicating it can use my camera, same for microphone.   But when i go to settings and privacy, Zoom is not listed there as wanting permission.  The box is empty as in the attached screenshot.   So there is no way to grant Zoom permission.   Anyone know how to resolve this issue?  Thanks

11 REPLIES 11

Bort
Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hi @ewb16 

 

This can happen when upgrading to a new version of macOS. Apps already installed still have permission, but not the new permissions that come with the new version of macOS, so there becomes an issue when trying to give that app permission again. Luckily, there is a way to reset this so that your mac can recognize Zoom wanting that permission again. 

 

  1. Open the Terminal app on your mac computer. 
  2. Type tccutil reset Camera and press Enter. 
  3. Type tccutil reset Microphone and press Enter. 
    Note: these commands will reset all permissions for your mic and camera, so other apps that have access will need to be given access again as well. 

After entering those commands, you can close terminal and try opening the Security and Privacy settings panel. Now you should see Zoom listed there to give permission. If not, try opening Zoom again and checking that settings panel.

 

Hope that helps and please make sure to mark the solution as accepted if this information is what you needed. 

I did as suggested but it made no difference.  Still no apps listed in the camera permissions box.

ewb16
Newcomer
Newcomer

sounds like it could work, BUT -- I do not have a terminal app on my computer -- I looked in Finder Applications, and no such thing as terminal.   Is this something that is supposed to be in the upgraded computer or do I need to download this terminal app?

 

Bort
Community Champion | Zoom Employee
Community Champion | Zoom Employee

Check in the Utilities folder of Applications

ewb16
Newcomer
Newcomer

ok, I found terminal in the utilities folder and typed as you instructed.   tccutil responded "failed to reset database" for both the mic and the camera.   And still the permissions box is just empty, no way to check permission for Zoom or anything else.   Any further ideas?

 

Bort
Community Champion | Zoom Employee
Community Champion | Zoom Employee

Not sure why you would get that message when using tccutil. Is this a device managed by your employer? If so, it could be that you don't have the necessary permissions to use tccutil on this device. 

BenMannell
Newcomer
Newcomer

The answer for me was:

 

1. Turning off SIP.
2. Deleting /Library/Application Support/com.apple.TCC/TCC.db
3. Turning on SIP

 

TCC is "Transparency, Consent and Control"

This resets all privacy permissions you've granted to apps, so after deleting the db file you'll probably have things like Google Drive asking again to access a network drive etc...

Ok great.  But how do I turn off SIP (whatever that is)?    I tried Bort's solution -no joy.  I have reinstalled Zoom, restarted my Mac all to no avail.  Whenever I go to system settings-privacy and security- camera or microphone the list of applications that ask permission to access the camera is always blank   The camera works for facetime.  Any help much appreciated.

I tried to turn SIP off.  when I typed csrutil disable   in terminal the response was 'command not found"   Still nothing works to give zoom access to my camera.

thebencollier
Newcomer
Newcomer

Thanks BenMannell.  This nailed it and fixed a couple of other apps too!

mgraam1869
Newcomer
Newcomer

I have exactly the same problem with Ventura.