cancel
Showing results for 
Search instead for 
Did you mean: 

Wayland screen sharing broken with GNOME 41 on Fedora 35

intrlocutr
Explorer
Explorer

Hi,

 

I recently updated to Fedora 35 with GNOME 41. This GNOME release restricts the screenshot API which Zoom has used for screen sharing on Wayland, so the screen sharing functionality no longer works (see here on Ask Fedora).

 

I require screen sharing for school, and I'm sure many others have a similar requirement/system configuration. With Wayland increasingly becoming a de facto standard on Linux, it is crucial that Zoom support Wayland screen sharing.

1 ACCEPTED SOLUTION

It's not a bug in xdg-desktop-portal-wlr, so I'm not going to create a pull request to add code that does nothing (if the client is behaving correctly...). There's already work on supporting to share only a region of the screen (https://github.com/emersion/xdg-desktop-portal-wlr/pull/156) which should coincidentally also fix Zoom.

 

Simply running Zoom with "env XDG_CURRENT_DESKTOP=GNOME /usr/bin/zoom" should be enough to make Zoom think it's on Gnome while still keeping dbus working.

 

Edit: This should not be marked as solution! If any, https://community.zoom.com/t5/Meetings/Wayland-screen-sharing-broken-with-GNOME-41-on-Fedora-35/m-p/... provides a workaround for the issue, which has to be fixed by Zoom!

View solution in original post

407 REPLIES 407

JHBoricua
Newcomer
Newcomer

JHBoricua_0-1670337444985.png

Why is this idiotic check still a thing? I run Nobara 36, which is essentially Fedora 36 with some gaming specific tweaks built in. But no, you're not running 'Fedora' so we are simply not going to allow you to screenshare despite meeting all the requirements. FFS guys, get rid of this artificial gate. I wonder how many issues would be resolved by eliminating this.

 

And fix your darn PWA too if you want to push it as an alternative. There, I can screen share but I can't see chat messages in Team Chat unless I happen to have the person/group in focus. Otherwise, I can see the bubble indicators showing new messages from a person/group in Team Chat, but when I click on them, it doesn't display the messages. What a joke.

I agree, I am pretty sure they got rid of it in 5.11 and then added it back in 5.12 (big brain zoom) 

I am running (vanilla) Fedora 37 and I also see this error message.

PhilArmstrong
Newcomer
Newcomer

For those people who upgraded to Zoom version 5.12.x & found that screen sharing under Wayland stopped working, I have discovered a fix that worked for me.

 

Set EnableWaylandShare=true in ~/.config/zoomus.conf

 

After I upgraded from 5.11 to 5.12, screen sharing under Wayland stopped working for me, with the error box about sharing under Wayland only being supported under specific versions of Linux. Checking ~/.config/zoomus.conf I discovered that this setting had been set to false. I set it to true & Wayland screen sharing now seems to work.

 

 

I tried that solution and it seemed to work, at least with a few trivial tests.  Thanks for the tip!

ofaurax
Newcomer
Newcomer

Note: if you still have problems with screensharing on linux, test with the web interface, and in different browsers, to see if it's really the zoom client.

 

My case: screensharing with zoom client and zoom in firefox didn't work, and I ended up here.

BUT it worked with chromium, which had a different dialog for choosing the window/screen to be shared and... it worked.

So finally, my problem seems to that the OS/GNOME screensharing (used by zoom and by firefox) is broken, and the one embedded in chromium (which only allow sharing tabs) is working.

And finally, the answer for me was to launch:

systemctl --user start pipewire.service 

This service was inactive, so I need to start it. Perhaps I'll make it launch at start.

You can use systemctl --user enable {service} for that