cancel
Showing results for 
Search instead for 
Did you mean: 

New: extension to enable “original sound” on Chromebook / others using Web client

MarcSabatella
Newcomer
Newcomer

If you use the desktop client for Zoom to share music, you probably know about the “Original Sound” option to disable echo cancellation, noise suppression, and other music-killing audio processing.  You may also have realized this option is not available on the web client - so, no luck on Chromebook.

 

It turns out it is possible to get this functionality using a free Chrome extension that I developed.  See:

 

https://chrome.google.com/webstore/detail/original-sound/ffhniinhbjmjakiabdojmfehdhnbcmdh

I developed this for my own use but am pleased to share it with all.  Feedback welcome!

17 REPLIES 17

PurplePianoCat
Newcomer
Newcomer

Thank you so much! I will check it out. Much appreciated. You should join the music teacher groups and let them know on Facebook!

Thanks - I did post this there already last week 🙂

AlanDorn
Newcomer
Newcomer

Hi Marc

Thanks so much for developing and sharing this.  I'd like to understand it properly to make sure I have Original Sound when I need it!  If I open the extension and disable the processing, will this be the default next time I start a Zoom meeting?  Or does it need to be done within the Zoom meeting each time?  And is there any way of telling from within the Zoom meeting whether the processing is disabled or not?  Many thanks, Alan

Good questions!

 

Unfortunately, I didn't see a reliable way to make the settings apply by default.  So you have to do it for each meeting where you want this.  Also, keep in mind the change doesn't take effect until you select a new input device - e.g., from "same as system" to "internal mic" even if that's not actually a change.  But then it remains in effect for the duration of the browser session even if you make further input device changes - probably even if you change meetings although I haven't tested that.

 

As for being able to tell if it worked or not, I don't have a better answer than to do a test.  Echo cancellation is very simple to check - just try playing some audio on your computer through the speaker (eg, watch a YouTube video) and ask others in the meeting if they can hear it.  If yes, you successfully turned off echo cancellation.  Or log in for yourself on another device (keep that device muted and use headphones!) and do a sound check before starting the meeting if that's convenient.  The voice optimization is tougher to characterize, but for me, if I play a sustained chord on the piano, with the voice optimization *on*, the sound cuts out ways too fast, - I guess it's misinterpreted as background noise.  But also, just playing music normally will sound garbled - a little like being underwater - if voice optimization is on.

 

A couple more things to mention while I'm at it.  First, if you turn off echo cancellation, you need to be listening to the meeting itself via headphones, or else there will be echo.  I usually set my system sound to my speaker but select the headphones within Zoom.  Second, a recent change in the Zoom app makes the Original Sound dialog not appear when you run the extension from within the meet - it is showing up on the main Zoom window, not the meeting window.  So you need to switch back to the main window to work with the dialog.   In theory it should work to just run the extension from the main window before you even enter the meeting, but it doesn't.

 

So it does take a bit of practice to get the routine down, but it's worth it!

alex61mary
Newcomer
Newcomer

Marc,  I've been using your extension for a while and it worked well at first, but this past week it hasn't.  I've tried installing the link twice during a violin lesson this morning and wasn't able to hear the violin.  What do you suggest?  I install it during every lesson.

 

Mary

 

Hello!  I just tested and it is still working for me on the current version of ChromeOS for my system - 109.  Are you on Chromebook, or another system?  Did you remember to change input devices after making the setting?  I forgot to do that at first when I tested just now and got worried for a second, then I remembered to change devices and all was well.

alex61mary
Newcomer
Newcomer

Marc,

 

You offered me some advice a few weeks ago.  I can't hear one of my violin students on zoom even when I use your extension.  You said to change input devices.  How would I do that?

 

Thanks,

Mary

The extension only affects the quality of your own sound - how you sound to others.  It cannot have any effect on how others sound to you - unless they also install and use the extension.

 

The way to change input devices in Zoom, click the audio icon at lower left:

 

MarcSabatella_0-1678284132868.png

 

As explained in the original description for the extension, you need to do this after selecting new options within the "original sound" dialog.  Even just changing from "same as system" to "internal mic" does it, so you don't need to actually have a second input device connected.

Rennie
Newcomer
Newcomer

Hi there! I recently bought a Chromebook (I am a yoga instructor) and I need to bring a device to the studio since I teach live and on zoom. Can you explain in non-tech savvy terms how to use this extension? I would greatly appreciate it. 

I spent over $100 on JustAsk and I did everything the tech told me, and today when I was teaching, the original sound was not there, according to my zoom students. I would really appreciate step by step instructions for the 51 year old widow whose husband did all this stuff for her! 😂

Hello!  I have no idea what JustAsk is, but I'm also confused about your question - are you saying you installed this extension, followed the directions for using it, but your students had reason to believe it didn't work correctly?  What specifically did they hear that led them to believe it wasn't doing what it should?

Is there a reason you feel you need this extension?  Normally it would be needed only for live music.  if you explain in more detail the actual problem you are trying to solve, I can try to assist better.

I use original sound because I chant and play the harmonium during my yoga classes. I had been using my MacBook but I didn’t want to keep dragging it back and forth to the studio so I got a little Chromebook at a great price. It’s lighter, and I’m not concerned about it getting damaged. Installed the extension. And then after I started the meeting, I clicked the extension, but the dialog box did not come up. When it did come up, I assumed it was working, went back to the meeting and changed the mic. I k own it didn’t work because they said they could hear me but not the harmonium as they had been hearing from my MacBook. Am I doing things out of order?

I really do appreciate your help.  

OK, thanks for the explanation!  When you start the extension from within a meeting, the dialog pops up but *not* within the window for the meeting itself.  Instead, you need to click the little icon at top right to move back to the main Zoom window.  Then you should see the dialog.  At that point, you should *uncheck* the options to cancel echo and/or optimize for voice.  If you are actually chanting and playing the harmonium live, you can probably just uncheck the optimize for voice option and leave the echo cancellation enabled - that will avoid the need to wear headphones if others are speaking during the meeting.  But if you know everyone else will always be muted, you can also uncheck the cancel echo button.  Then hit the Close button, then return to your meeting, and then select your audio input device.

Rennie
Newcomer
Newcomer

Thank you so much for the clarification.! I am excited to try it tomorrow! I really do appreciate your help. 🙏