cancel
Showing results for 
Search instead for 
Did you mean: 

Logitech Spotlight Presentation Pointer Stops Responding During Meeting

mmotsko
Newcomer
Newcomer

We recently had two seeming unrelated events. The first event (Zoom version unknown) during the set up for the presentation, the Logitech Spotlight would change slides, but the remote viewers on Zoom only saw the original slide. The slides only changed on the local system. The presenter, on a MacBook, shared his desktop. To fix we moved to the room workstation and all was well. I marked this as a network issue.

 

However yesterday, we had another meeting. I hosted it on the workstation that I have been using for all meetings for the last year with the Logitech Presentation Pointer (sharing the Desktop). The pointer worked fine until about halfway through the 1 hour presentation. Then it stopped working. The laser pointer would work, just the forward and back no longer worked. I switched to a different Presentation pointer and it changed slides without issue for the remainder of the meeting.

 

After the meeting ended, I stopped zoom remotely and then tested the Logitech Spotlight pointer. It worked flawlessly. The PC has 16 GB of memory and until this event has not experienced this issue.

 

Zoom version 5.14.15287

 

Any ideas what may be causing this issue? I plan on reinstalling Zoom and the Logitech software in an attempt to fix this issue.

 

Thank you for any help you can offer, its appreciated.

2 REPLIES 2

RN
Moderator
Moderator

Hey @mmotsko the latest version as of May 9, is 5.14.7; suggest updating to see if that improves your experience. As I see you said, reinstalling the :Logitech software; were you able to do so or attempt to update? 

 

And curious, is this the device you're referring to? https://www.logitech.com/en-us/products/presenters/spotlight-presentation-remote.910-004654.html

⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯⎯
Zoom Community Moderator
he/him/his

Have you heard about Zoom AI Companion? ➡️ Check it out!

mmotsko
Newcomer
Newcomer

Thank you for your reply. That is the device in the link you added. Until now the device has never failed and if you share the desktop (not the presentation), all users - local and remote - can see the what the presenter is highlighting.  I have not had a chance to reload the software and then test. The last failure was 30 minutes into the presentation.  I will update the issue, but was seeking out if anyone else was having issues / warning others that use the Logitech Spotlight to be on the lookout for this issue.  Thank you all so very much again.