Showing results for 
Search instead for 
Did you mean: 

Can't join meetings



I am in a redundant cycle of being able to join a meeting. I have tried on multiple browsers, uninstalled the the desktop application, reinstalled, checked for updates, and still unable to join a meeting. I keep getting the "Join a new meeting?" pop-up. 

"You will have to leave this meeting to join the new meeting." 

Option 1: Leave and join         Option 2: Cancel

I always click "Leave and Join" option but it  sends me back to the landing page with these options

- Join a meeting - Greyed out, unable to click on it
- Sign up

- Sign in

I have signed in and it's the situation. Can someone please help out?     Bueller? Bueller?



I'm having the same issue, although I am not getting any error messages at all... just sitting in the launch screen. 

I am not able to enter a meeting from a link at all.

I've also tried numerous ways to join, uninstalling and reinstalling, manually typing in the code, etc...  

At this point, the only thing that seems to work consistently is to go to the web app and NOT log in to my account, and then manually enter the meeting ID.  

Same. I've also tried CleanZoom.exe, reinstalling 64-bit, reinstalling 32-bit. Nothing works. I can log in from my Android phone. I have Windows 11. 


Does anyone respond to these messages? This is getting really annoying. 


I am having the same problem. I can use zoom on my ipad, but not on my personal computer. It has to do with updating my browser, but I don't know how to do that. 


Welcome to the Zoom Community @rjhelton! We sincerely appreciate your contribution to bringing up this issue and sharing it with the community. Such participation is highly encouraged, as it allows other users to provide solutions and assistance.

You may check out this article on troubleshooting when you can't join a Zoom meeting.

Thank you, and have a fantastic day!