Showing results for 
Search instead for 
Did you mean: 

Black screen when sharing screen on Wayland (Fedora 37, GNOME,




I use Fedora 37 with GNOME DE and Wayland. Whenever I'm trying to share a screen using the app other people are just seeing a black screen. I can confirm this behavior if I do a recording.


My setup:

OS: Fedora Linux 37 (Workstation Edition) x86_64 
Host: 20VX006CGE ThinkPad P14s Gen 2i
Kernel: 6.1.11-200.fc37.x86_64
Resolution: 3440x1440
DE: GNOME 43.3
WM: Mutter
CPU: 11th Gen Intel i7-1165G7 (8) @ 4.700GHz
GPU: NVIDIA Quadro T500 Mobile
GPU: Intel TigerLake-LP GT2 [Iris Xe Graphics]
Memory: 13640MiB / 31820MiB 




Same for me, fedora 36, nvidia 3080ti, wayland.  both the rpm and flatpak are blank windows.

The wayland hump probably has 5 years to go.  gonna be quite a ride.


I'm experiencing the same behavior with Zoom 5.12. Zoom basically supports screen sharing since version 5.11 but it looks as if something broke again.

Hi @straurob, Have you been able to share screen/window in any of the previous versions (5.11.xx)?

I tried to downgrade to 5.11.10 but same issue..  I'll stry 5.11.9 which I found link


Unfortunately, I haven't found any solution so far. The only thing which works for me is is using X11 instead of Wayland. There is also a support ticket for that case but it its final result is: "Wait until Zoom fixed this". 😑


I'll try your hint with using the nouveau driver although this has raised other issues on my system using two external displays.

Hi @straurob 

It looks like that reverting nvidia driver to nouveau works for some people.  It didn't work for me.

I had hooked up 2 extra displays on laptop, and everything seems to be still working fine with nouveau driver (apart from zoom window sharing 🙂

  I'm in a process of upgrading to Fedora 37, to see if any luck.

Link to mentioned post



I can confirm same issue also on F36 Wayland different laptops, always blank screen.  When I try to share on laptop with 2 additional displays, it will always put sharing controls on the laptop screen and not where sharing window is located.  I've tried 5.12.2 and 5.12.6 and same issue


Check if you are using nvidia driver, and try with nouveau and it should work

Sorry, but even using X11 is a better advice than this.

ridiculous advice

Well I've got it to work, by activating nouveau instead of nvidia module.  Doing 1 reboot before I start zoom meeting, doesn't seem too ridiculous of an idea, when I can use all the functions of the zoom client.  Not that one is doing much more on a computer while having zoom lecture/meeting, unless he has Jeffrey Toobin as a role model.


By now even Telegram client on Linux has a properly working screen sharing in Wayland. Makes me wonder what's the issue with making it to work properly in Zoom.


The only real solution is to use the web version of zoom while on linux.

Web version of zoom scales 16:9 picture into 4:3 so it looks funny, and not settings to change it. (when external camera is connected)


I have a Dell XPS 15 laptop (hybrid video: nvidia + intel) with Fedora 37 (Gnome, Wayland) installed. And I can confirm that during screen sharing other people just see a black screen. When this issue will be fixed? I don't want to install the nouveau driver or use X11 just because of one app.

I am facing the same issue and I kind of believe it is not something that can be fixed by Zoom but rather needs to be fixed in the Nvidia driver.

Screen sharing works for me in other apps, like Telegram or Slack (basically, all electron-based apps) and ofc in Chromium and Firefox. Pretty sure this is something that has to be fixed in Zoom.

Are you using the proprietary Nvidia driver with the other apps?  Did you make sure the apps actually use the Nvidia card and not the integrated one?

Yes, I use the proprietary driver with enabled dynamic power management (configured in PRIME render offload mode). All the apps use the integrated GPU unless specific ENV vars are provided to run the app with render offload. I'm pretty sure Zoom runs on integrated GPU as well. I think the root cause is how Zoom initializes screen sharing with pipewire.

I am confused now. Is Zoom running on your integrated or not? Does it also not work on integrated graphics?

Zoom runs on integrated GPU. When it runs on integrated GPU it fails to share the screen. Or rather it always shows a black screen.

I never run it using discrete GPU, what's the point to do that?

Ok so I am not alone. (Although it seems that people in this thread actually got it working).

And in that case it is indeed an issue that Zoom needs to fix. You better write a ticket to support because they actually help 🙂

Taking into account how long did it take them to implement some initial Wayland support, I doubt Zoom support will be very helpful with that. Likely they'd give some generic response with a suggestion to use 😒


Also, I think I sent a message to support when I first faced this, but I don't remember getting any response at all 🤔

Nope. They are actually helping with fixing support for Nvidia and Xwayland/Wayland (still some stuff are not working properly).


They even updated this page with "If you are still experiencing issues, submit a request to Zoom Support to assist you with troubleshooting logs."

Please update when you get a response from tech support 😀

Lol, I told you



They are clearly not aware of their own updates. They no longer recommend using Xorg.

Try to show her that link


They are clearly doing the opposite of that and dont try to help.


Sorry to necro bumb this thread, but this is likely to do with your screen resolution. Using Wayland + Zoom  + anything non-16:9 resolution will result in black/garbled images. It's been reported elsewhere that a workaround is to use the web client or change your resolution to 16:9 until they can sort out this bug. (Neither are great options, it's just all we have atm).