Showing results for 
Search instead for 
Did you mean: 

Logitech Tap not working with new computer


We installed a new computer to run our Zoom Room.  I have installed the Zoom Room software on the computer and the Zoom Room works fine, but the Logitech Tap screen is black.  The tap is correctly connected and if you tap its screen the action you tapped is displayed on the main screen.  I have tried powering the Tap off and on and resetting it to factory,  but nothing works.  If I put the Tap back on the old computer it works, so it must be something that is not installed on the new computer, but I can't find any required drivers for the Tap on the Logitech web site.  I have tried installing the Zoom Room Controller software, but that hasn't resolved it.  Any help would be appreciated. 



The USB Logitech Tap comes with an embedded Synaptics DisplayLink video controller. Even though this is supposed to be a plug-and-play, you may download the latest Windows driver from the DisplayLink web. Also, the Tap is very picky about which USB port is connected to. Verify you are using a blue (USB 3.0) usb male connector in your PC.