cancel
Showing results for 
Search instead for 
Did you mean: 

fix zero-touch provisioning of desk phones

JoshT
Listener

How can I fix zero-touch provisioning on our hundreds of new-in-box vvx250 polycom phones?

 

Some auto-provision on first boot, as advertised.

Some fail and must be factory reset.  After the factory reset some will auto-provision correctly.

Many require assisted provisioning.  This requires us to log into the phone's web page and manually enter the provisioning URL, clear out the username/pass, and set DHCP to static.

 

My goal is to avoid assisted provisioning.  Is there a way to take the config of a phone and quickly flash it to another phone?  Can we do that in bulk?

3 REPLIES 3

aaroncoffman
Attendee | Zoom Employee
Attendee | Zoom Employee

 

@JoshT , 

 

Good day!  I hope you are well. 

 

As you indicated, Zero Touch Provisioning (ZTP) will be the best way to provisioning all of your Poly handsets.  

I would recommend opening a support ticket on one or two of the handsets that are failing the ZTP process which is requiring you to step through the assisted provisioning process.  It would be best to make sure the root cause of the issue is understood. 

 

There may be another viable option for you if all of your devices share the same manufacturer and if you have control of the DHCP server. 

 

Zoom has a single URL per manufacturer which would eliminate the need for the assisted provisioning and bypass the ZTP process that appears to be failing for you. 

 

The URLs are as follows: 

AudioCodes - https://provpp.zoom.us/api/v2/pbx/provisioning/audiocodes

Poly - https://provpp.zoom.us/api/v2/pbx/provisioning/polycom

Yealink - https://provyp.zoom.us/api/v2/pbx/provisioning/yealink

This info was pulled from here: https://support.zoom.us/hc/en-us/articles/360033223411#h_01F65FEPTABPHZERDMF84NBET6

 

Keep in mind, using one of the above URLs is only supported by the corresponding manufacturer, which is why it would be best to ensure ZTP is working properly.  Not all devices are supported with this method, though the VVX-250 certainly should be. 

 

If you have a ticket, feel free to direct message me with the number and I'll see if I can assist. 

 

Does Zoom have any document explaining how to configure DHCP options for Poly VVX-series phones to force registration to https://provpp.zoom.us/api/v2/pbx/provisioning/polycom ?

 

 

Eliot
Community Champion | Zoom Partner
Community Champion | Zoom Partner

hi josh

 

one of my clients had a similar issues.

 

for ztp, poly phones need to connect to poly.   check that the phones have access whatever subnet they may on.  in one case ztp at one location worked but not at another.   the issue was solved with a change to access control list.

Required Ports and Trusted IP Addresses and Hosts (polycom.com) 

 

in real time, zoom connects to poly to provide the mac addresses that a zoom phone admin enters.  the mac addresses are hex addresses containing 0-9 and a-f.  you should not do a copy and paste of the mac because what you copy may contain special characters.  you should manually enter the mac addresses.

Managing phones and devices – Zoom Help Center

 

best

 

eliot