cancel
Showing results for 
Search instead for 
Did you mean: 

Zoom Phone Appliance not showing contact name with income calls

mike_h
Listener

I have a Yealink MP56 Zoom Phone Appliance. When there are incoming calls the phone number and whatever Caller ID info is displaying instead of the contact name I have in my Contacts. Same for the call history and voicemails as well.

I have contacts synced with Google and that is working, though when I login to the Zoom web site I don't see the contacts listed in settings under Personal – Personal Contacts. I do see "For Google Calendar, Microsoft Exchange, and Microsoft Office 365, sync your contacts here." Clicking "here" takes me to Personal - Profile - Other at the bottom, and Google syncing is set up there. I even reauthorized it to be sure.

Oddly, in the Zoom Workplace apps on my Mac and on my iPhone I do see the contact name on incoming calls, history, and voicemail. The contacts are appearing in "My Contacts" in "Cloud Contacts" in Contacts on the Zoom Workplace apps and on the Zoom Phone Appliance app.

 

To test further, I also created a contact manually. The contact name still doesn't show on the Zoom Phone Appliance when that phone number calls, or in the history or voicemail.

How can I get the Zoom Phone Appliance app on the Yealink MP56 phone display the contact names on income calls, history, and voicemails?

The firmware of the MP56 is 122.30.0.45 and the Zoom version is 6.0.0.652.

2 REPLIES 2

mike_h
Listener

Still troubleshooting this. I tried adding the phone number of a missed call to an existing cloud contact on the Zoom Phone Appliance. That still would not make the contact name show instead of the phone number/caller ID. For the caller ID it's just showing "WIRELESS CALLER".

 

Then I tried creating a new "Personal Contact" with that missed call phone number right in the Zoom Phone Appliance, and it still won't show the contact name. This should be showing the contact name for incoming calls, history, and voicemail. This is basic functionality of modern phone apps and I'm baffled at why this isn't working.

mike_h
Listener

I just figured something out. If, on the web, I go to Phone System Management – Company Info – Account Settings – External Contacts and add a contact there the contact name will show on the ZPA. I think the ZPA should pull the contact name from the Cloud Contacts also, but in the meantime this could be a solution. How can I get the Google contacts to sync to the External Contacts instead of Cloud Contacts?